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UNDERSTANDING COURSE GUIDE  

Refer and understand this Course Guide carefully from the beginning to 

the end. It describes the course and how you use the course material. 

It suggests the learning time to complete the course successfully. 

Referring the Course Guide will help you to clarify important contents 

that you might miss or overlook. 

 

ABOUT THE COURSE 

TCIT 1013 Introduction to Computer System is subject for Diploma 

Information Technology that offered by School of Engineering and 

Computing Technology in ICYM. This course is worth 3 credit hours and 

should be covered to 14 weeks 

 

You should be acquainted with learning independently and being able to 

optimize the learning modes and environment available to you. Make sure 

refer right course material and understand the course requirements as 

well as how the course is conducted. 

LEARNING TIME SCHEDULE 

It is a standard ICYM practice that learner accumulate 40 study hours for 

every credit hour. As for this three-credit hour course, you are expected 

to spend 120 study hours. Table 1 gives an estimation of how the 120 

study hours could be accumulated. 
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Table 1: Estimation of Student Learning Time 

Distribution of 

Student Learning 

Time by Chapter 

CLO 

Teaching and Learning Activities 

Face to Face Non-Face to 

Face 

(Independent 

Learning) 

Total 
L T P O 

Topic 1 1     6 

 

Topic 2 1     6 

Topic 3 1     6 

Topic 4 1     6 

Topic 5 1     6 

Topic 6 1     6 

Topic 7 1     6 

Topic 8 2     8 

Topic 9 3     10 

Topic 10 3     10 

Topic 11 3     10 

Topic 12 3     10 

Sub-Total SLT 90 

Continuous Assessment % 

Face to Face Non-Face to 

Face 

(Independent 

Learning) 
 

Physical Online 

1 Quiz 5  1 2 

2 Participations  15   4 

3 Test 15  2 4 

4 Assignment 15   9 

Sub-Total SLT 22 

Final Assessment % 

Face to Face Non-Face to 

Face 

(Independent 

Learning) 

 Physical Online 

1 Final Examination 50 2.5  5.5 

Sub-Total SLT 8 

GRAND-Total SLT 120 
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COURSE LEARNING OUTCOME 

By the end of this course, you should be able to: 

1. Define today's technology theories and concepts (C1, PLO1) 

2. Describe digital security, ethics and privacy (C2, PLO2) 

3. Construct documents, spreadsheet, slides presentation and database on 

an assignment task using Microsoft Office Suite (C3A, PLO3) 

 

COURSE SYNOPSIS 
 

This course is divided into 10 topics. The synopsis for each topic can 

be listed as follows: 

 

Topic 1 students will learns the basic computer concepts, such as what a 

computer is, how it works, and what makes it a powerful tool 

 

Topic 2 students will learns  about the Internet, World Wide Web, browsers, 

e-mail, FTP, and instant messaging. 

 

Topic 3 students are introduced to a variety of business software, graphics 

and multimedia software, home/personal/educational software, and 

communications software. 

 

Topic 4 students are introduced to the components of the system unit; how 

memory stores data, instructions, and information; and how the system 

unit executes an instruction. 

 

Topic 5 students will learns describes the various methods of input and 

output, and commonly used input and output devices 
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Topic 6 students will learns about various storage media and storage 

devices 

 

Topic 7 students learn about a variety of stand-alone operating systems, 

network operating systems, and embedded operating systems. 

 

Topic 8 students will learns about computer and Internet risks, ethical 

issues surrounding information accuracy, intellectual property rights, codes 

of conduct, information privacy, and computer-related health issues. 

 

Topic 9 students learn how to create document using Microsoft Word to 

construct letter, article, simple poster, and memo. 

 

Topic 10 students learn how to create presentation slide using Microsoft 

PowerPoint 

Topic 11 students learn how to create a simple data analysis using 

Microsoft Excel 

Topic 12 students learn how to create database using Microsoft 

Access  

 

 

LEARNING GUIDANCE 

The learning guidance is important to understand before you go through 

this module. Understanding the learning guidance will help you to organize 

your study of this course in a more objective and effective way. Generally, 

learning guidance for each topic is as follows: 

 

Learning Outcomes: This part is to measurable, observable, and specific 



 

 

 

x 

statement that clearly indicates what you should know and be able to do 

because of learning in each chapter. By go through each topic, you can 

continuously gauge your understanding of the topic. 

 

Self-Learning Material:  To aid you in your subsequent learning and to 

report on what you have learned. The activities are in-text questions (ITO) 

and self-assessment questions (SAQ), assignment on each chapter of the 

material to monitor and develop your own learning. 

 

Activity: Question and activity within module can be constructed to put 

back the dialogue between student and module in learning activity. With 

the given question or task, you are encouraged to read the description 

or explanation within a module, so you can answer the question or solve 

the problem proposed.  

 

You are encouraged to read since you realize that without reading the 

description or explanation, you will not be able to answer the question 

or the assignment. Text question is applied to you to pay attention to a 

certain problem rather than to assess the learning progress. 

 

Self-assessment question is such a task that requires written answer 

form you. If you complete the task, you are asking to check your answer 

with the answer key provided in the module. 

 

Self -assessment is be developed in various form of test questions, there 

are easy question, fill in the blank, multiple choices, true-false and 

matching. 

 

Summary: You will find this part at the end of each topic. This 

component helps you to recap the whole topic. By going through the 



 

 

 

xi 

summary, you should be able to gauge your knowledge retention level. 

Should you find points in the summary that you do not fully understand, 

it would be a good idea for you to revisit the details in the module. 

 

Key Terms: This component can be found at the end of each topic. You 

should go through this component to remind yourself of important terms 

or jargon used throughout the module. Should you find terms here that 

you are not able to explain, you should look for the terms in the module. 

 
 

References: The References section is where a list of relevant and 

useful textbooks, journals, articles, electronic contents, or sources can 

be found. The list can appear in a few locations such as in the Course 

Guide (at the References section), at the end of every topic or at the back 

of the module. You are encouraged to read or refer to the suggested 

sources to obtain the additional information needed and to enhance your 

overall understanding of the course. 
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Nowadays, many people use computer in daily life. They use it to 

communicate, information searching, doing personal task to increase their 

productivity and helps them in their daily routine.  

 

Computer literacy is about having knowledge on how to use computer. 

 

Figure 1.1 shows the relationship of digital literacy and human activities. 

Many aspects of digital computer use have affected human life today. 

Among them are functional skills in improving quality of life, stimulating 

creativity, enabling people to think critically and make evaluation more 

easily. Cultural issues are also affected by this digital exposure where more 

people can understand the culture of a race that was previously ignored. 

 

The ability to quickly and accurately search for information can preside over 

the quality of human life. Communication has also become more effective 

with the use of technology that enables humans to collaborate in conducting 

matters. However, safety aspects must also be taken into account to ensure 

 

By the end of topic, you should be able to: 

 
Recognize the importance of computer literacy 

Identify the components of a computer 

Differentiate Data and Information 

Discuss the uses of the Internet and World Wide Web 

Explain the advantages and disadvantages of a computer 

 

LEARNING OUTCOMES 

TOPIC 

1 

Introduction to Computer System  

 

 1.1 Computer Literacy 
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that human life remains peaceful in line with the natural nature of human 

life. 

 

Figure 1.1 : Digital Literacy 

 

 

 

 

 

Computer is a device that operates under the instruction given. These 

instructions are stored in its own memory and can be modified at anytime. 

Computer receives data and instructions, process it and produce the result.  

 

 

 

This Photo is licensed under CC BY 

 1.2 Definition Of Computer  

 

https://wisehouseeducation.blogspot.com/2019/02/pendataan-literasi-digital-kelas-5-sdn.html
https://creativecommons.org/licenses/by/3.0/
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Figure 1.2 : The flow of computer processing 

 

Figure 1.2 shows that input will be processed in such a way that the output 

can be used by human. 

 

 

 

 

Computer process data to produce an information. Data can be text such 

as names, address, or any other details or, number such as age, price or 

picture, video or even sound. Data can be entered into the computer and 

computer will process it and display the data in an organized layout that 

we called information. 

 

Figure 1.3 show the relationship of how data can be turn into information. 

Data is a single input, whereas information is the combined of some data 

that gives a meaningfull intepretation to it. 

 

Figure 1.3 : Data vs Information 

 

 

Input Process Output

Data

Muhammad

20

Melaka

Information

Muhammad is 20 
years old and living 
in Melaka

 1.3 Data and Information  
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Components of a computer is any devices that can be connected to form 

the functional computer. Common components are; 

a. Input device –used to enter data or instruction into computer 

b. Output device –used to display the result of computer process  

c. Processor – process data into information 

d. Storage  - to hold data and information 

e. Communication device – device that conveys data across computer 

 

Figure 1.4 shows the components of computer. It can be any devices that 

connected into system unit to make it functional. 

 

Figure 1.4 : The components of computer 

 

 

This Photo is licensed under CC BY-SA-NC 

 1.4 Components of Computer  

 

http://tic-cbtis111.blogspot.com/2011/11/elementos-del-hardware.html
https://creativecommons.org/licenses/by-nc-sa/3.0/


 

 

 

5 

 

 

 

 

The use of computer can give several effects into human life. It can be 

beneficial if used correctly. It can also have a detrimental effect if not used 

properly. 

 

The advantages  

 

Speed: When data, instructions, and information flow along electronic 

circuits in a computer, they travel at incredibly fast speeds. Many 

computers process billions or trillions of operations in a single second. 

 

Reliability: The electronic components in modern computers are 

dependable and reliable because they rarely break or fail. 

 

Consistency: Given the same input and processes, a computer will 

produce the same results — consistently. Computers generate error-free 

results, provided the input is correct and the instructions work. 

 

Storage: Computers store enormous amounts of data and make this data 

available for processing anytime it is needed. 

 

Communications: Most computers today can communicate with other 

computers, often wirelessly. Computers allow users to communicate with 

one another. 

 

 

 

 

 1.5 
Disadvantages And Advantages Of 

Computer 
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The disadvantages 

 

Violation of Privacy: Personal and confidential records were not properly 

protected may affected individuals in protecting their privacy violated and 

identities stolen.  

 

Public Safety: Some information that people shared may be used by other 

people that can do harm to others. 

 

Impact on Labor Force: People can be jobless since computers can 

replaced human labor in many sectors. 

 

Health Risks: Prolonged or improper computer use can lead to health 

injuries or disorders.  

 

Impact on Environment: Computer manufacturing processes and 

computer waste are depleting natural resources and polluting the 

environment.  

 

 

 

 

A network is a collection of computers and devices connected together, 

often wirelessly, via communications devices and transmission media 

(Figure 1.5). When a computer connects to a network, it is online.  

 

Networks allow computers to share resources, such as hardware, software, 

data, and information. Sharing resources saves time and money.  

 

 1.6 
Definition Of Network And Advantages 

Of Network 
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Figure 1.5 : Computer Network.  

 

 

 

 

 

The Internet is a worldwide collection of networks that connects millions of 

businesses, government agencies, educational institutions, and individuals. 

 

Figure 1.6 shows that several network connected together to form the 

Internet. 

 

 1.7 
The Uses Of The Internet And World 

Wide Web 
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 Figure 1.6 : The flow of computer processing 

 

 

Short Questions 

1. What are some ways people use computers in the home, at work, and 

at school? _______  

2. What does it mean to be computer literate? _______ 

3. In what ways do people use the Internet to communicate with each 

other?  

4. How do computers benefit individuals’ health care? _______  

This Photo is licensed under CC BY 

 

 

 

 

 

Instructions: Find the true statement below. Then, rewrite the remaining 
false statements so they are true. 
1. A personal computer contains a processor, memory, and one or more 

input, output, and storage devices. 
2. A network is a collection of computers and devices connected together, 

often wirelessly, via communications devices and transmission media.  

Checkpoint  

http://writing-the-wrongs.blogspot.com/2010_04_01_archive.html
https://creativecommons.org/licenses/by/3.0/
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5. How can telemedicine benefit health care? _______ 

6. Explain FIVE (5) components of a Computer 

7. Explain the advantages of using Computers  

8. Explain the disadvantages of using Computers 

 

 

 

 

 

 

 

 

 

Self Assessment 

Login to Elearning to do Self Assessment1 

 

 

 

 

 

 

 

 

 

 

 

• Technology and interactive media are learning tools that are able to 

support childrens education, growth and relationship. 

• Computers cause challnes in social , emotional and languages 

development. 

• Computers encourage us to think effectively 

• Technology and interactive media are learning tools that are able to 

support childrens education, growth and relationship. 

SUMMARY 

 

 

 

 

 

 

                                     

Among the advantages of using computers is speed, reliability, 

consistency, storage, and communications.  

Explain why you use computer/mobile device in your daily life in 

terms of the above advantages. 
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 KEY TERM 

Computer Network 

Data Information 

Memory Component  
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The Internet has its roots in a networking project started by an agency of 

the U.S. Department of Defense. That network, called ARPANET, became 

functional in September 1969, linking scientific and academic researchers 

across the United States 

 

 
 

Figure 2.1 : Arpanet Goals 

Allowed scientists at different locations 
to share information and work together 

on military and scientific projects

Could function even if part of the 
network were disabled or destroyed by a 

disaster such as a nuclear attack. 

 

By the end of topic, you should be able to: 

1. Explain how to access and connect to the Internet 

2. Explain how to view pages and search for information on the 
Web 

3. Describe the types of Web sites Identify the steps required 

for Web publishing 
4. Describe the types of e-commerce  

5. Explain how e-mail, FTP, newsgroups and message boards, 
mailing lists, chat rooms, instant messaging, and Internet 
telephony work 

7. Identify the rules of netiquette 

LEARNING OUTCOMES 

TOPIC 

2 

 

The Internet and World Wide Web 

 2.1 The Evolution Of The Internet 
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Data sent over the Internet travels via networks and communications 

media owned and operated by many companies. Connecting to the 

Internet, employees and students often connect to the Internet through a 

business or school network. 

 
Connection Description 

DSL  
(digital subscriber line) 

Technology that provides high-speed Internet 
connections using regular telephone lines. A cable 

modem allows access to high-speed Internet 
services through the cable television network. 

Wi-Fi 

(wireless fidelity) 

A network uses radio signals to provide Internet 

connections to wireless computers and devices.  

Mobile broadband Connections over the cellular radio network 

Fixed wireless Using a dish shape antenna for use in a house or 
business using radio signals 

Satellite modem A communicates with a satellite dish to provide 
high-speed Internet connections via satellite. 
 

 

 

 

 

 

Users access the Internet through ISPs, online service providers, and 

wireless Internet service providers.  

 

An ISP (Internet service provider) is company that provides Internet 

access to their customers. 

 

 2.2 Internet Connections  

 

 2.3 Internet Service Providers 
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In Malaysia, there are many companies that provides Internet services to 

its customer. Among the popular company for home users are TM, Astro 

Broadband,  and YES. For mobile users, ALL cellular companies provides 

data connections for its users.  

 

 

Figure 2.2 : TM Unifi and Streamyx 

 

 

Figure 2.3 : yes Internet Provides 

 

This Photo by Unknown Author is licensed under CC BY 

This Photo by Unknown Author is licensed under CC BY-SA 

http://relakssminda.blogspot.com/2014/11/gangguan-prestasi-tm-unifi-dan-streamyx.html
https://creativecommons.org/licenses/by/3.0/
https://www.malaysianwireless.com/2011/03/yes4g-lost-subscribers-targets-14-million/yes4g-logo/
https://creativecommons.org/licenses/by-sa/3.0/
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The Internet relies on an addressing system much like the postal service to 

send data to a computer at a specific destination.  

 

An IP address, short for Internet Protocol address, is a number that 

uniquely identifies each computer or device connected to the Internet.  

 

A domain name is the text version of an IP address. 

 

As with an IP address, the components of a domain name are separated by 

periods. 

 

A DNS server translates the domain name into its associated IP address 

 

Example : IP address for www.kym.edu.my is 10.100.4.250 

 

Given an IP number, we are able to know its location. 

 

 

 

 

A Web browser, or browser, is application software that allows users to 

access and view Web pages. To browse the Web, you need a computer that 

is connected to the Internet and that has a Web browser. The browser 

retrieves and displays a starting Web page, sometimes called the browser’s 

home page.  

 

 2.4 IP Address And Domain Name 

 

 2.5 Web Browser 

 

http://www.kym.edu.my/
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Home page, refers to the first page that a Web site displays. Similar to a 

book cover or a table of contents for a Web site, the home page provides 

information about the Web site’s purpose and content.  

 

Downloading is the process of a computer receiving information, such as 

a Web page, from a server on the Internet. 

 

Web Addresses A Web page has a unique address, which is called a URL 

(Uniform Resource Locator) or Web address.  

 

 

 

Figure 2.4 : The popular web Browser 

 

 

 

 

A search engine is particularly helpful in locating Web pages about certain 

topics or in locating specific Web pages, images, videos, news, and other 

information for which you do not know the exact Web address.  

 

Instead of clicking through links, search engines require that you enter a 

word or phrase, called search text, that define the item about which you 

want information.  

 

This Photo is licensed under CC BY-SA 

 2.6 Search Engine 

 

http://mathematica.stackexchange.com/questions/44099/web-browser-screen-shot
https://creativecommons.org/licenses/by-sa/3.0/
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Figure 2.5 : Google 

 

 
 

 
Figure 2.6 : Bing Search Engine 

 
 

This Photo is licensed under CC BY 

This Photo by Unknown Author is licensed under CC BY-SA-NC 

http://www.weblancexperts.com/search-engine-optimization-services/
https://creativecommons.org/licenses/by/3.0/
https://softmetal.wordpress.com/2009/06/03/visita-bing-beta/
https://creativecommons.org/licenses/by-nc-sa/3.0/
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Figure 2.6 : Search Hit 

 
 

 

 

SHORT QUESTIONS 

 

1. How is a regional ISP different from a national ISP? __________  

2. How are an ISP, OSP, and WISP different? __________ 

3. How is a Web page different from a Web site? __________  

  

 

 

 

 

 

Instructions: Find the true statement below. Then, rewrite the 
remaining false statements so they are true. 
1. DSL is a technology that provides high-speed Internet connections 

over the cable television network.  
2. A domain name is the text version of an IP address.  

3. A Web 2.0 Web site may include application software built into the 
site for visitors to use.  

4. Tabbed browsing refers to the practice of Web sites keeping tabs 

on their visitors.  
5. A search engine is a program that finds Web sites, Web pages, 

images, videos, news, and other information.  
 

Checkpoint 2 
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4. How can you use a Web address to display a Web page? __________ 

5. What are the differences between blogs, wikis, and podcasts? 

_________  

6. When might you use each? _________ 

7. What is one specification used by content aggregators to distribute 

content? _________  

8. How might you evaluate the accuracy of a Web site? _________ 

9. When might you use an online payment system? ________  

10. How does the service work? ________ 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• Internet are widely used nowadays 

• Need to connect to internet to enable us to use browser to search for 

information 

• DSL, WIFI, satellite dish is among the popular way to connect to 

Internet 

SUMMARY 

 

 

 

 

                                    
Describe how you connect the Internet by using your handphone. Do 

you need to pay for it? 

 
 ACTIVITY 
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 KEY TERM 

Internet Network 

Browser Internet service provider 

Wifi Search engine 

Ip Domain 
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Most computer users rely on task -oriented software or better known as 

application software. Therefore, such software can be classified according 

to the function of the software.  

 

Application software is available in various forms of software, namely: 

 

Package. This software is usually produced in large quantities, protected 

by copyright, produced to meet the needs of users either for individual or 

organizational use widely. A good example of this type is Ms Office. 

 

Custom. There are some companies that hire computer programmers 

solely to produce software that meets their needs. This software is only 

used for the use of certain companies only. 

 

Shareware. Software like this is commonly found on the internet, available 

for free can be used in certain usually within 30 days. To use it after 30 

 

By the end of topic, you should be able to: 

1. Explain application software 
2. List types of application software 

3. Explain System Software 
4. List types of system software 

 

LEARNING OUTCOMES 

TOPIC 

3 

 

Software 

 3.1 Application Software  
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days payment must be made to the company or individual who developed 

it. 

 

Freeware. Software like this is commonly found on the internet, anyone 

can use it without time limit. It is protected by copyright so users cannot 

sell this software for profit. 

 

Public domain. This software is free from copyright can be used without 

error. Usually, this software has been donated by its maker for anyone to 

use without limit. 

 

Software Categories. 

There are many categories of software that can be found in the market. 

This software is used to helps user to complete their task in many ways. 

These categories are. 

Business software. Business software is application software used to help 

users to be more efficient and effective in carrying out daily business tasks. 

Business software includes Word processing, Data spreadsheets Graphic 

presentation databases, PIM, PDA business software, package software, 

project management software and accounting.  

Software Function  

Word Processing  The most widely used and widely used software. This 
software allows tasks such as editing, formatting, saving, 

and printing text to be done easily.  
 
Features of this software 

Change the shape, type, size and colour of the text. 
Produce and organize documents into specific layouts 

such as newspapers. 
Ability to combine images, graphics, clip art or 
photographs. 

Ability to identify spelling errors 
Ability to determine document size  
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Spreadsheets Used to manage and analyse data such as examination 

score data, finance, name list etc. In a spreadsheet, data 
is filled in the form of rows and columns known as 
worksheets. Complete data can be analysed easily such 

as counting numbers, arranging names in alphabetical 
order. With it you can also visualize data in the form of 

bar charts, pies etc. 

Presentation This software is used to show charts, maps or graphics 

as a viewing or presentation. By using an LCD or 
projector on -screen content can be displayed on the 
screen for public viewing.  

Note taking This software allows users to insert handwriting, 
drawings or sketches on any part of the page screen and 

save and become part of the document.  

Software Suite A collection of application software sold in packages. 

When the user installs this software, the entire package 
will be installed in the user's computer. The advantage of 

packaged software is that it costs less than buying the 
software individually. 

Project 
Management  

This software allows users to plan, identify, analyse 
everything that happens in a project including costs, 
available resources, and time of a project.  

Accounting Software used by a company to assist the company in in 
financial activities such as recording, financial reporting, 

this buying and selling journey allows a complete 
financial report for the use of company managers. 

 

Graphics And Multimedia Software. This software is commonly used by 

users involved in the fields of engineering, architecture, publishing, and 

graphic design.  

 
Software Function  

Computer Aided 

Design 

This software helps users such as engineers to design 

tools before the actual tools are produced. For architects, 
this software helps to design building plans in terms of 

site structure and overall building. For scientists this 
software helps to design the shape of the molecular 
structure.  

Desktop 
Publishing 

Allows users to design and produce high quality 
documents containing text, graphics, colour etc. as in 

magazines or newspaper publications.  

Image Editing Graphic artists, multimedia developers, magazine 

publishers use this software to modify graphic images for 
use in their products. The software allows users to draw, 

create objects assisted by tools such as pens, pencils, 
and brushes digitally. 
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Video And Audio 

Editing 

Software allows users to modify video segments into 

video clips. For example, the video can have subtitles 
added, cut out whichever is not needed, and take only a 
few excerpts. Examples of audio editing software such as 

adobe premiere. 
 

Audio editing software allows users to modify audio 
segments into audio clips. These modifications such as 
removal of background noise, removal of background 

noise during recording, and modifying the audio tempo 
from short tones to long tones. Examples of audio editing 

software such as sound forge. 

Multimedia 

Authoring 

Multimedia developer software is application software 

that can integrate all multimedia elements in one 
package. These multimedia elements include text, 
graphics, audio, video, and animation. With this the 

software works to produce an application that contains 
these elements. Examples of multimedia developer 

software include Director, Authorware. The examples of 
applications developed using multimedia developer 
software are game applications, children's learning 

applications and let's cook applications. 

Web Page 
Authoring  

Website developer software helps users develop 
websites. This software allows all multimedia elements to 

be included on the website. Users are allowed to enter, 
maintain, and update the website.  

 

 

 
Figure 3.1 : Desktop Publishing Software 

This Photo is licensed under CC BY-SA 
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Figure 3.2 : Image Editing Software 

 

 
Figure 3.3 : Video Editing Software 

 
 

 

This Photo is licensed under CC BY-NC 

This Photo is licensed under CC BY 
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Individual user software, home, and education  
 

Most computer users are so dependent on software that is 'task oriented' 

or better known as application software. 

 
Software Function  

Software Suite This software is a collection of application software sold 
in packages. When the user installs this software, the 

entire package will be installed in the user's computer. 
Examples are Microsoft office. The advantage of 

packaged software is that it costs less than buying the 
software individually. 

Personal 
Accounting 
Software 

The software used by the company to assist the 
company in in financial activities such as recording, 
financial reporting, buying, and selling journey allows a 

complete financial report for the use of company 
managers. 

Image Editing The software allows users to draw, create objects 
assisted by tools such as pens, pencils, and brushes 

digitally. 

Education And 

Reference  

Educational and reference software is software that 

provides instruction to users on how to do something. 
For example, the Learn to Cook software teaches users 
how to cook. 

Entertainment Entertainment software is software that provides 
entertainment to users such as game software, 

software that supports hobbies and video. 

Communication Software that enables user to communicate with other 

people around the world. Example is media social 
application such as Facebook, Instagram, and Forum.  
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Figure 3.4 : Microsoft Office Software 

 

 

 

 

 

To enable application software to be implemented we need a type of 

software called system software. The system software acts as an agent 

that allows communication between users, applications, and computer 

hardware to take place. The system software consists of programs referred 

to as operating systems. 

 

What Is System Software? 

System software is defined as all programs including operating systems 

whose function is to control all operations of hardware computer. Among 

the functions of system software are: 

✓ Control when starting a computer system 

✓ Loading and executing application software 

✓ Store and receive files or information 

This Photo is licensed under CC BY-NC-ND 

 3.2 Operating system and utility program 
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Operating System.  

Operating System is a program/software that functions to control all 

operations that take place in a computer and acts as an interface between 

users, application software and computer hardware. A computer will not 

operate without this OS. 

  

The Operating System is stored in the user's hard disk, every time we start 

the computer the Operating System will be transferred and brought from 

the hard disk into the computer's memory until all important programs are 

completed. This process is called loading. 

  

 One of the important features in which Operating System provide is the 

user interface, where this interface serves to determine how users and 

computers interact. The interface also controls how we enter data, 

commands and how information is displayed on a computer screen.  
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     Figure 3.5 : Operating System Role 

 

Program Utilities.  

This type of software that are installed on an Operating System and have 

a function that is specific to a task. 

 

Type Description 

File Conversion 
 

When a user uses application software, this software will 
name the file with one name and have a specific symbol 
such as MS Word using the name .doc on each named 

file. With the conversion file we can read the typed 
document without using Ms Word or other word 

processing software. 

This Photo is licensed under CC BY-SA 
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Backup Software 

 

Allows us to re -copy important programs in storage such 

as disk cartridges or other secondary storage devices. 

Diagnostic 

 

Allows a computer system to maintain its performance in 

both software and hardware. A faulty system can be 
easily detected. 

Antivirus Antivirus programs are very important to prevent 
computers from being infected with computer viruses that 
can damage the entire computer system. 

 

   

 

 

 

 

 

 

 

 

FILL IN THE BLANKS 

 

1. A ________________________, consists of a series of related 

instructions, organized for a common purpose, that tells the computer 

what tasks to perform and how to perform them 

2. An ________________________, consists of programs designed 

to make users more productive and/or assist them with personal tasks 

 

 

 

 

 

 

 

Instructions: Find the true statement below. Then, rewrite the 
remaining false statements so they are true. 

1. Application software serves as the interface between the user, the 
apps, and the computers or mobile device’s hardware.  

2. While a computer or mobile device is running, the operating system 
remains in memory.  

3. When downloading shareware, freeware, or public-domain 

software, it is good practice to seek websites with ratings for and 
reviews of products.  

4. With database software, users run functions to retrieve data. 

 

 

 

 

                                    

Explain software that you use every day to facilitate your daily life. 

 
 ACTIVITY 

Checkpoint  
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3. An ________________________ is a set of programs that 

coordinates all the activities among computer or mobile device 

hardware 

4. ________________________ applications can assist you in 

becoming more effective and efficient while performing daily activities 

at work, school, and home 

5. ________________________ software allows users to create and 

manipulate documents 

6. ________________________ is a collection of drawings, photos, 

and other images  

7. ________________________ software allows users to create 

visual aids for presentations to communicate ideas, messages, and 

other information to a group  

8. ________________________ software allows users to organize 

data in rows and columns and perform calculations  

9. A ________________________ is a collection of data organized in 

a manner that allows access, retrieval, and use of that data 

10. A ________________________ is a collection of individual 

programs available together as a unit 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This chapter presented a variety of programs and apps available for 

computers and mobile devices. You learned about the role of the operating 

system and the various ways software is distributed. The chapter presented 

the features of a variety of productivity applications, graphics and media 

applications, and personal interest applications.  

SUMMARY 
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 KEY TERM 

Application Program 

Operating system Utilities 

Antivirus software 

blog execute 

desktop computer application software 
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Input refers to the process of entering data, programs, commands, and 

user actions into computer memory. There are 4 types of inputs used by 

computers, namely: 

  

Data: refers to raw data such as numbers, words, images or sounds 

received by a computer from an input device and processed to produce 

information. 

 

Program: all the instructions that instruct the computer to perform an 

operation and then process the data into information. 

 

Command: is a keyword or phrase for input that directs the computer to 

perform an activity such as using a mouse or keyboard or other types of 

input tools. 

 

User Response: refers to the data entered by the user because of the 

response by the example software as below: 

  

 

By the end of topic, you should be able to: 

1. Explain input and its device 
2. Explain output and its device 

 

LEARNING OUTCOMES 

TOPIC 

4 

 

Input and Output 

 4.1 What is Input? 
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Input device is any tools that have been used to enter data or instruction 

into the computer. There are many types of input device in variation of the 

way how it is used. 

  

Keyboard is the most used input tool. Using the keyboard, input is entered 

by pressing keys on the keyboard. 

  

 
Figure 4.1 : Keyboard 

  

 

Pointing Devices allow users to control symbols/icons on the computer 

screen. The Pointer Tool is also known as a mouse pointer. We also use 

pointing tools to select text, images or move objects on the screen and 

start a program. 

  

Mouse 

A palm -sized pointer is used to control the movement of the cursor on the 

screen. Mouse is usually placed on a flat surface or use a mouse pad (mouse 

pad).  

This Photo is licensed under CC BY-SA-NC 

 4.2 Input Device 
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 Figure 4.2 : Mouse 

 

 

Touchpad  

The touchpad is a flat square surface, which detects the movement of a 

fingertip on its surface to control the movement of the cursor on the screen. 

Touch pads are usually only found on a laptop because of their space -

saving nature. 

  

 

 Figure 4.3 : Touch pad 

 

 
 

 

This Photo is licensed under CC BY-NC 
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https://creativecommons.org/licenses/by-nc-sa/3.0/


 

 

 

35 

Joystick 

A common input device used for computer games only. Joysticks are 

essential for vertical and horizontal movement and there are buttons that 

can be pressed on this gadget. 

 

 
 Figure 4.4 : Joystick 

 

Pen Input 

Pen like stick that can be used write on the surface of the smartphone or 

tablet.  

 

 
 Figure 4.5 : Pen Input 

 

This Photo is licensed under CC BY-NC 
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Touch Screen 

This tool allows the user to touch the surface of the screen to enter data or 

make selections from the provided icons.  

 

 
 Figure 4.6 : Touch Screen 

 

Scanner  

A scanner is an input device that electronically scans text or images and is 

inserted into a computer. The scanner converts the original text or image 

into a form of digital data that will be stored on the hard disk and processed 

in the computer. To scan the text, the scanner uses a technology called 

OCR (Optical Character Recognition) along with OCR software to scan the 

text in hardcopy to softcopy. 

 

This Photo is licensed under CC BY-SA 
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 Figure 4.7 : Scanner 

 
  

Sound Input/Voice Input 

It is usually recorded using a microphone connected to a sound card or a 

musical instrument such as an electronic music keyboard to a sound card. 

Sound editing software is used to change the sound. 

 

 
  

 Figure 4.8 : Voice input 

 
 

 

Digital Camera. 

Digital camera stores the image taken in a memory in digital form. This 

image can be used in a computer for display, or editing. 

This Photo is licensed under CC BY-NC 
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 Figure 4.9 : Digital Camera 

 

 
 

Digital Camcorder. 

Digital camcorder records video in digital form. The video can be edit using 

video editing software. 

  

 
 Figure 4.10 : Digital Camcorder 

 
  

  

 

 

This Photo is licensed under CC BY-NC-ND 

This Photo is licensed under CC BY-SA 
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Output refers to data that has been processed into a useful form called 

information, it can be used by computers or users. 

  

Output can be in two forms, that is printed version or on the screen. The 

printed output is called hard copy, while the output displayed on the 

screen is called soft copy. Audio and video are also output. 

 

 

 
  

Audio Output 

Consists of sound including words or music generated by a computer. 

Speakers are audio output devices especially for multimedia computers. 

 

 
  Figure 4.11 : Speaker 

 

This Photo is licensed under CC BY-SA 

 4.3 What is Output? 

 

 4.4 Output Device 

 

https://jv.wikipedia.org/wiki/Speaker
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Monitor 

A display surface called a screen, and the internal electronic part is 

protected by plastic on the outside.  

 

 
  

 Figure 4.12 : Monitor 

 

 

Flat panel display  

A thin display device and does not use CRT technology.   

  

Resolution 

Resolution (intensity) can be said to be the ability of a monitor to display 

the highest image quality that can be achieved by the monitor. This 

resolution depends on the type of video adapter card and the capabilities 

of the monitor itself. 

    

 

 

 

This Photo is licensed under CC BY-NC 
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Printer 

The printer allows all output in softcopy form to be transferred to form 

hardcopy. Generally, printers can be divided into 2: 

1. Impact 

2. Nonimpact 

 

This classification is based on how the printer transfers characters to the 
printing paper. 

 
 

  

Impact Printer 

This type of printer transfers the image onto paper using a typewriter -like 

mechanism, where paper, ink ribbons and tapers encounter each other to 

produce an alphabet. 

 

Dot Matrix 

Printer This printer produces an image by tapping a pin on an inked ribbon. 

The printer head consists of tubes containing pins which when pressed onto 

ribbon and paper, small dots will form. The combination of these small dots 

produces a character. Dot matrix printers usually have a different number 

of pins such as 9 pins or 24 pins, the higher the number of pins the better 

the print quality. 

 

Non-impact Printer 

Nonimpact printers because the printing process takes place without any 

contact mechanism on the printing medium. Examples of this type of 

printer: 

 

Injet.  

This printer works by spraying ink on the printing medium. Paint quality is 

usually determined based on dpi (dot per inch) which is how much spray to 

produce dots in one square inch. 
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 Figure 4.13 : Dot matrix 

 
  

  

 

 
 Figure 4.13 : InkJet 

  
 

 

 

This Photo is licensed under CC BY-SA-NC 
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Laser.  

Printer This printer acts like a photocopier where the laser radiation is 

converted into different charge forms and the charged toner (ink) is 

transferred to the printing medium. 

 

 
 Figure 4.14 : Laser Printer 

 

 

Therma printer.  

This type of printer uses heated coloured wax and the resulting combination 

of the heated wax is transferred to the printing medium. 

 

 
 Figure 4.15 : Thermal Printer 

This Photo is licensed under CC BY-NC 
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Plotter.  

A non-impact printer used to draw lines as in building plans and engineering 

designs. 

  

 
 Figure 4.16 : Plotter 

 
  

  
  

  

  

  

  

 
 

 
 

 
 

 
 

This Photo is licensed under CC BY-SA-NC 
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Short Questions 

1. What is input?  
2. List FOUR (4) types of input by users. 

3. Give examples of input types of pointing devices (pointing devices) 
4. What does the output say? 

5. Give an example of an output tool. 
6. How do impact and nonimpact printers differ? Give examples of 

printers for both types of printers. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

Instructions: Find the true statement below. Then, rewrite the 

remaining false statements so they are true. 
1. On notebook and some handheld computers, PDAs, and smart 

phones, the keyboard is built in the top of the system unit. 

2. An air mouse is a newer type of motion-sensing mouse that allows 
you to control objects, media players, and slide shows by moving 

the mouse in predetermined directions through the air.  
3. Resolution is the number of horizontal and vertical pixels in a 

display device.  

 

• Technology and interactive media are learning tools that are able to 

support childrens education, growth and relationship. 

• Computers cause challnes in social , emotional and languages 

development. 

• Computers encourage childreen to think effectively 

• Technology and interactive media are learning tools that are able to 

support childrens education, growth and relationship. 

SUMMARY 

 

 

 

 

                                    

Explain the most common input device that you used every day. 

 
 ACTIVITY 

Checkpoint 4 
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 KEY TERM 

Input Output 

Mouse Keyboard 
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The system unit is a case that contains electronic components of the 

computer used to process data. System units are available in a variety of 

shapes and sizes. The case of the system unit is made of metal or plastic 

and protects the internal electronic components from damage. All 

computers have a system unit (Figure 5.1).  

 

 
Figure 5.1 : System Unit 

 

This Photo is licensed under CC BY 

 

By the end of topic, you should be able to: 

1. Describe the components in system unit 

2. Define processor 
3. Explain the function of a bus 
4. Explain the purpose of a power supply and batteries 

 

LEARNING OUTCOMES 

TOPIC 

5 

 

Components of System Unit 

 5.1 The system unit 
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System unit have a variety of components inside it. Some of these 

components, which include the processor, memory, adapter cards, drive 

bays, and the power supply.  

 

The processor interprets and carries out the basic instructions that operate 

a computer.  

 

 
Figure 5.2 : Processor 

 

 

Memory typically holds data waiting to be processed and instructions 

waiting to be executed.  

 

This Photo is licensed under CC BY 
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Figure 5.3 :Memory 

 

 

The electronic components and circuitry of the system unit, such as the 

processor and memory, usually are part of or are connected to a circuit 

board called the motherboard.  

Many motherboards also integrate sound, video, modem, and networking 

capabilities. 

 

The motherboard, sometimes called a system board, is the main circuit 

board of the system unit. Many electronic components attach to the 

motherboard; others are built into it.  

 

This Photo  is licensed under CC BY 
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Figure 5.4 :Motherboard 

 

 

 

 

 

The processor, also called the central processing unit (CPU), interprets and 

carries out the basic instructions that operate a computer. The processor 

significantly impacts overall computing power and manages most of a 

computer’s operations. On a personal computer, all functions of the 

processor usually are on a single chip. Some computer and chip 

manufacturers use the term microprocessor to refer to a personal computer 

processor chip.  

 

This Photo is licensed under CC BY-SA 

 5.2 Processor 
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Processors contain a control unit and an arithmetic logic unit (ALU). These 

two components work together to perform processing operations.  

 

 

 
Figure 5.5 :Processor Components 

 

 

The Control Unit  

The control unit is the component of the processor that directs and 

coordinates most of the operations in the computer.  

 

The Arithmetic Logic Unit  

The arithmetic logic unit (ALU), another component of the processor, 

performs arithmetic, comparison, and other operations. Arithmetic 

operations include basic calculations such as addition, subtraction, 

multiplication, and division. Comparison operations involve comparing one 

data item with another to determine whether the first item is greater than, 

equal to, or less than the other item. Depending on the result of the 

comparison, different actions may occur. 

 

 

This Photo is licensed under CC BY-SA-NC 
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Memory consists of electronic components that store instructions waiting 

to be executed by the processor, data needed by those instructions, and 

the results of processed data (information). Memory usually consists of one 

or more chips on the motherboard or some other circuit board in the 

computer.  

 

Memory stores three basic categories of items:  

✓ the operating system and other system software that control or 

maintain the computer and its devices;  

✓ application programs that carry out a specific task such as word 

processing; and 

✓ the data being processed by the application programs and resulting 

information. This role of memory to store both data and programs is 

known as the stored program concept 

 

 

Types of Memory  

 

The system unit contains two types of memory: volatile and nonvolatile.  

 

Volatile memory loses its contents when the computer’s power is turned 

off. 

 

Nonvolatile memory, by contrast, does not lose its contents when power 

is removed from the computer. Thus, volatile memory is temporary and 

nonvolatile memory is permanent.  

 

 

 5.3 Memory 
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RAM 

Random Access Memory (RAM) is the most common type of volatile 

memory. Examples of nonvolatile memory include ROM, flash memory, and 

CMOS.  

 

ROM  

Read-only memory (ROM pronounced rahm) refers to memory chips storing 

permanent data and instructions. The data on most ROM chips cannot be 

modified — hence, the name read-only. ROM is nonvolatile, which means 

its contents are not lost when power is removed from the computer.  

 

Flash Memory  

Flash memory is a type of nonvolatile memory that can be erased 

electronically and rewritten. Most computers use flash memory to hold their 

startup instructions because it allows the computer easily to update its 

contents.  

 

 

 

 

An expansion slot is a socket on the motherboard that can hold an adapter 

card. An adapter card, sometimes called an expansion card, is a circuit 

board that enhances functions of a component of the system unit and/or 

provides connections to peripherals. A peripheral is a device that connects 

to the system unit and is controlled by the processor in the computer. 

Examples of peripherals are modems, disk drives, printers, scanners, and 

keyboards. 

 

 

 5.4 Expansion slot and adapter cards 
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Figure 5.6 : Expansion Slot 

 

 

 

 

PORTS AND CONNECTORS  

A port is the point at which a peripheral attaches to or communicates with 

a system unit so the peripheral can send data to or receive information 

from the computer. An external device, such as a keyboard, monitor, 

printer, mouse, and microphone, often attaches by a cable to a port on the 

system unit.  

This Photo by Unknown Author is licensed under CC BY 

5.5 Ports and connectors 
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Figure 5.7 : Variety of Ports 

 

 

Serial Ports  

A serial port is a type of interface that connects a device to the system unit 

by transmitting data one bit at a time. Serial ports usually connect devices 

that do not require fast data transmission rates, such as a mouse, 

keyboard, or modem.  

 

Figure 5.8 : Serial Ports 

 

 

 

This Photo by Unknown Author is licensed under CC BY-SA 

This Photo by Unknown Author is licensed under CC BY-SA 
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Parallel Ports  

Unlike a serial port, a parallel port is an interface that connects devices by 

transferring more than one bit at a time. Parallel ports originally were 

developed as an alternative to the slower speed serial ports. Some printers 

can connect to the system unit using a parallel port. This parallel port can 

transfer eight bits of data (one byte) simultaneously through eight separate 

lines in a single cable.  

 

 

Figure 5.9 : Parallel Port 

 

 

USB Ports  

A USB port, short for universal serial bus port, can connect up to 127 

different peripherals together with a single connector. Devices that connect 

to a USB port include the following: mouse, printer, digital camera, 

scanner, speakers, portable media player, CD, DVD, smart phone, PDA, 

game console, and removable hard disk.  

This Photo by Unknown Author is licensed under CC BY-SA 
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https://creativecommons.org/licenses/by-sa/3.0/


 

 

 

57 

 

Figure 5.10 : USB Ports 

 

 

 

 

BUSES  

A computer processes and stores data as a series of electronic bits. These 

bits transfer internally within the circuitry of the computer along electrical 

channels. Each channel, called a bus, allows the various devices both inside 

and attached to the system unit to communicate with each other. Just as 

vehicles travel on a highway to move from one destination to another, bits 

travel on a bus. Buses transfer bits from input devices to memory, from 

memory to the processor, from the processor to memory, and from 

memory to output or storage devices.  

 
 

This Photo by Unknown Author is licensed under CC BY-SA-NC 

 5.6 Buses 

 

https://gadgetsin.com/hyperdrive-net-6-in-2-usb-c-dock-for-macbook-pro.htm
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Figure 5.11 : Computer Buses 

 

 

 

 

 

 

 

 

 

This Photo by Unknown Author is licensed under CC BY-SA 

 

 

 

 

 

 

 

Instructions: Find the true statement below. Then, rewrite the 

remaining false statements so they are true. 
1. The motherboard also is called a system boar 

2. On a personal computer, all functions of the processor usually are 
on a single chip.  

3. The system clock keeps track of the date and time in a computer.  

4. In cloud computing, the back end consists of the servers and 
storage devices that manage and store the 

5. Most RAM is nonvolatile 
6. The processor interprets and executes a program or application’s 

instructions while the program or application 

7. is in nonvolatile memory. (291) 

 

 

 

 

                                    
Explain the specifications of your computer 

 
 ACTIVITY 

Checkpoint 5 

https://commons.wikimedia.org/wiki/Computer_extension_cards
https://creativecommons.org/licenses/by-sa/3.0/
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Short Question 
 

1. Explain 2 parts of a processor 
2. A computer might have these three types of buses. Explain it 

3. The system unit contains two types of memory. Volatile and 
nonvolatile. Explain it 

4. List two common types of RAM chips  
5. Differentiate RAM and ROM 
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• Technology and interactive media are learning tools that are able to 

support childrens education, growth and relationship. 

• Computers cause challnes in social , emotional and languages 

development. 

• Computers encourage childreen to think effectively 

• Technology and interactive media are learning tools that are able to 

support childrens education, growth and relationship. 

SUMMARY 

 KEY TERM 

central processing unit computer 

computer literacy data 

developer embedded computer 

blog execute 

desktop computer application software 
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Storage holds data, instructions, and information for future use.  

 

A storage medium (media is the plural), also called secondary storage, is 

the physical material on which a computer keeps data, instructions, and 

information. Examples of storage media are hard disks, floppy disks, CDs 

and DVDs, tape, PC Cards and ExpressCard modules, flash memory cards, 

USB flash drives, smart cards, and microfilm. 

 
 

 
 

 

 

 

By the end of topic, you should be able to: 

1. Describe the characteristics of magnetic disks  
2. Describe the characteristics of a hard disk  
3. Discuss various types of miniature, external, and 

removable hard disks 
4. Describe the characteristics of optical discs  

5. Differentiate among various CD and DVD formats  
6. Identify the uses of tape 

 

LEARNING OUTCOMES 

TOPIC 

6 

 

Storage  

 6.1 Storage 
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Figure 6.1 : Computer Storage 

 

 

Capacity is the number of bytes (characters) a storage medium can hold. 

Figure 6-2 identifies the terms manufacturers use to define the capacity of 

storage media. For example, a reasonably priced USB flash drive can store 

This Photo by Unknown Author is licensed under CC BY-SA 

https://commons.wikimedia.org/wiki/File:Memory-card-comparison.jpg
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up to 512 MB of data (approximately 512 million bytes) and a typical hard 

disk has 250 GB (approximately 250 billion bytes) of storage capacity.  

 

 
Figure 6.2 : Memory Capacity Measurement 

 

 

A storage device is the computer hardware that records and/or retrieves 

items to and from storage media.  

 

Writing is the process of transferring data, instructions, and information 

from memory to a storage medium.  

 

Reading is the process of transferring these items from a storage medium 

into memory. When storage devices write data on storage media, they are 

creating output.  

 

The speed of storage devices is defined by access time. Access time 

measures the amount of time it takes a storage device to locate an item on 

This Photo by Unknown Author is licensed under CC BY-SA-NC 

https://todotecnologia-eso.blogspot.ca/2011/10/bytes-kilobytes-megabytes-y-otras.html
https://creativecommons.org/licenses/by-nc-sa/3.0/
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a storage medium. The access time of storage devices is slow, compared 

with the access time of memory.  

 

 

 

 

A hard disk is a storage device that contains one or more inflexible, circular 

platters that store data, instructions, and information. People use hard 

disks to store all types of documents, spreadsheets, presentations, 

databases, e-mail messages, Web pages, digital photographs, music, 

videos, and software.  

 

The system unit on most desktop and notebook computers contains at least 

one hard disk. The entire device is enclosed in an airtight, sealed case to 

protect it from contamination. A hard disk that is mounted inside the 

system unit sometimes is called a fixed disk because it is not portable  

 

Characteristics Of A Hard Disk  

Characteristics of a hard disk include capacity, platters, read/write heads, 

cylinders, sectors and tracks, revolutions per minute, transfer rate, and 

access time.  

 

The capacity of a hard disk is determined from the number of platters it 

contains, together with composition of the magnetic coating on the platters.  

 

A platter is made of aluminum, glass, or ceramic and is coated with an 

alloy material that allows items to be recorded magnetically on its surface. 

The coating usually is three millionths of an inch thick. On desktop 

computers, platters most often have a size of approximately 3.5 inches in 

diameter. A typical hard disk has multiple platters stacked on top of one 

another. Each platter has two read/write heads, one for each side. The hard 

6.2 Hard disk 
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disk has arms that move the read/write heads to the proper location on the 

platter. 

 

 
Figure 6.3 : Hard Disc 

 

 

 

 

Flash Memory Cards  

Common types of flash memory cards include CompactFlash (CF), Secure 

Digital (SD), xD Picture Card, and Memory Stick. Depending on the device, 

manufacturers claim miniature mobile storage media can last from 10 to 

100 years. To view, edit, or print images and information stored on 

miniature mobile storage media, you transfer the contents to your desktop 

computer or other device. Some printers have slots to read flash memory 

cards. If your computer or printer does not have a built-in slot, you can 

purchase a card reader/writer, which is a device that reads and writes data, 

instructions, and information stored on flash memory cards. Card 

This Photo by Unknown Author is licensed under CC BY-NC 

 6.3 Flash memory 

 

https://freepngimg.com/png/50464-hard-disk-drive-picture-png-download-free
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reader/writers usually connect to the USB port or FireWire port on the 

system unit. The type of card you have will determine the type of card 

reader/writer needed. 

 

 

 
Figure 6.4 : Flash Drive 

 

 

 

 
Some users choose online storage instead of storing data locally on a hard 

disk. Online storage is a service on the Web that provides hard disk storage 
to computer users, for free or for a minimal monthly fee.  

 

This Photo by Unknown Author is licensed under CC BY-SA 

This Photo licensed under CC BY-SA 

 6.4 Cloud storage 
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Users subscribe to an online storage service for a variety of reasons:  

✓ To access files on the Internet hard disk from any computer or device 

that has Internet access  

✓ To allow others to access files on their Internet hard disk so others 

can listen to an audio file, watch a video clip, or view a picture — 

instead of e-mailing the file to them  

✓ To view time-critical data and images immediately while away from 

the main office or location; for example, doctors can view x-ray 

images from another hospital, home, or office  

✓ To store offsite backups of data Once users subscribe to the online 

storage service, they can save on the Internet hard disk in the same 

manner they save on their local hard disk. 

 

 

Figure 6.5 : Cloud Storage 

This Photo by Unknown Author is licensed under CC BY-SA-NC 

This Photo by Unknown Author is licensed under CC BY-SA-NC 

http://www.rauldiego.es/google-drive/
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An optical disc is a type of optical storage media that consists of a flat, 

round, portable, disc made of metal, plastic, and lacquer. These discs 

usually are 4.75 inches in diameter and less than one-twentieth of an inch 

thick.  

 

Optical discs primarily store software, data, digital photographs, movies, 

and music. Some optical disc formats are read only, meaning users cannot 

write (save) on the media. Others are read/write, which allows users to 

save on the disc just as they save on a hard disk. 

 

 

 
Figure 6.6 : Optical Disc 

 

 

 

 

 

 

 

 6.5 Optical disc 
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A solid-state drive (SSD) is a new generation of storage device used in 

computers. SSDs use flash-based memory, which is much faster than a 

traditional mechanical hard disk. 

 

The new solid-state drives work completely differently. They use a simple 

memory chip called NAND flash memory, which has no moving parts and 

near-instant access times. 

 

Why SSD Is Better than HDD 

 

Speed: Speed is the most prominent and significant advantage of an SSD 

over an HDD. Since it doesn’t have moving parts, an SSD can read data 10 

times faster than an HDD and write 20 times faster. Moreover, the HDD’s 

copying process ranges between 30 MB/s and 150 MB/s, whereas a 

standard SSD takes 500 MB/s. This way, SSDs deliver faster boot 

times, load times for applications and files (e.g. games and videos), and 

data transfer. 

 

Energy Efficiency: Due to an HDD’s dependency on lots of mechanical 

operations, it’s power-hungry storage. In contrast, SSDs are more energy-

efficient and consume less power, prolonging battery life. 

 

No Overheating: SSDs are more heat-resistant, whereas HDDs tend to 

overheat, compromising the system’s overall performance. 

 

Build: Having no moving parts gives an SSD an edge over HDD in terms 

of durability. It’s a more reliable storage device, doesn’t vibrate, and can 

 6.6 Solid State Drive  
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endure shocks, which HDD can’t. SSDs are also quiet, whereas HDDs are 

noisy. 

 

Weight: SSDs are lightweight compared to HDDs, making them more 

efficient in performance and functionality. 

 

Figure 6.7 : SSD  

 

 

 

 

 

 

This Photo by Unknown Author is licensed under CC BY-NC 

 

 

 

 

 

 

Instructions: Find the true statement below. Then, rewrite the 
remaining false statements so they are true. 
1. Storage devices can be categorized as input or output devices. 

2. A storage medium is volatile; that is, items stored on it remain intact even 

when you turn off a computer or mobile device.  

3. Compared with the access time of memory, the access time of storage 

devices is slow.  

4. On storage media, a higher density means less storage capacity.  

Checkpoint 6 

https://kinsta.com/blog/boosting-wordpress-performance/
https://www.pngall.com/ssd-solid-state-drive-png
https://creativecommons.org/licenses/by-nc/3.0/
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Short Questions 

 
1. In terms of storage devices, what is reading and writing?  

2. Is a screen display volatile or nonvolatile? 
3. What does access time measure?  

4. Explain FIVE (5) types of storage. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

• This chapter discussed different types of memory used in computer system 

SUMMARY 

 

 

 

 

                                    
What type of memory that you used in your handphone? Can you 

differentiate it? 

 
 ACTIVITY 

 KEY TERM 

Memory RAM 

ROM Harddisk 

Flash Memory Cloud Storage  
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When you purchase a personal computer, it usually has system software 

installed on its hard disk.  

 

System software consists of the programs that control or maintain the 

operations of the computer and its devices. System software serves as the 

interface between the user, the application software, and the computer’s 

hardware. Two types of system software are operating systems and utility 

programs. This chapter discusses the operating system and its functions, 

as well as several types of utility programs for personal computers 

 

 

 

 

 

 

By the end of topic, you should be able to: 

1. Identify the types of system software  
2. Describe the functions of an operating system  
3. Explain the purpose of the utilities included with most 

operating systems  
4. Summarize the features of several stand-alone operating 

systems  
5. Identify devices that use embedded operating systems  
6. Explain the purpose of several stand-alone utility programs 
 

LEARNING OUTCOMES 

TOPIC 

7 

 

Operating System 

7.1 System Software 
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An operating system (OS) is a set of programs containing instructions 

that coordinate all the activities among computer hardware resources. Most 

operating systems perform similar functions that include; 

✓ starting a computer 

✓ providing a user interface 

✓ managing programs 

✓ managing memory 

✓ scheduling jobs 

✓ configuring devices 

✓ establishing an Internet connection 

✓ monitoring performance 

✓ providing file management utilities 

✓ control a network  

✓ administer security 

 

 

 

 

 

Many different operating systems exist; however, most operating systems 

provide similar functions. The following sections discuss functions common 

to most operating systems. The operating system handles many of these 

functions automatically, without requiring any instruction from a user.  

 

Starting a Computer  

Booting is the process of starting or restarting a computer. When turning 

on a computer that has been powered off completely, you are performing 

7.2 Operating Systems 

 

 7.3 Operating System Functions 
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a cold boot.  A warm boot, by contrast, is the process of using the operating 

system to restart a computer.  

 

 
Figure 7.1 : Operating System Interface 

 

Providing a User Interface  

You interact with software through its user interface. That is, a user 

interface controls how you enter data and instructions and how information 

is displayed on the screen.  

 

Managing Programs  

Some operating systems support a single user and only one running 

program at a time. Others support thousands of users running multiple 

programs. How an operating system handles programs directly affects your 

productivity. A single user/single tasking operating system allows only one 

user to run one program at a time. PDAs, smart phones, and other small 

computing devices often use a single user/single tasking operating system. 

A single user/multitasking operating system allows a single user to work on 

This Photo is licensed under CC BY 
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75 

two or more programs that reside in memory at the same time. Users today 

typically run multiple programs concurrently. It is common to have an e-

mail program and Web browser open at all times, while working with 

application programs such as word processing or graphics 

 

Managing Memory  

The purpose of memory management is to optimize the use of random 

access memory (RAM). RAM consists of one or more chips on the 

motherboard that hold items such as data and instructions while the 

processor interprets and executes them. The operating system allocates, 

or assigns, data and instructions to an area of memory while they are being 

processed. Then, it carefully monitors the contents of memory. Finally, the 

operating system releases these items from being monitored in memory 

when the processor no longer requires them. 

 

Scheduling Jobs  

The operating system determines the order in which jobs are processed. A 

job is an operation the processor manages. Jobs include receiving data from 

an input device, processing instructions, sending information to an output 

device, and transferring items from storage to memory and from memory 

to storage. A multiuser operating system does not always process jobs on 

a first-come, first-served basis. Sometimes, one user may have a higher 

priority than other users. In this case, the operating system adjusts the 

schedule of jobs. Sometimes, a device already may be busy processing one 

job when it receives a second job. This occurs because the processor 

operates at a much faster rate of speed than peripheral devices.  

 
 

Configuring Devices  

A driver is a small program that tells the operating system how to 

communicate with a specific device. Each device on a computer, such as 

the mouse, keyboard, monitor, printer, and scanner, has its own specialized 
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set of commands and thus requires its own specific driver. When you boot 

a computer, the operating system loads each device’s driver. If you attach 

a new device to a computer, such as a printer or scanner, its driver must 

be installed before you can use the device. For many devices, the 

computer’s operating system includes the necessary drivers. Today, many 

devices and operating systems support Plug and Play. Plug and Play means 

the operating system automatically configures new devices as you install 

them. With Plug and Play, a user can plug in a device, turn on the computer, 

and then use the device without having to configure the system manually.  

 

Establishing an Internet Connection  

Operating systems typically provide a means to establish Internet 

connections. Some operating systems also include a Web browser and an 

e-mail program, enabling you to begin using the Web and communicate 

with others as soon as you set up the Internet connection. Some also 

include utilities to protect computers from unauthorized intrusions and 

unwanted software such as viruses and spyware 

 

Monitoring Performance  

Operating systems typically contain a performance monitor. A performance 

monitor is a program that assesses and reports information about various 

computer resources and devices. The information in performance reports 

helps users and administrators identify a problem with resources so they 

can try to resolve any problems. 

 

Providing File Management and Other Utilities  

Operating systems often provide users with the capability of managing files, 

searching for files, viewing images, securing a computer from unauthorized 

access, uninstalling programs, scanning disks, defragmenting disks, 

diagnosing problems, backing up files and disks, and setting up screen 

savers.  
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Some operating systems have network features built into them. In other 

cases, the network OS is a set of programs separate from the operating 

system on the client computers that access the network. When not 

connected to the network, the client computers use their own operating 

system. When connected to the network, the network OS may assume 

some of the operating system functions.  

 

Administering Security  

The network administrator uses the network OS to establish permissions to 

resources. These permissions define who can access certain resources and 

when they can access those resources. For each user, the network 

administrator establishes a user account, which enables a user to access, 

or log on to, a computer or a network. Each user account typically consists 

of a user name and password. A user name, or user ID, is a unique 

combination of characters, such as letters of the alphabet or numbers, that 

identifies one specific user.  

 

 

 

 

A utility program, also called a utility, is a type of system software that 

allows a user to perform maintenance-type tasks, usually related to 

managing a computer, its devices, or its programs.  

 

Utility programs included with most operating systems provide the 

following functions:  

✓ managing files, searching for files 

✓ viewing images 

✓ securing a computer from unauthorized access 

✓ uninstalling programs 

 7.4 Utility Programs 
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✓ scanning disks 

✓ defragmenting disks 

✓ diagnosing problems 

✓ backing up files and disks 

✓ setting up screen savers 

 

File Manager  

A file manager is a utility that performs functions related to file 

management. Some of the file management functions that a file manager 

performs are displaying a list of files on a storage medium organizing files 

in folders; and copying, renaming, deleting, moving, and sorting files. A 

folder is a specific named location on a storage medium that contains 

related documents.  

 

 

Figure 7.2 : File Manager 

 
 

 

This Photo is licensed under CC BY-SA 

http://superuser.com/questions/1141631/make-windows-10-file-explorer-look-like-mac-osx-finders-column-view
https://creativecommons.org/licenses/by-sa/3.0/
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Search Utility  

A search utility is a program that attempts to locate a file on your computer 

based on criteria you specify. The criteria could be a word or words 

contained in a file, date the file was created or modified, size of the file, 

location of the file, file name, author/artist, and other similar properties. 

Search utilities can look through documents, pictures, music, and other 

files.  

 

Figure 7.3 : Searching 

 

Personal Firewall  

A personal firewall is a utility that detects and protects a personal computer 

from unauthorized intrusions. Personal firewalls constantly monitor all 

transmissions to and from a computer. When connected to the Internet, 

your computer is vulnerable to attacks from a hacker. A hacker is someone 

who tries to access a computer or network illegally.  

 

This Photo by Unknown Author is licensed under CC BY-SA 

http://superuser.com/questions/496188/can-i-use-wildcards-in-windows-8-search
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Figure 7.4 : Firewall 

 

Uninstaller  

An uninstaller is a utility that removes a program, as well as any associated 

entries in the system files. When you install a program, the operating 

system records the information it uses to run the software in the system 

files. The uninstaller deletes files and folders from the hard disk, as well as 

removes program entries from the system files.  

 

Disk Scanner  

A disk scanner is a utility that searches for and removes unnecessary files.  

 

Disk Defragmenter  

A disk defragmenter is a utility that reorganizes the files and unused space 

on a computer’s hard disk so the operating system accesses data more 

quickly and programs run faster. When an operating system stores data on 

a disk, it places the data in the first available sector on the disk. It attempts 

This Photo by Unknown Author is licensed under CC BY-SA-NC 
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to place data in sectors that are contiguous (next to each other), but this 

is not always possible. When the contents of a file are scattered across two 

or more noncontiguous sectors, the file is fragmented. Fragmentation slows 

down disk access and thus the performance of the entire computer. 

Defragmenting the disk, or reorganizing it so the files are stored in 

contiguous sectors, solves this problem.  

 

Diagnostic Utility  

A diagnostic utility compiles technical information about your computer’s 

hardware and certain system software programs and then prepares a report 

outlining any identified problems. Information in the report assists technical 

support staff in remedying any problems.  

 

Backup Utility  

A backup utility allows users to copy, or back up, selected files or an entire 

hard disk to another storage medium such as CD, DVD, external hard disk, 

tape, or USB flash drive. During the backup process, the backup utility 

monitors progress and alerts you if it needs additional discs or tapes. Many 

backup programs compress, or shrink the size of, files during the backup 

process. By compressing the files, the backup program requires less 

storage space for the backup files than for the original files. Because they 

are compressed, you usually cannot use backup files in their backed up 

form. In the event you need to use a backup file, a restore program 

reverses the process and returns backed up files to their original form. 

Backup utilities include restore programs. You should back up files and 

disks regularly in the event your originals ar 
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When you purchase a new computer, it typically has an operating system 

preinstalled.The three basic categories of operating systems that exist 

today are desktop, network, and mobile operating system. 

 

Desktop Operating System 

A desktop operating system, sometimes called a stand-alone operating 

system, is a complete operating system that works on desktops, laptops, 

and some tablets. Desktop operating systems sometimes are called client 

operating systems because they also work in conjunction with a server 

operating system. Client operating systems can operate with or without a 

network.  

 

Examples of the more widely used desktop operating systems are Windows, 

Mac OS, UNIX, Linux, and Chrome OS. 

 

Windows is an operating system develop by Microsoft, which provided a 

graphical user interface. Since then, Microsoft continually has updated its 

Windows operating system, incorporating innovative features and functions 

with each subsequent version.  

 

UNIX (pronounced YOU-nix) is a multitasking operating system and was 

implemented on many different types of computers. In the 1980s, the 

source code for UNIX was licensed to many hardware and software 

companies to customize for their devices and applications. As a result, 

several versions of this operating system exist, each with slightly different 

features or capabilities. Today, a version of UNIX is available for most 

computer. 

 

 7.5 Types Of Operating Systems 
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Chrome Os introduced by Google, is a Linux-based operating system 

designed to work primarily with web apps. Apps are available through the 

Chrome Web Store, and data is stored on Google Drive.  

 

 

Figure 7.5 : Windows Operating System 

 

This Photo by Unknown Author is licensed under CC BY-SA-NC 
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Figure 7.6 : Unix Operating System 

 

Server Operating Systems  

Network operating system is an operating system that is designed 

specifically to support a network. A network operating system typically 

resides on a server. The client computers on the network rely on the 

server(s) for resources. Many of the client operating systems discussed in 

the previous section work in conjunction with a network operating system. 

  

Examples of server operating systems include the following:  

Windows Server: Developed by Microsoft, Windows Server enables 

organizations to manage applications and websites on-site and/or on the 

cloud.  

OS X Server: Developed by Apple, OS X Server enables organizations to 

collaborate, share files, host websites and mail servers, and more on Mac 

computers and iOS devices.  

 

 

This Photo by Unknown Author is licensed under CC BY 
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Mobile Operating Systems  

The operating system on mobile devices and many consumer electronics is 

called a mobile operating system and resides on firmware. Popular mobile 

operating systems include Android, iOS, and Windows Phone.  

 

Android  

Android is an open source, Linux-based mobile operating system designed 

by Google for smartphones and tablets. A variety of manufacturers produce 

devices that run the Android operating system, adding their own interface 

elements and bundled software. As a result, an Android smartphone 

manufactured by Samsung may have different user interface features from 

one manufactured by Google.  

 

 
Figure 7.6 : Android Operating System 

 

Windows Phone  

Windows Phone, developed by Microsoft, is a proprietary mobile operating 

system that runs on some smartphones.  

 

 

 

This Photo is licensed under CC BY-SA 

https://www.htnovo.net/2020/09/android-11-disponibile-ufficialmente.html
https://creativecommons.org/licenses/by-sa/3.0/
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ios  

iOS (originally called iPhone OS), developed by Apple, is a proprietary 

mobile operating system specifically made for Apple’s mobile devices. 

Supported devices include the iPhone, iPod Touch, and iPad. 

 

 
Figure 7.7 :iOS 

 

 

 

 

 

 

This Photo  is licensed under CC BY-NC 

 

 

 

 

 

 

 

 

 

 

 

 

 

Instructions: Find the true statement below. Then, rewrite the 

remaining false statements so they are true. 
1. Every computer must have operating system 

2. User interface is the same for all computers regardless of the 

operating system install 

3. Desktop and mobile has the same operating system 

Checkpoint 7 

https://www.iphonemod.net/ios-12-ipad-same-gestures-iphone-x.html
https://creativecommons.org/licenses/by-nc/3.0/
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Short Question 
1. Define the term, operating system. List the functions of an 

operating system. 
2. List methods to start a computer or device. 

3. Identify the five steps in the start-up process. 
4. Explain the role of a boot drive. 

5. List reasons why users might shut down computers or mobile 
devices regularly.  

6. Define the term, user interface.  
7. Describe how a computer manages memory.  
 

 

 

 

 

 

 

 

• Technology and interactive media are learning tools that are able to 

support childrens education, growth and relationship. 

• Computers cause challnes in social , emotional and languages 

development. 

• Computers encourage childreen to think effectively 

• Technology and interactive media are learning tools that are able to 

support childrens education, growth and relationship. 

SUMMARY 

 

 

 

 

 

                                    
Explain the operating system of Your computer and mobile device. Is 

it the same? 

 
 ACTIVITY 

 KEY TERM 

System software Operating system 

Booting File manager 

Utility Program Firewall 
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A computer security risk is any event or action that could cause a loss 

of or damage to computer hardware, software, data, information, or 

processing capability. Some breaches to computer security are accidental 

while others are planned intrusions.  

 

Some intruders do no damage; they merely access data, information, or 

programs on the computer. Other intruders indicate some evidence of their 

presence either by leaving a message or by deliberately altering or 

damaging data.  

 

An intentional breach of computer security often involves a deliberate act 

that is against the law. Any illegal act involving a computer generally is 

referred to as a computer crime. 

 

By the end of topic, you should be able to: 

1. Identify ways to safeguard against computer viruses, worms, 
Trojan horses, botnets, denial of service attacks, back doors, 
and spoofing  

2. Discuss techniques to prevent unauthorized computer access 
and use 

3. Identify safeguards against hardware theft and vandalism  
4. Explain the ways to protect against software theft and 

information theft  
 

LEARNING OUTCOMES 

TOPIC 

8 

Computer Security and Safety: Ethics and 

Privacy 

 8.1 Computer Security Risks 
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The term cybercrime refers to online or Internet-based illegal acts.  
 

 

Figure 8.1 : Cybercrime 

 

 

 

 

Information transmitted over networks has a higher degree of security risk 

than information kept on a company’s premises. Internet and network 

attacks include computer viruses, worms, and Trojan horses; botnets; 

denial of service attacks; back doors; and spoofing.  

 

A computer virus is a potentially damaging computer program that 

affects, or infects, a computer negatively by altering the way the computer 

works without the user’s knowledge or permission. Once the virus infects 

the computer, it can spread throughout and may damage files and system 

software, including the operating system.  

 

This Photo is licensed under CC BY-SA 

8.2 Internet And Network Attacks 

 

https://www.picpedia.org/legal-01/c/cybercrime.html
https://creativecommons.org/licenses/by-sa/3.0/
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Figure 8.2 : Antivirus 

 

A worm is a program that copies itself repeatedly, for example in memory 

or on a network, using up resources and possibly shutting down the 

computer or network.  

 

A Trojan horse (named after the Greek myth) is a program that hides 

within or looks like a legitimate program. A certain condition or action 

usually triggers the Trojan horse. Unlike a virus or worm, a Trojan horse 

does not replicate itself to other computers.  

 

Computer viruses, worms, and Trojan horses are classified as malware 

(short for malicious software), which are programs that act without a user’s 

knowledge and deliberately alter the computer’s operations.  
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A computer infected by a virus, worm, or Trojan horse often has one or 

more of the following symptoms:  

 

✓ Screen displays unusual message or image  

✓ Music or unusual sound plays randomly  

✓ Available memory is less than expected  

✓ Existing programs and files disappear  

✓ Files become corrupted  
✓ Programs or files do not work properly  

✓ Unknown programs or files  
✓ System properties change mysteriously appear  

 
 

Users can take several precautions to protect their home and work 

computers from these malicious infections.  

 

✓ Do not start a computer with removable media, such as CDs, DVDs, 

and USB flash drives, in the drives or ports  

✓ Never open an e-mail attachment unless you are expecting the 

attachment and it is from a trusted source.  

✓ Turn off message preview in your e-mail program. Some viruses are 

hidden in macros, which are instructions saved in software such as a 

word processing or spreadsheet program.  

✓ In programs that allow users to write macros, you should set the 

macro security level so the application software warns users that a 

document they are attempting to open contains a macro.  

✓ Users should install an antivirus program and update it frequently. 

An antivirus program protects a computer against viruses by 

identifying and removing any computer viruses found in memory, on 

storage media, or on incoming files.  
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Botnets  

A botnet is a group of compromised computers connected to a network 

such as the Internet that are being used as part of a network that attacks 

other networks, usually for nefarious purposes.  

A compromised computer, known as a zombie, is one whose owner is 

unaware the computer is being controlled remotely by an outsider. 

Cybercriminals use botnets to send spam via e-mail, spread viruses and 

other malware, or commit a denial of service attack. 

Denial of Service Attacks  

A denial of service attack, or DoS attack, is an assault whose purpose is to 

disrupt computer access to an Internet service such as the Web or e-mail. 

Perpetrators carry out a DoS attack in a variety of ways.  

Back Doors  

A back door is a program or set of instructions in a program that allow users 

to bypass security controls when accessing a program, computer, or 

network. Once perpetrators gain access to unsecure computers, they often 

install a back door or modify an existing program to include a back door, 

which allows them to continue to access the computer remotely without the 

user’s knowledge.  

Spoofing  

Spoofing is a technique intruders use to make their network or Internet 

transmission appear legitimate to a victim computer or network.  

Safeguards against Botnets, DoS Attacks, Back Doors, and Spoofing To 

defend against botnets, DoS attacks, improper use of back doors, and 

spoofing, users can implement firewall solutions and install intrusion 

detection software.  
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Another type of computer security risk is unauthorized access and use. 

Unauthorized access is the use of a computer or network without 

permission.  

 

Unauthorized use is the use of a computer or its data for unapproved or 

possibly illegal activities. Unauthorized use includes a variety of activities: 

an employee using an organization’s computer to send personal e-mail 

messages, an employee using the organization’s word processing software 

to track his or her child’s soccer league scores, or someone gaining access 

to a bank computer and performing an unauthorized transfer.  

 

 
Figure 8.3 : Unauthorized Access 

 

 

 

 

 

 

This Photo is licensed under CC BY-SA 

 8.3 Unauthorized Access And Use 

 

http://stackoverflow.com/questions/39035125/how-can-i-redirect-to-my-login-screen-when-unauthorized-while-also-returning-a-4
https://creativecommons.org/licenses/by-sa/3.0/
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Hardware theft and vandalism are other types of computer security risks.  

 

Hardware theft is the act of stealing computer equipment.  

 

Hardware vandalism is the act of defacing or destroying computer 

equipment. Hardware vandalism takes many forms, from someone cutting 

a computer cable to individuals breaking into a business or school computer 

lab and aimlessly smashing computers. Mobile users are susceptible to 

hardware theft.  

 

To help reduce the chances of theft, companies and schools use a variety 

of security measures. Physical access controls, such as locked doors and 

windows, usually are adequate to protect the equipment. Many businesses, 

schools, and some homeowners install alarm systems for additional 

security. School computer labs and other areas with a large number of 

semifrequent users often attach additional physical security devices such 

as cables that lock the equipment to a desk, cabinet, or floor.  

 

Small locking devices also exist that require a key to access a hard disk or 

CD/DVD drive. Mobile computer users must take special care to protect 

their equipment. Some users attach a physical device such as a cable to 

lock a mobile computer temporarily to a stationary object.  

 

Some notebook computers use passwords, possessed objects, and 

biometrics as methods of security. When you boot up these computers, you 

must enter a password, slide a card in a card reader, or press your finger 

on a fingerprint scanner before the hard disk unlocks. This type of security 

does not prevent theft, but it renders the computer useless if it is stolen. 

 8.4 Hardware Theft And Vandalism 
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Figure 8.4 : Laptop Lock 

 

 

 

 

Another type of computer security risk is software theft.  

 

Software theft occurs when someone steals software media, intentionally 

erases programs, or illegally copies a program.  

 

One form of software theft involves someone physically stealing the media 

that contain the software or the hardware that contains the media, as 

described in the previous section.  

 

Another form of software theft occurs when software is stolen from software 

manufacturers. This type of theft, called piracy, is by far the most common 

form of software theft.  

This Photo is licensed under CC BY-SA 

 8.5 Software Theft 

 

https://www.ipevo.com/prods/Dual-Mode-Laptop-Security-Lock/0/0/
https://creativecommons.org/licenses/by-sa/3.0/
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Software piracy is the unauthorized and illegal duplication of copyrighted 

software.  

 

To protect software media from being stolen, owners should keep original 

software boxes and media in a secure location. All computer users should 

back up their files and disks regularly, in the event of theft. To protect 

themselves from software piracy, software manufacturers issue users 

license agreements.  

 

 

 
Figure 8.5 : Software Theft 

 

This Photo is licensed under CC BY-SA-NC 

https://levashove.ru/fix-aksdf-sys-blue-screen-error-in-windows-10/
https://creativecommons.org/licenses/by-nc-sa/3.0/
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Short Question 

 
1. Define the terms, digital security risk, computer crime, cybercrime, 

and crimeware. 
2. List common types of malwares.  

3. Identify risks and safety measures when gaming. 
4. Define these terms: botnet, zombie, and bot.  

5. Describe the damages caused by and possible motivations behind 

DoS and DDoS attacks. 
6. A(n) ___ allows users to bypass security controls when accessing a 

program, computer, or network. 
7. Define the term, spoofing. How can you tell if an email is 

spoofed? 
8. List ways to protect against Internet and network attacks. 
 
 

 

 

 

 

 

 

 

 

 

 

Instructions: Find the true statement below. Then, rewrite the 

remaining false statements so they are true. 
1. Any illegal act involving a computer generally is referred to as a 

cybercrime.  

2. Hackers often claim the intent of their security breaches is to 
improve security.  

3. A firewall is hardware and/or software that allows users to bypass 
security controls when accessing a program, computer, or network.  

4. In order to safeguard against unauthorized access and use of its 

computers, a company should have a digital certificate.  
 

Checkpoint 8 

 

 

 

 

                                    

Share your experience regarding internet attack on your PC or mobile 

device. 

 
 ACTIVITY 
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This chapter identified some potential computer risks and the safeguards 

that schools, businesses, and individuals can implement to minimize 

these risks. Wireless security risks and safeguards also were discussed.  

SUMMARY 

 KEY TERM 

Virus Malware 

Cyber crime Zombie 

Software Theft Firewall  
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With Microsoft Word on your PC, Mac, or mobile device, you can: 

 Create documents from scratch, or a template. 

 Add text, images, art, and videos. 

 Research a topic and find credible sources. 

 MS Access your documents from a computer, tablet, or phone with 

OneDrive. 

 Share your documents, and work with others. 

 Track and review changes. 

To create a document, simply open Word, select a blank document or 

template, and start typing. Word offers many professionally designed 

templates to help you create letters, resumes, reports, and more. 

 

 

 

 

By the end of topic, you should be able to: 

1. Create document that contain formatted text, table, image, 

smart art 
2. Create a simple poster that combined text box, and picture 

element. 

 

LEARNING OUTCOMES 

TOPIC 

9 

 

Microsoft Word 

 

 9.1 Introduction 
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Create a blank document 

1. Open Word. Or, if Word is already open, select File > New. 

2. Select Blank document. 

 

Create a document using a template 

1. Open Word. Or, if Word is already open, select File > New. 

 

 

2. Double-click a template to open it. 

Tip: Pin templates you like, so you always see them when you start 

Word. Select the template and then select the pin icon that appears next 

to the name of the template. 
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Search for a template 

1. Open Word. Or, if Word is already open, select File > New. 

2. In the Search for online templates box, enter a search word 

like letter, resume, or invoice. 

 

Or, select a category under the search box  like Business, Personal, 

or Education. 

3. Click a template to see a preview. Click the arrows on the side of the 

preview to see more templates. 

 

4. Select Create. 
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Add text 

1. Place the cursor where you want to add the text. 

2. Start typing. 

Format text 

1. Select the text you want to format. 

2. Select an option to change the font, font size, font color, or make the 

text bold, italics, or underline. 

 

Copy formatting 

1. Select the text with the formatting you want to copy. 

2. Click Format painter, and then select the text you want to copy the 

formatting to. 

 

Tip: Double-click Format painter if you want to copy the formatting 

in more than one place. 

 

 

 

 9.2 Working with Text 
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Select text 

In Word, you can select all text in a document, or select specific text or 

items in a table by using the mouse or keyboard. You can also select text 

or items that are in different places. For example, you can select a 

paragraph on one page and a sentence on a different page. 

 

Select all text 

1. Click anywhere within the document. 

2. Press Ctrl+A on your keyboard to select all text in the document. 

 

 

Select specific text 

You can also select a specific word, line of text, or one or more paragraphs. 

1. Place your cursor in front of the first letter of the word, sentence, or 

paragraphs you want to select. 

2. Click and hold while you drag your cursor to select the text you want. 
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Other ways to select text 

▪ To select a single word, quickly double-click that word. 

▪ To select a line of text, place your cursor at the start of the line, and 

press Shift + down arrow. 

▪ To select a paragraph, place your cursor at the start of the paragraph, 

and press Ctrl + Shift + down arrow. 
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You can use Word to select and format text, change line and paragraph 

spacing, change indentation, and add lists. You can also use the edit menu 

to cut, copy, paste, and delete text that you select. 

Change the font, font size, or font style 

You can use the formatting options available on the Home tab to format 

text. 

▪ Change the font: Select some text and then tap the font name box. 

Choose a font from the drop-down list. 

 

 

▪ Change the font size: Select some text, tap the font size box, and 

then choose a size from the drop-down list. 

 9.3 Formatting  
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▪ Add bold, italics, or underlining: Select some text and then tap the 

appropriate icon to apply the formatting. 

 

▪ Highlight text: Select some text, tap the highlight icon, and then 

choose a highlight color. 
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▪ Change the font color: Tap the font color icon, and then choose a 

color. 

 

▪ Add strikethrough: Select the text, and then tap the down arrow. 

Tap the strikethrough icon on the Font menu. 
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▪ Remove formatting: Select the text that has the formatting you want 

to remove, and then tap the down arrow. Tap Clear Formatting on 

the Font menu. 

▪ Add subscript or superscript: Select some text, tap the down arrow, 

and select subscript or superscript on the Font menu 

 

Notes: If you are using your device in portrait mode, many of the 

formatting options will appear on the Font menu. 

▪  
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▪ Apply a style: Select some text, tap the style icon, and then select from 

the list of defined styles. 

 

 

Use editing tools 

You can also select formatting options from the edit menu. 

 

 

Cut and paste or copy and paste 

Select some text, tap the scissors icon to cut the text or the copy icon to 

copy the text, tap a new location, and then tap the clipboard icon. Tap the 

arrow next to the clipboard to see the Paste menu. You can 

select Paste, Keep Source Formatting, Keep Text Only, or Paste 

Format. 
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Add bullet or numbered lists 

▪ Select the text and then tap the bullet or the numbered list icon. 

 

You can select a bullet or numbering style. 

 

 9.4 Bullets & Numbering 
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Indent a paragraph 

▪ Tap anywhere in the paragraph, and then tap the indent icon or the 

negative indent icon. 

 

 

 

 

Format Paragraphs 

▪ Align the text: Tap the text and then tap the alignment icon to align 

the text left, center, right, or justified. 

 9.5 Paragraphing 
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▪ Line spacing: To add or remove space before or after a line or 

paragraph, tap the arrow and then select from the spacing options. 

 

▪ Insert or remove tabs: Tap the place where you want the tab to be 

located, tap the paragraph tab icon, and then tap the insert tab or 

remove tap icon. 

 



 

 

 

114 

To indent only the first line or use a hanging indent, tap the paragraph 

tab icon, tap Special Indent, and then make your selection. 

 

 

 

 

Change margins in your document to change the layout and make sure 

everything fits. 

Apply a predefined margin setting 

1. Select Layout > Margins. 

 

2. Select the margin measurements you want. 

9.6 Margin & Alignment 
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Note: If your document contains multiple sections, the new margins apply 

only to the selected sections. 

Create a custom margin 

1. Select Layout > Margins. 

2. Select Custom Margins. 

3. In Margins, use the Up and Down arrows to enter the values you want. 

4. Select OK when done. 

Change default margins 

1. Select Layout > Margins > Custom Margins. 

2. Set your margins. 

3. Select Set As Default. 

4. Confirm your selection. 
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For a basic table, click Insert > Table and move the cursor over the grid 

until you highlight the number of columns and rows you want. 

 

For a larger table, or to customize a table, elect Insert > Table > Insert 

Table. 

 

Tips:  

▪ If you already have text separated by tabs, you can quickly convert it 

to a table. Select Insert > Table, and then select Convert Text to 

Table. 

▪ To draw your own table, select Insert > Table > Draw Table. 

 9.7 Tables & Borders 
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Format a table 

After you create a table, Word offers you many ways to format that table. 

If you decide to use Table Styles, you can format your table all at once, 

and even see a preview of what your table will look like formatted in a 

particular style before you actually apply the style. 

You can create a custom look for tables by splitting or merging cells, adding 

or deleting columns or rows, or adding borders. If you're working with a 

long table, you can repeat the table headings on each page on which the 

table appears. To prevent awkward page breaks that disrupt the flow of 

your table, you can also specify just how and where the table should break 

across pages. 

Use Table Styles to format an entire table 

After you create a table, you can format the entire table by using Table 

Styles. By resting your pointer over each of the preformatted table styles, 

you can preview what the table will look like. 

1. Click in the table that you want to format. 

2. Under Table Tools, click the Design tab. 

3. In the Table Styles group, rest the pointer over each table style until 

you find a style that you want to use. 

 

Note: To see more styles, click the More arrow . 

4. Click the style to apply it to the table. 
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5. In the Table Style Options group, select or clear the check box next 

to each the table element to apply or remove the selected style. 

Add or remove borders 

You can add or remove borders to format a table the way that you want. 

Add table borders 

1. Under Table Tools, click the Layout tab. 

2. In the Table group, click Select, and then click Select Table. 

3. Under Table Tools, click the Design tab. 

4. In the Table Styles group, click Borders, and then do one of the 

following: 

▪ Click one of the predefined border sets. 

▪ Click Borders and Shading, click the Borders tab, and then 

choose the options that you want. 

Remove table borders from the whole table 

1. Under Table Tools, click the Layout tab. 

2. In the Table group, click Select, and then click Select Table. 

3. Under Table Tools, click the Design tab. 

4. In the Table Styles group, click Borders, and then click No Border. 

Add table borders to specified cells only 

1. On the Home tab, in the Paragraph group, click Show/Hide. 
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2. Select the cells that you want, including their end-of-cell marks. 

 

3. Under Table Tools, click the Design tab. 

4. In the Table Styles group, click Borders, and then click the border 

that you want to add. 

Remove table borders from specified cells only 

1. On the Home tab, in the Paragraph group, click Show/Hide. 

 

2. Select the cells that you want, including their end-of-cell marks. 

 

3. Under Table Tools, click the Design tab. 

4. In the Table Styles group, click Borders, and then click No Border. 
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Display or hide gridlines 

Gridlines show the cell boundaries of a table on the screen wherever the 

table doesn't have borders applied. If you hide the gridlines in a table that 

has borders, you won't see the change because the gridlines are behind the 

borders. To view the gridlines, remove the borders. 

Unlike borders, gridlines appear only on the screen; they are never printed. 

If you turn off gridlines, the table is displayed as it will be printed. 

Note: Gridlines are not visible when you view a document in a Web browser 

or in Print Preview. 

Display or hide table gridlines in a document 

▪ Under Table Tools, on the Layout tab, in the Table group, click View 

Gridlines. 

Add a cell, row, or column 

Add a cell 

1. Click in a cell that is located just to the right of or above where you want 

to insert a cell. 

2. Under Table Tools, on the Layout tab, click the Rows & 

Columns Dialog Box Launcher. 

3. Click one of the following options: 
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Click this To do this 

Shift cells 

right 

Insert a cell and move all other cells in that row to the 

right. 

Note: This option may result in a row that has more 

cells than the other rows. 

Shift cells 

down 

Insert a cell and move remaining existing cells in that 

column down one row each. A new row will be added 

at the bottom of the table to contain the last existing 

cell. 

Insert entire 

row 

Insert a row just above the cell that you clicked in. 

Insert entire 

column 

Insert a column just to the right of the cell that you 

clicked in. 

Add a row 

1. Click in a cell that is located just below or above where you want to 

add a row. 

2. Under Table Tools, click the Layout tab. 

3. Do one of the following: 

▪ To add a row just above the cell that you clicked in, in the Rows 

and Columns group, click Insert Above. 

▪ To add a row just below the cell that you clicked in, in the Rows 

and Columns group, click Insert Below. 
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Add a column 

1. Click in a cell that is located just to the right or left of where you want 

to add a column. 

2. Under Table Tools, click the Layout tab. 

3. Do one of the following: 

▪ To add a column just to the left of the cell that you clicked in, in 

the Rows and Columns group, click Insert Left. 

▪ To add a column just to the right of the cell that you clicked in, in 

the Rows and Columns group, click Insert Right. 

Delete a cell, row, or column 

1. Do one of the following: 

To select Do this 

A cell 
Click the left edge of the cell. . 

A row 
Click to the left of the row.  

A column Click the column's top gridline or top 

border.  

2. Under Table Tools, click the Layout tab. 

3. In the Rows & Columns group, click Delete, and then click Delete 

Cells, Delete Rows, or Delete Columns, as appropriate. 
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Merge or split cells 

Merge cells 

You can combine two or more cells in the same row or column into a single 

cell. For example, you can merge several cells horizontally to create a table 

heading that spans several columns. 

1. Select the cells that you want to merge by clicking the left edge of a cell 

and then dragging across the other cells that you want. 

2. Under Table Tools, on the Layout tab, in the Merge group, 

click Merge Cells. 

Split cells 

1. Click in a cell, or select multiple cells that you want to split. 

2. Under Table Tools, on the Layout tab, in the Merge group, click Split 

Cells. 

3. Enter the number of columns or rows that you want to split the selected 

cells into. 

Repeat a table heading on subsequent pages 

When you work with a very long table, it will be divided wherever a page 

break occurs. You can make adjustments to the table so that the table 

headings are repeated on each page. 

Repeated table headings are visible only in Print Layout view and when you 

print the document. 
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1. Select the heading row or rows. The selection must include the first row 

of the table. 

2. Under Table Tools, on the Layout tab, in the Data group, 

click Repeat Header Rows. 

Note:  Word automatically repeats the table headings on each new page 

that results from an automatic page break. Word does not repeat a heading 

if you insert a manual page break within a table. 

Control where a table is divided 

When you work with a very long table, it must be divided wherever a page 

break occurs. By default, if a page break occurs within a large row, 

Microsoft Word allows a page break to divide the row between the two 

pages. 

You can make adjustments to the table to make sure that the information 

appears as you want it to when the table spans multiple pages. 

Prevent a table row from breaking across pages 

1. Click in the table. 

2. Under Table Tools, click the Layout tab. 

3. In the Table group, click Properties, and then click the Row tab. 

4. Clear the Allow row to break across pages check box. 

Force a table to break across pages at a particular row 

1. Click in the row that you want to appear on the next page. 

2. Press CTRL+ENTER. 
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Add a drawing to a document 

These are the basic types of graphics that you can use to enhance your 

Word documents: drawing objects, SmartArt, charts, pictures, and clip art. 

Drawings refer to a drawing object or a group of drawing objects. 

Drawing objects include shapes, diagrams, flowcharts, curves, lines, and 

WordArt. These objects are part of your Word document. You can change 

and enhance these objects with colors, patterns, borders, and other effects. 

Add a drawing to a document 

1. Click in your document where you want to create the drawing. 

2. On the Insert tab, in the Illustrations group, click Shapes. 

 

3. You can do any of the following on the Format tab, which appears after 

you insert a drawing shape: 

4. Insert a shape. On the Format tab, in the Insert Shapes group, click 

a shape, and then click somewhere in the document. 

5. Change a shape. Click the shape you want to change. On 

the Format tab, in the Insert Shapes group, click Edit Shape, point 

to Change Shape, and then choose a different shape. 

 9.8 Drawing 
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6. Add text to a shape. Click the shape you where you want text, and 

then type. 

7. Group selected shapes. Select several shapes at a time by pressing 

CTRL on your keyboard and clicking each shape you want to include in 

the group. On the Format tab in the Arrange group, click Group so 

that all of the shapes will be treated like a single object. 

8. Draw in the document. On the Format tab, in the Insert 

Shapes group, expand the shapes options by clicking the arrow. 

Under Lines click Freeform or Scribble. 

Tip: To stop drawing with the Freeform or Scribble lines, double-click. 

9. Adjust the size of the shapes. Select the shape or shapes you want 

to resize. On the Format tab, in the Size group, click the arrows or type 

new dimensions in the Height and Width boxes. 

10. Apply a style to a shape. In the Shape Styles group, rest your 

pointer over a style to see what your shape will look like when you apply 

that style. Click the style to apply it. Or, click Shape Fill or Shape 

Outline and select the options that you want. 

 

Note: If you want to apply a color and gradient that aren't available in 

the Shape Styles group, select the color first, and then apply the 

gradient. 
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11. Add flow charts with connectors. Before you create a flow 

chart, add a drawing canvas by clicking the Insert tab, 

clicking Shapes in the Illustrations group, and then 

clicking New Drawing Canvas. On the Format tab, in 

the Insert Shapes group, click a Flow chart shape. Under Lines, 

choose a connector line such as the Curved Arrow Connector. 

12. Use shadow and three-dimensional (3-D) effects to add 

interest to the shapes in your drawing. On the Format tab, in 

the Shape Styles group, click Shape Effects, and choose an 

effect. 

13. Align the objects on the canvas. To align the objects, press 

and hold CTRL while you select the objects that you want to align. 

On the Format tab, in the Arrange group, click Align to choose 

from an assortment of alignment commands. 

Delete all or part of a drawing 

1. Select the drawing object that you want to delete. 

2. Press DELETE. 

 

Add shapes 

You can add shapes, such as boxes, circles, and arrows, to your documents, 

email messages, slide shows, and spreadsheets. To add a shape, 

click Insert, click Shapes, select a shape, and then click and drag to draw 

the shape. 

After you add one or more shapes, you can add text, bullets, and 

numbering to them, and you can change their fill, outline, and other effects 

on the Format tab. 
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Tip: You can add individual shapes to a chart, or add shapes on top of a 

SmartArt graphic to customize the chart or the graphic. 

Add a shape in Excel, Outlook, Word, or PowerPoint 

1. On the Insert tab, click Shapes. 

 

2. Click the shape you want, click anywhere in the workspace, and then 

drag to place the shape. 

 

To create a perfect square or circle (or constrain the dimensions of other 

shapes), press and hold Shift while you drag. 

Add a shape in Project  

To follow these steps, you need to open or create a report. To do that, on 

the Report tab, click Recent to open an existing report, or click More 

Reports to select a report from the list in the Reports dialog box or 

create a new report. 
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1. In the open report, on the Design tab, click Shapes. 

 

2. Click the shape you want, click anywhere in the workspace, and then 

drag to place the shape. 

 

To create a perfect square or circle (or constrain the dimensions of other 

shapes), press and hold Shift while you drag. 

Add text to a shape 

Insert a shape, or click an existing shape, and then enter text. 

1. Right-click the shape and click Add Text or Edit Text, or just start 

typing. 

Note: The text that you add becomes part of the shape — if you rotate 

or flip the shape, the text rotates or flips also. 

2. To format and align your text, click the Home tab, and then choose 

options from the Font, Paragraph, or Alignment groups, depending 
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on the program you're using and what kind of formatting you want to 

apply. (Text formatting options are limited in Project.) 

 

Change from one shape to another shape 

1. Click the shape you want to change. 

To change multiple shapes, press Ctrl while you click the shapes that 

you want to change. 

2. On the Format tab, in the Insert Shapes group, click Edit 

Shape , point to Change Shape, and then click the new 

shape that you want. 

Add the same shape multiple times 

If you need to add the same shape repeatedly, you can do so quickly by 

using Lock Drawing Mode. 

Note: Instead of adding individual shapes to create a drawing, you might 

want to choose a SmartArt graphic. In a SmartArt graphic, the arrangement 

of the shapes and the font size in those shapes is updated automatically as 

you add or remove shapes and edit your text. 

1. On the Insert tab, click Shapes. 

2. Right-click the shape you want to add, and then click Lock Drawing 

Mode. 



 

 

 

131 

 

3. Click anywhere in the workspace, and then drag to place the shape. 

4. Repeat step 3 to add the shape as many times as you like. 

Tip: To create a perfect square or circle (or constrain the dimensions 

of other shapes), press and hold Shift while you drag. 

5. After you add all the shapes you want, press Esc to turn off Lock 

Drawing Mode. 

 

Add a bulleted or numbered list to a shape 

1. Select the text in the shape that you want to add bullets or numbering 

to. 

2. Select the Home tab on the ribbon, and in the Paragraph group, 

select Bullets or Numbering. 
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You can find different bullet styles and numbering formats by clicking 

the down arrow next to Bullets or Numbering. 

Add a Quick Style to a shape 

Quick Styles let you apply a style to your shape with one click. You'll find 

the styles in the Quick Style gallery. When you rest your pointer over a 

Quick Style thumbnail, you can see how the style affects your shape. 

1. Click the shape you want to change. 

2. Select the Format tab, and in the Shape Styles group, select the 

Quick Style you want to use. 

 

To see more Quick Styles, click the More button . 

Delete a shape 

Click the shape that you want to delete, and then press Delete. To delete 

multiple shapes, press Ctrl while you click the shapes that you want to 

delete, and then press Delete. 
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Insert pictures 

1. Do one of the following: 

▪ Select Insert > Pictures > This Device for a picture on your 

PC. 

▪ Select Insert > Pictures > Stock Images for high quality 

images or backgrounds. 

▪ Select Insert > Pictures > Online Pictures for a picture on 

the web. 

Tip: For a picture from your OneDrive, go to the drop-down list at 

the top left, and switch from Bing to OneDrive. 

 

 

2. Select the picture you want, and then select Insert. 

Resize or move pictures 

▪ To resize a picture, select the picture and drag a corner handle. 

▪ To wrap text around a picture, select the picture, and then select a 

wrapping option. 
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Tip: Pick something other than In Line with Text, and you can 

move the picture around the page: select the picture and drag it. 

Crop a picture in Office 

Crop a picture to trim away outer edges that are unnecessary. 

Crop the margins of a picture 

1. Use Insert > Picture to add the image to an Office file (such as a Word 

document, PowerPoint presentation, or Excel workbook). 

2. Right-click the picture. A pop-up menu appears with two buttons either 

immediately above or below the menu. Crop is one of the buttons. 



 

 

 

135 

 

3. Select the Crop   button. 

Black crop handles appear on the edges and corners of the picture. 

 

4. Crop the image by doing one of the following: 

Description Action 

Crop one side Drag inward on the side cropping 

handle 

Crop two adjacent sides at the 

same time 

Drag inward on the corner cropping 

handle 

Crop equally on two parallel 

sides at once 

Press and hold Ctrl while dragging 

inward on the side cropping handle 
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5. You can also outcrop, or add a margin around a picture, by dragging the 

cropping handles outward rather than inward. 

6. (Optional) To reposition the crop area, either change the crop area by 

dragging the edges or corners of the crop rectangle, or move the picture. 

7. When you're finished, press Esc or click anywhere outside the picture 

within the document. 

Note: Cropping tools are not available for shapes, but in Office 2010 and 

later, you can resize a shape and use the Edit Points tool to achieve an 

effect similar to cropping or to customize the shape.  

 

 

 

 

Page numbering in Word 

A header or footer can contain text, information about the document, or 

even images. However, the most common elements in a header or footer 

are page numbers. Page numbers can be continuous though a document, 

all but the first page, or start over in each section. 

Note: The best way to work with page numbers is in Word on a laptop or 

desktop computer, rather than in a web browser or mobile app.  

Add page numbers to a header or footer in Word 

Add page numbers to a header or footer 

1. Click or tap in the header or footer where you want the page numbers 

to go. 

 9.9 Page Numbering 
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2. Go to Insert > Page Numbering. 

3. Select Current Position. 

4. Choose a style. 

 

Change where the page number appears 

1. In the header or footer area, select the page number. 

2. Use the Tab key to position the page number left, center, or right. If the 

number is flush left, press Tab once for center, and twice for right. To 

go back, press Backspace until in position. 

Change appearance of page number 

1. Select the page number 

2. On the Home tab, use the Font choices and dialog box to change the 

font family, style, size, and color. 
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Print a document in Word 

Before you print, you can preview your document and specify which pages 

you want to print. 

Preview your document 

1. Click File > Print. 

2. To preview each page, click the forward and backward arrows at the 

bottom of the page. 

 

If the text is too small to read, use the zoom slider at the bottom of 

the page to enlarge it. 

 

3. Choose the number of copies, and any other options you want, and 

click the Print button. 

 9.10 Printing 
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Print specific pages 

1. Click File > Print. 

2. To print only certain pages, print some of the document’s properties, or 

print tracked changes and comments, click the arrow under Settings, 

next to Print All Pages (the default), to see all of your options. 

 

3. To print only certain pages, do one of the following: 

▪ To print the page shown in preview, select Print Current Page. 

▪ To print consecutive pages like 1 -3, select Custom Print and 

enter the first and last page numbers in the Pages box. 
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▪ To print individual pages and a range of pages (like page 3, and 

pages 4-6) at the same time, select Custom Print, and enter the 

page numbers and ranges separated by commas (e.g. 3, 4-6). 

 

Print in color 

Note: If the printer you've chosen under Printer supports color, black 

and white, and grayscale printing options, the options will appear in the 

list under Settings. 

1. Click File > Print. 

2. Under Settings, choose the color printing option, and any other 

options you want, and click the Print button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Instructions: Find the true statement below. Then, rewrite the 
remaining false statements so they are true. 

1. Italicizing a word is an example of character formatting. 
2. To center selected paragraphs, click the Center button on the 

Formatting toolbar. 

3. To center a graphic in a Word document, right-click anywhere on 
the graphic and select Center from the shortcut menu. 

4. To save a Word document as a Web page, click the Save As Web 
button on the Standard toolbar. 

 

 

 

 

                                    
Write a letter to your lecturer to ask her/his permission to use 

computer lab 

 

Checkpoint 9 
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Multiple Choice 

Instructions: Select the best answer. 

1. The _____ bar contains buttons that allow you to speak commands.  
a. Status  

b. Talk 
c. Language 

d. Speak 

2. A(n) _____ contains buttons and boxes that allow you to perform 
frequent tasks quickly. 

a. indicator 
b. toolbar 

c. Scroll bar 

d. task pane 

3. _____ are used to display different portions of your document in the 

document window.  
a. Status indicators 

b. Toolbars 

c. Scroll bars 

d. Rulers 

4. The Language bar can be in any state except the following. 
a. Opened 

b. Closed 

c. Hidden 

d. Restored 

5. If a word you type is not in Word's dictionary, a _____ wavy underline 
displays below the word, and a red _____ displays on the Spelling 

and Grammar Checking Status icon.  

a. green, check mark 
b. green, X 

c. red, check mark 
d. red, X 

 

6. The file type _____ indicates that the file is a Word document.  
a. .word 

b. .doc 
c. .file 

d. .wd 
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7. The _____ command can be used to duplicate an action that you 
wish to perform again. 

a. Repeat 
b. Redo 

c. Undo 
d. Copy 

 

8. Selected graphics display _____ handles at the corner and middle 
locations. 

a. selection 
b. sizing 

c. picture 

d. resizing 

9. _____ the OVR status indicator to toggle between overtype and 

insert mode.  
a. Click 

b. Right-click 
c. Double-click 

d. Drag 

10. To close a document and start over, _____.  
a. click Close on the File menu 

b. click the Close button at the right edge of the menu bar 
c. click the Close button on the Standard toolbar 

d. both a and b 

 

 

 

This chapter teach how to use Microsoft Word to create documents 

SUMMARY 
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Format Bold 
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Table Alignment 

Paragraph Picture 

Bullet Numbering 
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With PowerPoint on your PC, Mac, or mobile device: 

 Create presentations from scratch or a template. 

 Add text, images, art, and videos. 

 Select a professional design with PowerPoint Designer. 

 Add transitions, animations, and motion. 

 Save to OneDrive, to get to your presentations from your computer, 

tablet, or phone. 

 Share and work with others, wherever they are. 

 

 

 

 

 

By the end of topic, you should be able to: 

Create a Powerpoint presentation that consists ot slide transition, 

animations, picture, video, and sound 

 

LEARNING OUTCOMES 

TOPIC 

10 

 

Microsoft PowerPoint 

 

 10.1 Introduction  
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Create a presentation 

1. Open PowerPoint. 

2. Select an option: 

▪ Select Blank Presentation to create a presentation from scratch. 

▪ Select one of the templates. 

▪ Select Take a Tour, and then select Create, to see tips for using 

PowerPoint. 

 

 

Add a slide 

1. Select the slide you want your new slide to follow. 

2. Select Home > New Slide. 

3. Select Layout and the you type want from the drop-down. 
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Add and format text 

1. Place the cursor where you want, and type. 

2. Select the text, and then select an option on 

the Home tab: Font, Font size, Bold, Italic, Underline, ... 

3. To create bulleted or numbered lists, select the text, and then 

select Bullets or Numbering. 
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Add a picture, shape, and more 

1. Select Insert. 

2. To add a picture: 

▪ Select Pictures. 

▪ Browse for the picture you want and select Insert. 

3. To add illustrations: 

▪ Select Shapes, Icons, 3D Models, SmartArt, or Chart. 

▪ Select the one you want. 

 

 

 

 

Choose the right view for the task in PowerPoint 

You can view your PowerPoint file in a variety of ways, depending on the 

task at hand. Some views are helpful when you're creating your 

presentation, and some are most helpful for delivering your presentation. 

 10.2 View 
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You can find the different PowerPoint view options on the View tab, as 

shown below. 

 

You can also find the most frequently used views on the task bar at the 

bottom right of the slide window, as shown below. 

 

Views for creating your presentation 

Normal view 

You can get to Normal view from the task bar  at the bottom of the 

slide window, or from the View tab on the ribbon. 

Normal view is the editing mode where you’ll work most frequently to 

create your slides. Below, Normal view displays slide thumbnails on the 

left, a large window showing the current slide, and a section below the 

current slide where you can type your speaker notes for that slide. 
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Slide Sorter view 

You can get to Slide Sorter view from the task bar  at the bottom of 

the slide window, or from the View tab on the ribbon. 

Slide Sorter view (below) displays all the slides in your presentation in 

horizontally sequenced, thumbnails. Slide show view is helpful if you need 

to reorganize your slides—you can just click and drag your slides to a new 

location, or add sections to organize your slides into meaningful groups. 
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Notes Page view 

You can show or hide your speakers notes with 

the Notes button  at the bottom of the slide window, or you can 

get to Notes Page view from the View tab on the ribbon. 

The Notes pane is located beneath the slide window. You can print your 

notes or include the notes in a presentation that you send to the audience, 

or just use them as cues for yourself while you're presenting. 
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Outline view 

You can get to Outline view from the View tab on the ribbon.  

Use Outline view to create an outline or story board for your presentation. 

It displays only the text on your slides, not pictures or other graphical 

items. 
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Master views 

To get to a master view, on the View tab, in the Master Views group, 

choose the master view that you want. 

Master views include, Slide, Handout, and Notes. The key benefit to 

working in a master view is that you can make universal style changes to 

every slide, notes page, or handout associated with your presentation. 

Views for delivering and viewing a presentation 

Slide Show view 

You can get to SlideShow view from the task bar  at the bottom 

of the slide window. 

Use Slide Show view to deliver your presentation to your audience. Slide 

Show view occupies the full computer screen, exactly the way your 

presentation will look on a big screen when your audience sees it. 
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Presenter view 

To get to Presenter view, in Slide Show view, in the lower left corner of 

the screen, click , and then click Show Presenter View (as shown 

below). 

Use Presenter view to view your notes while delivering your presentation. 

In Presenter view, your audience cannot see your notes. 

 

Reading view 

You can get to Reading view from the task bar  at the bottom of the 

slide window. 

Most people reviewing a PowerPoint presentation without a presenter will 

want to use Reading view. It displays the presentation in a full screen like 
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Slide Show view, and it includes a few simple controls to make it easy to 

flip through the slides. 

 

 

 

Slide transitions are the animation-like effects that happen when you move 

from one slide to the next during a presentation. Add slide transitions to 

bring your PowerPoint presentation to life. 

1. Select the slide you want to add a transition to. 

2. Select the Transitions tab and choose a transition. 

3. Select a transition to see a preview. 

4. Select Effect Options to choose the direction and nature of the 

transition. 

Note: Not every transition has Effect Options. 

5. Select Preview to see what the transition looks like. 

To remove a transition, select Transitions > None. 

 

Add, change, or remove transitions between slides 

A slide transition is the visual effect that occurs when you move from one 

slide to the next during a presentation. You can control the speed, add 

sound, and customize the look of transition effects. 

 

10.3 Transition 
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Add slide transitions to bring your presentation to life 

1. Select the slide you want to add a transition to. 

2. Select the Transitions tab and choose a transition. Select a transition 

to see a preview. 

3. Select Effect Options to choose the direction and nature of the 

transition. 

4. Select Preview to see what the transition looks like. 

To remove a transition, select Transitions > None. 

Set the timing and speed of a transition 

You can modify the duration of a transition, modify the transition effect, 

and even specify a sound to play during a transition. Also, you can specify 

the time to spend on a slide before advancing to the next. 

Set the speed of a transition 

Use Duration to set transition speed. A shorter duration means that a slide 

advances faster, and a larger number makes the slide advance more slowly. 

1. Select the slide that has the transition that you want to modify. 

2. On the Transitions tab, in the Timing group, in the Duration box, 

type the number of seconds that you want. 
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Tip: If you want all the slide show's transitions to use the same speed, 

click Apply to All. 

 

Modify the effect options for a transition 

Many, but not all, of the transitions in PowerPoint can be customized. 

1. Select the slide that has the transition you want to modify. 

2. On the Transitions tab, in the Transition to This Slide group, 

click Effect Options and select the option that you want. 

 

In this example, a Gallery transition is applied to the slide and the From 

Right option is selected. 
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A Gallery transition, with the From Right option selected, during a 

presentation. 

Specify a time to advance to the next slide 

Advance Slide sets the transition timing by specifying how long a slide 

stays in view before the transition to the next slide begins. If no timing is 

selected, slides advance when you click the mouse. 

1. Select the slide that you want to set the timing for. 

2. On the Transitions tab, in the Timing group, under Advance Slide, 

do one of the following: 

 

▪ To make the slide advance to the next slide when you click the 

mouse, select the On Mouse Click check box. 

▪ To make the slide advance automatically, select the After check 

box, and then enter the number of minutes or seconds that you 

want. The timer starts when the final animation or other effect 

on the slide finishes. 

▪ To enable both the mouse and automatic advance, select both 

the On Mouse Click check box and the After check box. Then, 

at After, enter the number of minutes or seconds that you want. 

The slide will advance automatically, but you can advance it 

more quickly by clicking the mouse. 
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Tip: If you want all the slides to advance using the same speed, 

click Apply to All. 

 

Set a sound to play during a transition 

1. Select the slide that has the transition that you want to modify. 

2. On the Transitions tab, in the Timing group, in the Sound list, select 

the sound that you want. 

 

Note: If you want to use your own sound, in the Sound list, 

select Other Sound. Then, in the Add Audio dialog box, select the 

sound that you want, and then click OK 

 

 

 

Animation can help make a PowerPoint presentation more dynamic, and 

help make information more memorable. The most common types of 

animation effects include entrances and exits. You can also add sound to 

increase the intensity of your animation effects. 

Presentation experts recommend using animations and sound effects 

sparingly. Animation can be useful in making a presentation more dynamic, 

and help to emphasize points, but too much animation can be distracting. 

Do not let animation and sound take the focus away from what you are 

saying. 

 10.4 Animations 
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Add animations and effects 

1. Select the object or text you want to animate. 

2. Select Animations and choose an animation. 

3. Select Effect Options and choose an effect. 

Manage animations and effects 

There are different ways to start animations in your presentation: 

▪ On Click - Start an animation when you click a slide. 

▪ With Previous - Play an animation at the same time as the previous 

animation in your sequence. 

▪ After Previous - Start an animation immediately after the previous 

one happens. 

▪ Duration - Lengthen or shorten an effect. 

▪ Delay - Add time before an effect runs. 

Add more effects to an animation 

1. Select an object or text with an animation. 

2. Select Add Animation and choose one. 

Change the order of animations 

1. Select an animation marker. 

2. Choose the option you want: 

▪ Move Earlier - Make an animation appear earlier in the 

sequence. 

▪ Move Later - Make an animation occur later in the sequence. 
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Add animation to grouped objects 

You can add an animation to grouped objects, text, and more. 

1. Press Ctrl and select the objects you want. 

2. Select Format > Group > Group to group the objects together. 

3. Select Animations and choose an animation. 

 

Animate text or objects 

You can animate the text, pictures, shapes, tables, SmartArt graphics, and 

other objects in your PowerPoint presentation. 

Effects can make an object appear, disappear, or move. They can change 

an object's size or color. 

Add animations to text, pictures, shapes, and more in your 

presentation 

1. Select the object or text you want to animate. 

2. Select Animations and choose an animation. 

3. Select Effect Options and choose an effect. 

Manage animations and effects 

There are different ways to start animations in your presentation: 

▪ On Click: Start an animation when you click a slide. 

▪ With Previous: Play an animation at the same time as the previous 

animation in your sequence. 
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▪ After Previous: Start an animation immediately after the previous one 

happens. 

▪ Duration: Lengthen or shorten an effect. 

▪ Delay: Add time before an effect runs. 

Add more effects to an animation 

1. Select an object or text with an animation. 

2. Select Add Animation and choose one. 

Change the order of animations 

1. Select an animation marker. 

2. Choose the option you want: 

▪ Move Earlier: Make an animation appear earlier in the sequence. 

▪ Move Later: Make an animation occur later in the sequence. 

Add animation to grouped objects 

You can add an animation to grouped objects, text, and more. 

1. Press Ctrl and select the objects you want. 

2. Select Format > Group > Group to group the objects together. 

3. Select Animations and choose an animation. 
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Animate or make words appear one line at a time 

Make text appear one line at a time 

1. On the slide, select the box that contains your text. 

2. Select the Animations tab, and then pick an animation, such 

as Appear, Fade In, or Fly In. 

 

For some animations, such as Fly In, select Effects Options, as 

you’ll need to pick a direction for the bullets to fly in from, such as 

bottom, top, left, or right. 

3. Select Effect Options, and then select By Paragraph to make the 

paragraphs of text appear one at a time. (The other option, All at Once, 

makes all the lines of text appear at the same time.) 
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PowerPoint immediately previews the animation for you. 

By default, when you present in Slide Show, each paragraph appears in 

response to a click. That way, you control when each paragraph appears. 

You can modify this setting by using the Start, Duration, 

and Delay controls on the far-right end of the Animation tab of the 

ribbon. 
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Make text appear one letter at a time 

You can also create a "typing" visual effect by making characters in a 

paragraph appear one at a time. 

1. On the slide, select the box that contains your text. 

2. Select the Animations tab, and then select the Add Animation drop-

down menu to select an animation, such as Appear, Fade, or Fly In. 

 

3. Select the Animations tab, and then select Animation pane. 

 

The Animation Pane opens on the right side of the PowerPoint 

window. 

4. In the Animation Pane, select the arrow next to your animation, and 

select Effect Options. 

5. In the dialog box, on the Effect tab under Enhancements, select the 

arrow next to Animate text, and select By letter. You can change the 

delay time in the % delay between letters box. 
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PowerPoint immediately previews the animation for you so that you can see 

the timing as the characters appear individually. You can repeat the preview 

by selecting the animation in the Animation Pane and selecting Play 

Selected. 

 

 

 

Using the Recording tab introduced in PowerPoint 2016, you can add a 

screenshot, screen recording, audio (such as background music), or video 

to a slide. 

 10.5 Inserting Audio and Video 
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Tip: Don't see the Recording tab? Right-click any tab in PowerPoint and 

select Customize the Ribbon. On the right side of the dialog box you'll 

see a list of tabs. Make sure Recording is checked. 

Insert a screenshot 

Open the slide where you want the screenshot to be inserted. 

Click Recording tab > Screenshot button > (the gallery of windows 

opens) 

Either select one of the windows shown (for a full-window clipping of that 

app) or select Screen Clipping to define the area on your screen that you 

want to capture. 

Insert a screen recording 

▪ You can record your computer screen and related audio, and then embed 

it into your PowerPoint slide―or you can save it as a separate file.  

Insert a video file 

1. Open the slide where you want to add the video. 

2. Click Recording tab > Video > and then browse to the location on your 

computer or network where the video file is stored. Select the file and 

click Insert. 

The video will "auto-play"   That means that when viewers look at 

the presentation in Slide Show, and they arrive at the slide where the 

video is placed, the video immediately begins to play. The viewer doesn't 

need to click Play to start it. When the video finishes playing, the slide 

show automatically advances to the next slide. 

Important:   If you insert a video this way, then subsequently trim the 

video, the trimming doesn't alter the auto-advance timing for the video. 
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You must manually set the slide to advance at the appropriate time. 

(Select the video, click the Transitions tab of the ribbon, and at the far 

right end of the ribbon, adjust the Advance Slide > After setting to 

the amount of time that equals the length of the trimmed video.) 

 

Embed a web video 

▪ Click Insert tab > Video > Online Video and then select or specify 

the video you want to embed. 

Insert an audio file 

1. Open the slide where you want to add the audio file. 

2. Click Recording tab > Audio > Audio on My PC > and then browse to 

the location on your computer or network where the audio file is stored. 

Select the file and click Insert. 

The recording will "auto-play"   That means that when viewers look 

at the presentation in Slide Show, and they arrive at the slide where the 

audio recording is placed, it immediately begins to play. The viewer 

doesn't need to click Play to start it. When the audio finishes playing, 

the slide show automatically advances to the next slide. 

Record sound and insert it on a slide 

1. Open the slide where you want to add the audio. 

2. Click Recording tab > Audio > Record Sound 
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3. In the Record Sound dialog box, click the Record button , and begin 

speaking or playing your own audio. Click the square stop button when 

you are done. Assign a name to the recording if you like. Then click OK, 

and the recording is placed on the current slide, represented by the 

standard audio icon. 

 

The recording will "auto-play"   That means that when viewers look at 

the presentation in Slide Show, and they arrive at the slide where the audio 

recording is placed, it immediately begins to play. The viewer doesn't need 

to click Play to start it. When the audio finishes playing, the slide show 

automatically advances to the next slide. 

 

 

 

Start a slide show 

1. To start your slide show, on the Slide Show tab, select Play From 

Beginning. 

 

(If you've turned off the Simplified Ribbon, you don't have a Slide 

Show tab; instead use the View tab to start Slide Show.) 

 10.1 Slide Show  
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2. To manage your slide show, go to the controls in the bottom-left 

corner  and do any of the following: 

Select To 

 

Go to the previous slide 

 

Go to the next slide 

 

View all slides 

To skip to a particular slide, simply click it in this Grid view. 

 

Turn subtitles on or off 

 

End the slide show 

3. To skip to any slide in the presentation, right-click the screen and 

select Go to Slide. Then, enter the slide number you want in 

the Slide box, and select OK. 
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Instructions: Find the true statement below. Then, rewrite the 
remaining false statements so they are true. 
1. Powerpoint has 3 different type of view, that is reading, outline and 

normal view 

2. You can insert an online video into your presentation 

3. You cannot record your presentation. 

• Powerpoint is a software that can helps you to create an interesting 

presentation using its element 

SUMMARY 

 

 

 

 

                                    
Create a presentation about yourself. 

 
 ACTIVITY 

Checkpoint 10 

 KEY TERM 

Presentation  Slide 

Transition Animations 
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Create a workbook in Excel 

Excel makes it easy to crunch numbers. With Excel, you can streamline 

data entry with AutoFill. Then, get chart recommendations based on your 

data, and create them with one click. Or easily spot trends and patterns 

with data bars, color coding, and icons. 

Create a workbook 

1. Open Excel. 

2. Select Blank workbook. 

Or press Ctrl+N. 

 

 

By the end of topic, you should be able to: 

1. Create data analysis using Excel 

2. Create a graph using Excel 
 

LEARNING OUTCOMES 

TOPIC 

11 

 

Microsoft Excel 

 

 11.1 Introduction 
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Enter data 

To manually enter data: 

1. Select an empty cell, such as A1, and then type text or a number. 

2. Press Enter or Tab to move to the next cell. 

To fill data in a series: 

1. Enter the beginning of the series in two cells: such as Jan and Feb; or 

2014 and 2015. 

2. Select the two cells containing the series, and then drag the fill 

handle  across or down the cells. 

 

 

 

Basic tasks in Excel 

Excel is an incredibly powerful tool for getting meaning out of vast amounts 

of data. But it also works well for simple calculations and tracking almost 

 11.2 Working with Sheet 
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any kind of information. The key for unlocking all that potential is the grid 

of cells. Cells can contain numbers, text, or formulas. You put data in your 

cells and group them in rows and columns. That allows you to add up your 

data, sort and filter it, put it in tables, and build great-looking charts. Let’s 

go through the basic steps to get you started. 

Create a new workbook 

Excel documents are called workbooks. Each workbook has sheets, typically 

called spreadsheets. You can add as many sheets as you want to a 

workbook, or you can create new workbooks to keep your data separate. 

1. Click File, and then click New. 

2. Under New, click the Blank workbook. 

 

 

Enter your data 

1. Click an empty cell. 

For example, cell A1 on a new sheet. Cells are referenced by their 

location in the row and column on the sheet, so cell A1 is in the first row 

of column A. 
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2. Type text or a number in the cell. 

3. Press Enter or Tab to move to the next cell. 

 

Apply cell borders 

1. Select the cell or range of cells that you want to add a border to. 

2. On the Home tab, in the Font group, click the arrow next to Borders, 

and then click the border style that you want. 

 

Apply cell shading 

1. Select the cell or range of cells that you want to apply cell shading to. 

2. On the Home tab, in the Font group, choose the arrow next to Fill 

Color , and then under Theme Colors or Standard Colors, select 

the color that you want. 

Apply a number format 

To distinguish between different types of numbers, add a format, like 

currency, percentages, or dates. 

1. Select the cells that have numbers you want to format. 

2. Click the Home tab, and then click the arrow in the General box. 
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3. Pick a number format. 

 

If you don’t see the number format you’re looking for, click More 

Number Formats.  
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Overview of formulas in Excel 

Get started on how to create formulas and use built-in functions to perform 

calculations and solve problems. 

Create a formula that refers to values in other cells 

1. Select a cell. 

2. Type the equal sign =. 

Note: Formulas in Excel always begin with the equal sign. 

3. Select a cell or type its address in the selected cell. 

 

4. Enter an operator. For example, – for subtraction. 

5. Select the next cell, or type its address in the selected cell. 

 

6. Press Enter. The result of the calculation appears in the cell with the 

formula. 

 11.3 Formula 
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Using calculation operators in Excel formulas 

Operators specify the type of calculation that you want to perform on the 

elements of a formula. Excel follows general mathematical rules for 

calculations, which is Parentheses, Exponents, Multiplication and 

Division, and Addition and Subtraction, or the 

acronym PEMDAS (Please Excuse My Dear Aunt Sally). Using parentheses 

allows you to change that calculation order. 

▪ Arithmetic operators 

To perform basic mathematical operations, such as addition, 

subtraction, multiplication, or division; combine numbers; and produce 

numeric results, use the following arithmetic operators. 

Arithmetic operator Meaning Example 

+ (plus sign) Addition =3+3 

– (minus sign) Subtraction 

Negation 

=3–3 

=-3 

* (asterisk) Multiplication =3*3 

/ (forward slash) Division =3/3 

% (percent sign) Percent 30% 

^ (caret) Exponentiation =3^3 

See a formula 

1. When a formula is entered into a cell, it also appears in the Formula 

bar. 
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2. To see a formula, select a cell, and it will appear in the formula bar. 

 

Enter a formula that contains a built-in function 

1. Select an empty cell. 

2. Type an equal sign = and then type a function. For example, =SUM for 

getting the total sales. 

3. Type an opening parenthesis (. 

4. Select the range of cells, and then type a closing parenthesis). 

 

5. Press Enter to get the result. 

Formulas in-depth 

You can browse through the individual sections below to learn more about 

specific formula elements. 

The parts of an Excel formula 

A formula can also contain any or all of the 

following: functions, references, operators, and constants. 
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Parts of a formula    

 

1. Functions: The PI() function returns the value of pi: 3.142... 

2. References: A2 returns the value in cell A2. 

3. Constants: Numbers or text values entered directly into a formula, such as 2. 

4. Operators: The ^ (caret) operator raises a number to a power, and the * 

(asterisk) operator multiplies numbers. 

 

Using constants in Excel formulas 

A constant is a value that is not calculated; it always stays the same. For 

example, the date 10/9/2008, the number 210, and the text "Quarterly 

Earnings" are all constants. An expression or a value resulting from an 

expression is not a constant. If you use constants in a formula instead of 

references to cells (for example, =30+70+110), the result changes only if 

you modify the formula. In general, it's best to place constants in individual 

cells where they can be easily changed if needed, then reference those cells 

in formulas. 

Using references in Excel formulas 

A reference identifies a cell or a range of cells on a worksheet, and tells 

Excel where to look for the values or data you want to use in a formula. 

You can use references to use data contained in different parts of a 

worksheet in one formula or use the value from one cell in several formulas. 

You can also refer to cells on other sheets in the same workbook, and to 

other workbooks. References to cells in other workbooks are called links or 

external references. 

https://support.microsoft.com/en-us/office/pi-function-264199d0-a3ba-46b8-975a-c4a04608989b
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The A1 reference styles 

By default, Excel uses the A1 reference style, which refers to columns with 

letters (A through XFD, for a total of 16,384 columns) and refers to rows 

with numbers (1 through 1,048,576). These letters and numbers are called 

row and column headings. To refer to a cell, enter the column letter 

followed by the row number. For example, B2 refers to the cell at the 

intersection of column B and row 2. 

To refer to Use 

The cell in column A and row 10 A10 

The range of cells in column A and rows 10 

through 20 

A10:A20 

The range of cells in row 15 and columns B 

through E 

B15:E15 

All cells in row 5 5:5 

All cells in rows 5 through 10 5:10 

All cells in column H H:H 

All cells in columns H through J H:J 

The range of cells in columns A through E and 

rows 10 through 20 

A10:E20 
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The difference between absolute, relative and mixed references 

 

Relative references     

A relative cell reference in a formula, such as A1, is based on the relative 

position of the cell that contains the formula and the cell the reference 

refers to. If the position of the cell that contains the formula changes, the 

reference is changed. If you copy or fill the formula across rows or down 

columns, the reference automatically adjusts. By default, new formulas use 

relative references. For example, if you copy or fill a relative reference in 

cell B2 to cell B3, it automatically adjusts from =A1 to =A2. 

Copied formula with relative reference    

 

 

 

Absolute references     

An absolute cell reference in a formula, such as $A$1, always refer to a cell 

in a specific location. If the position of the cell that contains the formula 

changes, the absolute reference remains the same. If you copy or fill the 

formula across rows or down columns, the absolute reference does not 

adjust. By default, new formulas use relative references, so you may need 

to switch them to absolute references. For example, if you copy or fill an 

absolute reference in cell B2 to cell B3, it stays the same in both cells: 

=$A$1. 
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Copied formula with absolute reference    

 

 

Mixed references     

A mixed reference has either an absolute column and relative row, or 

absolute row and relative column. An absolute column reference takes the 

form $A1, $B1, and so on. An absolute row reference takes the form A$1, 

B$1, and so on. If the position of the cell that contains the formula changes, 

the relative reference is changed, and the absolute reference does not 

change. If you copy or fill the formula across rows or down columns, the 

relative reference automatically adjusts, and the absolute reference does 

not adjust. For example, if you copy or fill a mixed reference from cell A2 

to B3, it adjusts from =A$1 to =B$1. 

Copied formula with mixed reference    
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SUM function 

The SUM function adds values. You can add individual values, cell 

references or ranges or a mix of all three. 

For example: 

▪ =SUM(A2:A10) Adds the values in cells A2:10. 

▪ =SUM(A2:A10, C2:C10) Adds the values in cells A2:10, as well as 

cells C2:C10. 

Syntax: 

SUM(number1,[number2],...) 

Argument name Description 

number1    

Required 

The first number you want to add. The number can 

be like 4, a cell reference like B6, or a cell range like 

B2:B8. 

number2-255    

Optional 

This is the second number you want to add. You can 

specify up to 255 numbers in this way. 

 

 

 

 

 11.4 Functions 
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Functions Errors 

 

#VALUE! errors from referencing text instead of numbers 

If you use a formula like: 

• =A1+B1+C1 or =A1+A2+A3 

 

Your formula can break if there are any non-numeric (text) values in 

the referenced cells, which will return a #VALUE! error. SUM will 

ignore text values and give you the sum of just the numeric values. 
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#REF! error from deleting rows or columns 

 

If you delete a row or column, the formula will not update to exclude 

the deleted row and it will return a #REF! error, where a SUM function 

will automatically update. 

 

 

AVERAGE function 

Returns the average (arithmetic mean) of the arguments. For example, if 

the range A1:A20 contains numbers, the 

formula =AVERAGE(A1:A20) returns the average of those numbers. 

Syntax 

AVERAGE(number1, [number2], ...) 

The AVERAGE function syntax has the following arguments: 
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▪ Number1    Required. The first number, cell reference, or range for 

which you want the average. 

▪ Number2, ...    Optional. Additional numbers, cell references or 

ranges for which you want the average, up to a maximum of 255. 

Remarks 

▪ Arguments can either be numbers or names, ranges, or cell references 

that contain numbers. 

▪ Logical values and text representations of numbers that you type directly 

into the list of arguments are not counted. 

▪ If a range or cell reference argument contains text, logical values, or 

empty cells, those values are ignored; however, cells with the value zero 

are included. 

▪ Arguments that are error values or text that cannot be translated into 

numbers cause errors. 

▪ If you want to include logical values and text representations of numbers 

in a reference as part of the calculation, use the AVERAGEA function. 

▪ If you want to calculate the average of only the values that meet certain 

criteria, use the AVERAGEIF function or the AVERAGEIFS function. 

Note: The AVERAGE function measures central tendency, which is the 

location of the center of a group of numbers in a statistical distribution. The 

three most common measures of central tendency are: 

▪ Average, which is the arithmetic mean, and is calculated by adding a 

group of numbers and then dividing by the count of those numbers. For 

example, the average of 2, 3, 3, 5, 7, and 10 is 30 divided by 6, which 

is 5. 

▪ Median, which is the middle number of a group of numbers; that is, half 

the numbers have values that are greater than the median, and half the 
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numbers have values that are less than the median. For example, the 

median of 2, 3, 3, 5, 7, and 10 is 4. 

▪ Mode, which is the most frequently occurring number in a group of 

numbers. For example, the mode of 2, 3, 3, 5, 7, and 10 is 3. 

For a symmetrical distribution of a group of numbers, these three measures 

of central tendency are all the same. For a skewed distribution of a group 

of numbers, they can be different. 

Tip: When you average cells, keep in mind the difference between empty 

cells and those containing the value zero, especially if you have cleared 

the Show a zero in cells that have a zero value check box in the Excel 

Options dialog box in the Excel desktop application. When this option is 

selected, empty cells are not counted, but zero values are. 

To locate the Show a zero in cells that have a zero value check box: 

▪ On the File tab, click Options, and then, in the Advanced category, 

look under Display options for this worksheet. 

MAX function 

Returns the largest value in a set of values. 

 

Syntax 

MAX(number1, [number2], ...) 

The MAX function syntax has the following arguments: 

▪ Number1, number2, ...    Number1 is required, subsequent 

numbers are optional. 1 to 255 numbers for which you want to find 

the maximum value. 
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MIN function 

Returns the smallest number in a set of values. 

Syntax 

MIN(number1, [number2], ...) 

The MIN function syntax has the following arguments: 

▪ Number1, number2, ...    Number1 is optional, subsequent numbers 

are optional. 1 to 255 numbers for which you want to find the minimum 

value. 

 

 

 

 

Create a chart from start to finish 

Charts help you visualize your data in a way that creates maximum impact 

on your audience. Learn to create a chart and add a trendline.  

Create a chart 

1. Select data for the chart. 

2. Select Insert > Recommended Charts. 

3. Select a chart on the Recommended Charts tab, to preview the chart. 

Note: You can select the data you want in the chart and press ALT + F1 

to create a chart immediately, but it might not be the best chart for the 

 11.5  Chart 
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data. If you don’t see a chart you like, select the All Charts tab to see 

all chart types. 

4. Select a chart. 

5. Select OK. 

Add a trendline 

1. Select a chart. 

2. Select Design > Add Chart Element. 

3. Select Trendline and then select the type of trendline you want, such 

as Linear, Exponential, Linear Forecast, or Moving Average. 

 

Choose your chart using Quick Analysis 

Quick Analysis takes a range of data and helps you pick the perfect chart 

with just a few commands.  

1. Select a range of cells. 

2. Select the Quick Analysis button that appears at the bottom right 

corner of the selected data. 

Or, press Ctrl + Q. 
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3. Select Charts. 

 

4. Hover over the chart types to preview a chart, and then select the 

chart you want. 
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Chart Types 

 

There are several options for chart types that you can choose to represent 

your data. Among the easy to use charts are; 

Column chart 

Data that’s arranged in columns or rows on a worksheet can be plotted in 

a column chart. A column chart typically displays categories along the 

horizontal (category) axis and values along the vertical (value) axis, as 

shown in this chart: 

 

 

Use this chart when you have multiple data series and you want to 

emphasize the total. 
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Line chart 

Data that's arranged in columns or rows on a worksheet can be plotted in 

a line chart. In a line chart, category data is distributed evenly along the 

horizontal axis, and all value data is distributed evenly along the vertical 

axis. Line charts can show continuous data over time on an evenly scaled 

axis, so they're ideal for showing trends in data at equal intervals, like 

months, quarters, or fiscal years. 

 

 

Notes:  

▪ Line charts work best when you have multiple data series in your 

chart—if you have only one data series, consider using a scatter 

chart instead. 

▪ Stacked line charts sum the data, which might not be the result 

you want. It might not be easy to see that the lines are stacked, 

so consider using a different line chart type or a stacked area chart 

instead. 
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Pie charts 

Data that's arranged in one column or row on a worksheet can be plotted 

in a pie chart. Pie charts show the size of items in one data series, 

proportional to the sum of the items. The data points in a pie chart are 

shown as a percentage of the whole pie. 

 

Consider using a pie chart when: 

▪ You have only one data series. 

▪ None of the values in your data are negative. 

▪ Almost none of the values in your data are zero values. 

▪ You have no more than seven categories, all of which represent 

parts of the whole pie. 

 

 

 

 



 

 

 

195 

Doughnut charts 

Data that's arranged in columns or rows only on a worksheet can be plotted 

in a doughnut chart. Like a pie chart, a doughnut chart shows the 

relationship of parts to a whole, but it can contain more than one data 

series. 

 

 

Note: Doughnut charts aren't easy to read. You may want to use a 

stacked column charts or Stacked bar chart instead. 
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Bar chart 

Data that's arranged in columns or rows on a worksheet can be plotted in 

a bar chart. Bar charts illustrate comparisons among individual items. In a 

bar chart, the categories are typically organized along the vertical axis, and 

the values along the horizontal axis. 

 

 

 

 

Consider using a bar chart when: 

▪ The axis labels are long. 

▪ The values that are shown are durations. 
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Area chart 

Data that's arranged in columns or rows on a worksheet can be plotted in 

an area chart. Area charts can be used to plot change over time and draw 

attention to the total value across a trend. By showing the sum of the 

plotted values, an area chart also shows the relationship of parts to a whole. 

 

Change a chart type 

If you have already have a chart, but you just want to change its type: 

1. Select the chart, click the Design tab, and click Change Chart 

Type. 

 

2. Choose a new chart type in the Change Chart Type box. 
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Instructions: Find the true statement below. Then, rewrite the 
remaining false statements so they are true. 

1. Excel will recalculate a formula if any changes are made to the data 
2. You can create many types of charts using excel 

3. You must insert; to enable you to calculate in excel 
 

Excel is a software to make data analysis and a graph 

SUMMARY 

 

 

 

 

 

 

                                    
Create a graph based on this data 

 

Location Date Rainfall (inch) Temperature(C)  

Melaka 10/20/2021 0.2 25 

Kuala Lumpur 10/20/2021 2.3 26 

Selangor 10/20/2021 1.3 27 

 

 
 ACTIVITY 

Checkpoint 11 

 KEY TERM 

Formula Function 

Graph Sort  
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What is a database? 

A database is a tool for collecting and organizing information. Databases 

can store information about people, products, orders, or anything else. 

Many databases start as a list in a word-processing program or 

spreadsheet. As the list grows bigger, redundancies and inconsistencies 

begin to appear in the data. The data becomes hard to understand in list 

form, and there are limited ways of searching or pulling subsets of data out 

for review. Once these problems start to appear, it's a good idea to transfer 

the data to a database created by a database management system (DBMS), 

such as MS Access. 

A computerized database is a container of objects. One database can 

contain more than one table. For example, an inventory tracking system 

that uses three tables is not three databases, but one database that 

contains three tables. Unless it has been specifically designed to use data 

or code from another source, an MS Access database stores its tables in a 

single file, along with other objects, such as forms, reports, macros, and 

 

By the end of topic, you should be able to: 

• Create table, form, report and queries using Access 

 

LEARNING OUTCOMES 
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Microsoft Access 

 12.1 Introduction 
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modules. Databases created in the MS Access 2007 format (which is also 

used by MS Access, 2016, MS Access 2013 and MS Access 2010) have the 

file extension .accdb, and databases created in earlier MS Access formats 

have the file extension .mdb. You can use MS Access 2016, MS Access 

2013, MS Access 2010, or MS Access 2007 to create files in earlier file 

formats (for example, MS Access 2000 and MS Access 2002-2003). 

Using MS Access, you can: 

 Add new data to a database, such as a new item in an inventory 

 Edit existing data in the database, such as changing the current 

location of an item 

 Delete information, perhaps if an item is sold or discarded 

 Organize and view the data in different ways 

 Share the data with others via reports, e-mail messages, an intranet , 

or the Internet 

 

 

 

Tables 

 

A database table is similar in appearance to a spreadsheet, in that data is 

stored in rows and columns. As a result, it is usually quite easy to import a 

 12.2 Objects in MS Access 
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spreadsheet into a database table. The main difference between storing 

your data in a spreadsheet and storing it in a database is in how the data 

is organized. 

To get the most flexibility out of a database, the data needs to be organized 

into tables so that redundancies don't occur. For example, if you're storing 

information about employees, each employee should only need to be 

entered once in a table that is set up just to hold employee data. Data 

about products will be stored in its own table, and data about branch offices 

will be stored in another table. This process is called normalization. 

Each row in a table is referred to as a record. Records are where the 

individual pieces of information are stored. Each record consists of one or 

more fields. Fields correspond to the columns in the table. For example, 

you might have a table named "Employees" where each record (row) 

contains information about a different employee, and each field (column) 

contains a different type of information, such as first name, last name, 

address, and so on. Fields must be designated as a certain data type, 

whether it's text, date or time, number, or some other type. 

Another way to describe records and fields is to visualize a library's old-

style card catalog. Each card in the cabinet corresponds to a record in the 

database. Each piece of information on an individual card (author, title, and 

so on) corresponds to a field in the database. 
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Forms 

 

Forms allow you to create a user interface in which you can enter and edit 

your data. Forms often contain command buttons and other controls that 

perform various tasks. You can create a database without using forms by 

simply editing your data in the table datasheets. However, most database 

users prefer to use forms for viewing, entering, and editing data in the 

tables. 

You can program command buttons to determine which data appears on 

the form, open other forms or reports, or perform a variety of other tasks. 

For example, you might have a form named "Customer Form" in which you 

work with customer data. The customer form might have a button which 

opens an order form where you can enter a new order for that customer. 

Forms also allow you to control how other users interact with the data in 

the database. For example, you can create a form that shows only certain 

fields and allows only certain operations to be performed. This helps protect 

data and to ensure that the data is entered properly. 
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Reports 

 

Reports are what you use to format, summarize and present data. A report 

usually answers a specific question, such as "How much money did we 

receive from each customer this year?" or "What cities are our customers 

located in?" Each report can be formatted to present the information in the 

most readable way possible. 

A report can be run at any time, and will always reflect the current data in 

the database. Reports are generally formatted to be printed out, but they 

can also be viewed on the screen, exported to another program, or sent as 

an attachment to an e-mail message. 

Queries 

 

Queries can perform many different functions in a database. Their most 

common function is to retrieve specific data from the tables. The data you 
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want to see is usually spread across several tables, and queries allow you 

to view it in a single datasheet. Also, since you usually don't want to see 

all the records at once, queries let you add criteria to "filter" the data down 

to just the records you want. 

Certain queries are "updateable," meaning you can edit the data in the 

underlying tables via the query datasheet. If you are working in an 

updateable query, remember that your changes are actually being made in 

the tables, not just in the query datasheet. 

Queries come in two basic varieties: select queries and action queries. A 

select query simply retrieves the data and makes it available for use. You 

can view the results of the query on the screen, print it out, or copy it to 

the clipboard. Or, you can use the output of the query as the record source 

for a form or report. 

An action query, as the name implies, performs a task with the data. Action 

queries can be used to create new tables, add data to existing tables, 

update data, or delete data. 

 

 

 

 

 Introduction to tables 

Tables are essential objects in a database because they hold all the 

information or data. For example, a database for a business can have a 

Contacts table that stores the names of their suppliers, e-mail addresses, 

and telephone numbers. Because other database objects depend so heavily 

on tables, you should always start your design of a database by creating all 
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its tables and then creating any other objects. Before you create tables, 

consider your requirements, and determine all the tables that you might 

need.  

Table Overview 

A relational database like MS Access usually has several related tables. In 

a well-designed database, each table stores data about a particular subject, 

such as employees or products. A table has records (rows) and fields 

(columns). Fields have different types of data, such as text, numbers, 

dates, and hyperlinks. 

 

1. A record: Contains specific data, like information about a particular 

employee or a product. 

2. A field: Contains data about one aspect of the table subject, such as 

first name or e-mail address. 

3. A field value: Each record has a field value. For example, Contoso, Ltd. 

or someone@example.com. 

 

 

 

mailto:someone@example.com
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Table and field properties 

Tables and fields also have properties that you can set to control their 

characteristics or behavior. 

 

In an MS Access database, table properties are attributes of a table that 

affect the appearance or behavior of the table. Table properties are set in 

the table's property sheet, in Design view. For example, you can set a 

table's Default View property to specify how the table is displayed by 

default. 

A field property applies to a particular field in a table and defines one of the 

field's characteristics or an aspect of the field's behavior. You can set some 

field properties in Datasheet view. You can also set any field property in 

Design view by using the Field Properties pane. 

Data types 

Every field has a data type. A field's data type indicates the kind of data 

that the field stores, such as large amounts of text or attached files. 
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A data type is a field property, but it differs from other field properties as 

follows: 

▪ You set a field's data type in the table design grid, not in the Field 

Properties pane. 

▪ A field's data type determines what other properties the field has. 

▪ You must set a field's data type when you create the field. 

You can create a new field in MS Access by entering data in a new column 

in Datasheet view. When you create a field by entering data in Datasheet 

view, MS Access automatically assigns a data type for the field, based 

on the value that you enter. If no other data type is implied by your 

input, MS Access sets the data type to Text. If needed, you can change 

the data type by using the Ribbon. 

Examples of automatic data type detection 

The following table shows how automatic data type detection works in 

Datasheet view. 

If you enter: MS Access creates a field 

with a data type of: 

John Text 

http://www.contoso.com 

You can use any valid Internet protocol 

prefix. For example, http://, https://, and 

mailto: are valid prefixes. 

Hyperlink 
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1 Number, Long Integer 

50,000 Number, Long Integer 

50,000.99 Number, Double 

50000.389 Number, Double 

12/67 

The date and time formats recognized are 

those of your user locale. 

Date/Time 

December 31, 2016 Date/Time 

10:50:23 Date/Time 

10:50 am Date/Time 

17:50 Date/Time 

$12.50 

The currency symbol recognized is that of 

your user locale. 

Currency 

Table relationships 

Although each table stores data about a different subject, tables in an MS 

Access database usually store data about subjects that are related to each 

other. For example, a database might contain: 

▪ A customers table that lists your company’s customers and their 

addresses. 

▪ A products table that lists the products that you sell, including prices 

and pictures for each item. 

▪ An orders table that tracks customer orders. 

Because you store data about different subjects in separate tables, you 

need some way to tie the data together so that you can easily combine 

related data from those separate tables. To connect the data stored in 
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different tables, you create relationships. A relationship is a logical 

connection between two tables that specifies fields that the tables have in 

common.  

Keys 

Fields that are part of a table relationship are called keys. A key usually 

consists of one field but may consist of more than one field. There are two 

kinds of keys: 

Primary key     

A table can have only one primary key. A primary key consists of one or 

more fields that uniquely identify each record that you store in the table. 

Often, there is a unique identification number, such as an ID number, a 

serial number, or a code, that serves as a primary key. For example, you 

might have a Customers table where each customer has a unique customer 

ID number. The customer ID field is the primary key of the Customers 

table. When a primary key contains more than one field, it is usually 

composed of pre-existing fields that, taken together, provide unique values. 

For example, you might use a combination of last name, first name, and 

birth date as the primary key for a table about people.  

Foreign key    

A table can also have one or more foreign keys. A foreign key contains 

values that correspond to values in the primary key of another table. For 

example, you might have an Orders table in which each order has a 

customer ID number that corresponds to a record in a Customers table. 

The customer ID field is a foreign key of the Orders table. 
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The correspondence of values between key fields forms the basis of a table 

relationship. You use a table relationship to combine data from related 

tables. For example, suppose that you have a Customers table and an 

Orders table. In your Customers table, each record is identified by the 

primary key field, ID. 

To associate each order with a customer, you add a foreign key field to the 

Orders table that corresponds to the ID field of the Customers table, and 

then create a relationship between the two keys. When you add a record 

to the Orders table, you use a value for customer ID that comes from the 

Customers table. Whenever you want to view any information about an 

order's customer, you use the relationship to identify which data from the 

Customers table corresponds to which records in the Orders table. 

1. A primary key, identified by the key icon next to the field name. 

2. A foreign key — note the absence of the key icon. 

Do not add a field if you expect that each unique entity represented in the 

table might require more than value for the field. Continuing the preceding 

example, if you want to start tracking orders placed by your customers, 

you do not add a field to the table, because each customer will have more  

Plan your tables with relationships in mind. You can use the Lookup Wizard 

to create a foreign key field if the table that contains the corresponding 

primary key already exists. The Lookup Wizard creates the relationship for 

you.  

Create a table and add fields 

When you create an MS Access database, you store your data in tables—

subject-based lists that contain rows and columns. For instance, you can 

create a Contacts table to store a list of names, addresses, and telephone 
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numbers, or a Products table to store information about products. This 

article explains how to create a table, add fields to a table, set a table's 

primary key, and how to set field and table properties. 

Before you create tables and add fields, make sure you understand the 

background concepts.  

Creating a table 

A simple database, such as a contact list, might use only a single table. 

Many databases, however, use several tables. When you create a new 

database, you create a new file on your computer that acts as a container 

for all of the objects in your database, including your tables. 

You can create a table by creating a new database, by inserting a table into 

an existing database, or by importing or linking to a table from another 

data source — such as a Microsoft Excel workbook, a Microsoft Word 

document, a text file, or another database. When you create a new, blank 

database, a new, empty table is automatically inserted for you. You can 

then enter data in the table to start defining your fields. 

Create a new table in a new database 

1. Click File > New, and then select Blank database. 

2. In the File Name box, type a file name for the new database. 

3. To browse to a different location and save the database, click the folder 

icon. 

4. Click Create. 
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The new database opens, and a new table named Table1 is created and 

opens in Datasheet view. 

Create a new table in an existing database 

1. Click File > Open, and click the database if it is listed under Recent. If 

not, select one of the browse options to locate the database. 

2. In the Open dialog box, select the database that you want to open, and 

then click Open. 

3. On the Create tab, in the Tables group, click Table. 
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A new table is inserted in the database and the table opens in Datasheet 

view. 

 

Importing or linking to create a table 

You can create a table by importing or linking to data that is stored 

elsewhere. You can import or link to data in an Excel worksheet, a 

SharePoint list, an XML file, another MS Access database, a Microsoft 

Outlook folder, and more. 

When you import data, you create a copy of the data in a new table in the 

current database. Subsequent changes to the source data will have no 

effect on the imported data, and changes to the imported data do not affect 

the source data. After you connect to a data source and import its data, 

you can then use the imported data without connecting to the source. You 

can change the design of an imported table. 

When you link to data, you create a linked table in the current database 

that represents a live link to the existing information that is stored 

elsewhere. When you change data in a linked table, you are changing it in 

the source. Whenever data changes in the source, that change is shown in 
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the linked table. You must be able to connect to the data source whenever 

you use a linked table. You cannot change the design of a linked table. 

Note: You cannot edit data in an Excel worksheet by using a linked table. 

As a workaround, import the source data into an MS Access database, and 

then link to the database from Excel. 

Create a new table by importing or linking to external data 

1. Click File > Open. 

2. In the Open dialog box, select and open the database in which you 

wish to create a new table. 

3. On the External Data tab, in the Import & Link group, click one of 

the available data sources.  

 

4. Follow the instructions in the dialog boxes that appear at each step. 

MS Access creates the new table and displays it in the Navigation 

Pane. 

Save a table 

After you create or modify a table, you should save its design. When you 

save a table for the first time, give it a name that describes the data that 

it contains. You can use up to 64 alphanumeric characters, including 

spaces. For example, you might name a table Customers, Parts Inventory, 

or Products. 
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MS Access gives you lots of flexibility when it comes to naming your tables; 

however, there are some restrictions to be aware of. A table name can be 

up to 64 characters long, can include any combination of letters, numbers, 

spaces, and special characters except a period (.), exclamation point (!), 

square brackets ([]), leading space, leading equal sign (=), or nonprintable 

character such as a carriage return. The name also cannot contain any of 

the following characters: / \ : ; * ? " ' < > | # <TAB> { } % ~ &. 

Tip: You should decide on a naming convention for the objects in your 

database, and use it consistently. 

1. Select File > Save, or press CTRL+S. 

2. If you are saving the table for the first time, type a name for the table, 

and then click OK. 

Setting a primary key 

Unless you have a specific reason not to, you should specify a primary key 

for a table. MS Access automatically creates an index for the primary key, 

which can help improve database performance. MS Access also makes sure 

that every record has a value in the primary key field, and that the value 

is always unique. Unique values are crucial, because otherwise there is no 

way to reliably distinguish a particular row from other rows. 

When you create a new table in Datasheet view, MS Access automatically 

creates a primary key for you and assigns it a field name of ID and the 

AutoNumber data type. 

In Design view, you can change or remove the primary key, or set the 

primary key for a table that doesn't already have one. 
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Determine which fields to use as a primary key 

Sometimes, you might already have data that you want to use as a primary 

key. For example, you may have existing ID numbers for your employees. 

If you create a table to track employee information, you might decide to 

use the existing employee ID as the primary key for the table. Or, perhaps 

employee ID is only unique in combination with department ID, requiring 

that you use both fields together as the primary key. A good candidate for 

the primary key has the following characteristics: 

▪ Each record has a unique value for the field or combination of fields. 

▪ The field or combination of fields is never empty or null — there is 

always a value. 

▪ The values do not change. 

If no suitable data exists to use as a primary key, you can create a new 

field to use as a primary key. When you create a new field to use as a 

primary key, set the field's data type to AutoNumber to help make sure 

that it meets the three characteristics in the preceding list. 

Set or change the primary key 

1. Select the table whose primary key you want to set or change. 

2. On the Home tab, in the Views group, click View, and then 

click Design View. 

3. In the table design grid, select the field or fields that you want to use as 

the primary key. 

To select one field, click the row selector for the field that you want. 

To select more than one field, hold down CTRL, and then click the row 

selector for each field. 
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4. On the Design tab, in the Tools group, click Primary Key. 

 

A key indicator appears to the left of the field or fields that you specify as 

the primary key. 

Remove the primary key 

1. Select the table whose primary key you want to remove. 

2. On the Home tab, in the Views group, click View, and then 

click Design View. 

3. Click the row selector for the current primary key. If the primary key 

consists of multiple fields, hold down CTRL, and then click the row 

selector for each field. 

4. On the Design tab, in the Tools group, click Primary Key. 

 

The key indicator is removed from the field or fields that you previously 

specified as the primary key. 

When you save a new table without setting a primary key, MS Access 

prompts you to create a new field for the primary key. If you click Yes, MS 

Access creates an ID field that uses the AutoNumber data type to provide 

a unique value for each record. If your table already includes an 
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AutoNumber field, MS Access uses it as the primary key. If you click No, 

MS Access does not add a field, and no primary key is set. 

Adding fields 

To store a new piece of data about something for which you already have 

an MS Access table, consider adding a field to the table. For example, 

suppose you have a table that stores the last name, first name, email 

address, telephone number, and mailing address of each of your 

customers. If you want to start tracking each customer’s preferred means 

of communication, you add a field to store that data. 

You store each piece of data that you want to track in a field. For example, 

in a contacts table you create fields for Last Name, First Name, Telephone 

Number, and Address. In a products table you create fields for Product 

Name, Product ID, and Price. 

Every field has certain essential characteristics, such as a name that 

uniquely identifies the field within a table, a data type that defines the 

nature of the data, the operations that can be performed on the data, and 

how much storage space to set aside for each value. 

Before you create fields, try to separate data into its smallest useful parts. 

It is much easier to combine data later than it is to pull it apart. For 

example, instead of a Full Name field, consider creating separate fields for 

Last Name and First Name. Then, you can easily search or sort by First 

Name, Last Name, or both. If you plan to report, sort, search, or calculate 

on an item of data, put that item in a field by itself. 

After you create a field, you can also set field properties to control its 

appearance and behavior. For example, the Format property defines how 

the data appears in a datasheet or form that contains that field. 
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Add a field by entering data 

When you create a new table or open an existing table in Datasheet view, 

you can add a field to the table by entering data in the Add New 

Field column of the datasheet (1). MS Access automatically assigns a data 

type for the field, based on the value that you enter. If no other data type 

is implied by your input, MS Access sets the data type to Text but you can 

change the data type. 

 

To enter data in the Add New Field column: 

1. Create or open a table in Datasheet view by right-clicking the table 

that you want in the Navigation Pane and then clicking Datasheet 

view from the shortcut menu. 

2. In the Add New Field column, enter the name of the field that you 

want to create. 

Use a descriptive name so that the field will be easier to identify. 

3. Enter data in the new field. 

Add a field by using a field template 

Sometimes it is easier to choose from a predefined list of fields that fit your 

needs than to manually create a field. You can use the More Fields list to 

choose from a list of field templates. A field template is a predefined set of 

characteristics and properties that describes a field. The field template 
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definition includes a field name, a data type, a setting for the 

field's Format property, and other field properties. 

1. On the Home tab, in the Views group, click View, and then 

click Datasheet View. 

2. On the Fields tab, in the Add & Delete group, click More Fields. 

 

3. Select a field in the More Fields list to insert the new column. MS 

Access places the field to the right of the column where your cursor is 

currently located. If you choose one of the field options under the Quick 

Start heading, such as Address, MS Access creates multiple fields in your 

table to contain the various parts of an address. 

Setting field properties 

After you create a field, you can set field properties to control its 

appearance and behavior. 

For example, by setting field properties, you can: 

▪ Control the appearance of data in a field 

▪ Help prevent incorrect data entry in a field 

▪ Specify default values for a field 

▪ Help speed up searching and sorting on a field 

You can set some of the available field properties while you work in 

Datasheet view. To have MS Access to and set the complete list of field 

properties; however, you must use Design view. 
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The properties that you can set, depend on the field’s data type. 

Set field properties in Datasheet view 

You can rename a field, change its data type, change its Format property, 

and change some of a field's other properties while you work in Datasheet 

view. 

1. In the Navigation Pane, right-click the table that you want to open. 

2. On the shortcut menu, click Datasheet view. 

Rename a field 

When you add a field by entering data in Datasheet view, MS Access 

automatically assigns a generic name to the field. MS Access assigns the 

name Field1 to the first new field, Field2 to the second new field, and so 

on. By default, a field's name is used as its label wherever the field is 

displayed, such as a column heading on a datasheet. Renaming fields so 

that they have more descriptive names helps make them easier to use 

when you view or edit records. 

1. Right-click the heading of the field that you want to rename (for 

example, Field1). 

2. On the shortcut menu, click Rename Field. 

3. Enter the new name in the field heading. 

Field names can consist of up to 64 characters (letters or numbers), 

including spaces. 
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Change a field's data type 

When you create a field by entering data in Datasheet view, MS Access 

examines that data to determine the appropriate data type for the field. For 

example, if you enter 1/1/2017, MS Access recognizes that data as a date 

and sets the data type for the field to Date/Time. If MS Access can't 

definitively determine the data type, the data type is set to Text by default 

(Short Text if you're using MS Access 2016). 

The data type of the field determines which other field properties you can 

set. For example, you can set only the Append Only property for a field 

that has the Hyperlink data type or the Memo data type (Long Text if you're 

using MS Access 2016). 

There may be cases where you want to manually change a field's data type. 

For example, suppose you have room numbers that resemble dates, such 

as 10/2017. If you enter 10/2017 into a new field in Datasheet view, the 

automatic data type detection feature selects the Date/Time data type for 

the field. Because room numbers are labels, and not dates, they should use 

the Text data type. Use the following procedure to change a field's data 

type. 

1. On the Ribbon, click the Fields tab. 

2. In the Data Type list, in the Formatting group, select the data type 

that you want. 
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Data types for MS Access desktop databases 

When creating tables in MS Access, you need to select a data type for each 

column of data. The Short Text data type is a popular choice since it lets 

you enter almost any character (letter, symbol, or number). However, 

careful selection of data types can help you take advantage of more MS 

Access features (such as data validation and functions) and improves the 

accuracy of the information you’re storing. The table below gives an 

overview of the data types available in MS Access desktop databases 

(.accdb and .mdb). 

The following table lists the data types available in desktop databases in 

MS Access 2013 and later versions. 

Data Type Usage Size 

Short Text 

(formerly known 

as “Text”) 

Alphanumeric data (names, 

titles, etc.) 

Up to 255 characters. 

Long Text 

(formerly known 

as “Memo” 

Large amounts of 

alphanumeric data: 

sentences and paragraphs.  

Up to about 1 gigabyte 

(GB), but controls to 

display a long text are 

limited to the first 64,000 

characters. 

Number Numeric data. 1, 2, 4, 8, or 16 bytes. 

Large Number Numeric data. 8 bytes. 

Date/Time Dates and times. 8 bytes. 

Date/Time 

Extended 

Dates and times. Encoded string of 42 

bytes 

Currency Monetary data, stored with 4 

decimal places of precision. 

8 bytes. 
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AutoNumber Unique value generated by 

MS Access for each new 

record. 

4 bytes (16 bytes for 

ReplicationID). 

Yes/No Boolean (true/false) data; 

MS Access stores the 

numeric value zero (0) for 

false, and -1 for true. 

1 byte. 

OLE Object Pictures, graphs, or other 

ActiveX objects from another 

Windows-based application. 

Up to about 2 GB. 

Hyperlink A link address to a document 

or file on the Internet, on an 

intranet, on a local area 

network (LAN), or on your 

local computer 

Up to 8,192 (each part of 

a Hyperlink data type can 

contain up to 2048 

characters). 

Attachment You can attach files such as 

pictures, documents, 

spreadsheets, or charts; 

each Attachment field can 

contain an unlimited number 

of attachments per record, 

up to the storage limit of the 

size of a database file. Note, 

the Attachment data type 

isn't available in MDB file 

formats. 

Up to about 2 GB. 

Calculated You can create an expression 

that uses data from one or 

more fields. You can 

designate different result 

Dependent on the data 

type of the Result Type 

property. Short Text data 

type result can have up to 
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data types from the 

expression. Note, the 

Calculated data type isn't 

available in MDB file formats. 

243 characters. Long 

Text, Number, Yes/No, 

and Date/Time should 

match their respective 

data types. 

Lookup Wizard The Lookup Wizard entry in 

the Data Type column in 

Design view is not actually a 

data type. When you choose 

this entry, a wizard starts to 

help you define either a 

simple or complex lookup 

field. A simple lookup field 

uses the contents of another 

table or a value list to 

validate the contents of a 

single value per row. A 

complex lookup field allows 

you to store multiple values 

of the same data type in 

each row. 

Dependent on the data 

type of the lookup field. 

 

Tips on data types 

✓ The maximum size of an MS Access database file is 2 gigabytes. 

✓ To optimize performance, you should use the most appropriate Field 

Size when you create a Text or Number field. For example, if you expect 

to store postal codes of a predictable length, specify that length as the 

field size. You can specify the field size by setting a value in the Field 

Size property box.  
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✓ For phone numbers, part numbers, and other numbers that you don't 

intend to use for mathematical calculations, you should select the Text 

data type instead of the Number data type. A numeric value that is 

stored as text can be sorted and filtered more logically. 

Change a field's format 

In addition to determining the data type of a new field, MS Access may also 

set the Format property for the field, depending on what you enter. For 

example, if you enter 10:50 a.m., MS Access sets the data type to 

Date/Time and the Format property to Medium Time. To manually change 

a field's Format property, do the following: 

1. On the Ribbon, click the Fields tab.  

2. In the Format list, in the Formatting group, enter the format you 

want.  

Note: The Format list may be unavailable for some fields (for example, 

Text), depending on the data type of the field. 

Set other field properties 

1. In Datasheet view, click the field for which you want to set the 

property. 

2. On the Fields tab, in the Properties, Formatting, or Field 

Validation groups, select the properties that you want. 
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Set field properties in Design view 

You can set any field property while you work with a table in Design view. 

In Design view, you set a field's data type in the table design grid, and you 

set other properties in the Field Properties pane. 

1. In the Navigation Pane, right-click the table. 

2. On the shortcut menu, click Design view. 

Set other field properties 

Note: Not all formats are available for all data types. Set the data type 

first, and then, if needed, set the format. 

1. In the table design grid, select the field for which you want to set 

properties. MS Access displays the properties for this field in the Field 

Properties pane. 

The data type of the field determines the properties that you can set. 

2. In the Field Properties pane, enter the settings that you want for each 

property, or press F6 and then use the arrow keys to select a property. 

3. To provide more space for entering or editing a property setting in the 

property box, press SHIFT+F2 to display the Zoom box. 

Tip: If you are entering an input mask or validation expression and 

would like help in building it, click  next to the property box to 

display the appropriate builder. 

4. To save your changes, press CTRL+S. 
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Move a field 

To move a field, drag it to the position that you want. To select multiple 

contiguous fields to move, click the first field, hold down the SHIFT key, 

and then click the last field. You can then drag the selected group of fields 

to a new position. 

Dragging a field changes its position on the Datasheet but does not change 

the order of the fields in the table design. If you programmatically access 

the fields, the original order applies. For example, if you drag a field to a 

new position on the Datasheet, and then create a form from the table by 

using the Form button, the field will be in its original position. 

 

 

 

 

 

 A form in MS Access is a database object that you can use to create a user 

interface for a database application. A "bound" form is one that is directly 

connected to a data source such as a table or query, and can be used to 

enter, edit, or display data from that data source. Alternatively, you can 

create an "unbound" form that does not link directly to a data source, but 

which still contains command buttons, labels, or other controls that you 

need to operate your application. 

This article focuses primarily on bound forms. You can use bound forms to 

control access to data, such as which fields or rows of data are displayed. 

For example, certain users might need to see only several fields in a table 

with many fields. Providing those users with a form that contains only those 

fields makes it easier for them to use the database. You can also add 
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command buttons and other features to a form to automate frequently 

performed actions. 

Think of bound forms as windows through which people see and reach your 

database. An effective form speeds the use of your database because 

people don't have to search for what they need. A visually attractive form 

makes working with the database more pleasant and more efficient, and it 

can also help prevent incorrect data from being entered. 

Note: This article assumes you have already created a table (or a query 

based on one or more tables), and that you want to build a form to view or 

manipulate the data. 

Create a form by using the Form tool 

You can use the Form tool to create a form with a single mouse-click. When 

you use this tool, all the fields from the underlying data source are placed 

on the form. You can start using the new form immediately, or you can 

modify it in Layout view or Design view to better suit your needs. 

Use the Form tool to create a new form 

1. In the Navigation Pane, click the table or query that contains the data 

you want to see on your form. 

2. On the Create tab, in the Forms group, click Form. 

MS Access creates the form and displays it in Layout view. In Layout view, 

you can make design changes to the form while it is displaying data. For 

example, you can adjust the size of the text boxes to fit the data, if 

necessary. 
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If MS Access finds a single table that has a one-to-many relationship with 

the table or query that you used to create the form, MS Access adds a 

datasheet to the form that is based on the related table or query. For 

example, if you create a simple form that is based on the Employees table, 

and there is a one-to-many relationship that is defined between the 

Employees table and Orders table, the datasheet displays all the records in 

the Orders table that relate to the current Employee record. You can delete 

the datasheet from the form if you decide you do not need it. If there is 

more than one table with a one-to-many relationship to the table that you 

used to create the form, MS Access does not add any datasheets to the 

form. 

Create a split form by using the Split Form tool 

A split form gives you two views of the data at the same time — a Form 

view and a Datasheet view. 

A split form differs from a form/subform combination in that the two views 

are connected to the same data source and are synchronized with one 

another at all times. Selecting a field in one part of the form selects the 

same field in the other part of the form. You can add, edit, or delete data 

from either part (as long as the record source is updatable, and you have 

not configured the form to prevent these actions). 

Working with split forms gives you the benefits of both kinds of forms in a 

single form. For example, you can use the datasheet portion of the form to 

quickly locate a record, and then use the form portion to view or edit the 

record. 

To create a split form by using the Split Form tool: 
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1. In the Navigation Pane, click the table or query that contains the data 

that you want on your form. Or open the table or query in Datasheet 

view. 

2. On the Create tab, in the Forms group, click More Forms, and then 

click Split Form. 

MS Access creates the form and displays it in Layout view. In Layout view, 

you can make design changes to the form while it is displaying data. For 

example, you can adjust the size of the text boxes to fit the data, if 

necessary. 

Create a form that displays multiple records by using the Multiple 

Items tool 

When you create a form by using the Form tool, the form that MS Access 

creates displays a single record at a time. If you want a form that displays 

multiple records but is more customizable than a datasheet, you can use 

the Multiple Items tool. 

1. In the Navigation Pane, click the table or query that contains the data 

you want to see on your form. 

2. On the Create tab, in the Forms group, click More Forms, and then 

click Multiple Items. 

MS Access creates the form and displays it in Layout view. In Layout view, 

you can make design changes to the form while it is displaying data. 

When you use the Multiple Items tool, the form that MS Access creates 

resembles a datasheet. The data is arranged in rows and columns, and you 

see more than one record at a time. However, a Multiple Items form gives 

you more customization options than a datasheet, such as the ability to add 

graphical elements, buttons, and other controls.  
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Create a form by using the Form Wizard 

To be more selective about what fields appear on your form, you can use 

the Form Wizard instead of the various form-building tools previously 

mentioned. You can also define how the data is grouped and sorted, and 

you can use fields from more than one table or query, as long as you 

specified the relationships between the tables and queries beforehand. 

1. On the Create tab, in the Forms group, click Form Wizard. 

2. Follow the directions on the pages of the Form Wizard. 

Note: If you want to include fields from multiple tables and queries on 

your form, do not click Next or Finish after you select the fields from 

the first table or query on the first page of the Form Wizard. Instead, 

repeat the steps to select a table or query, and click any additional fields 

that you want to include on the form. Then click Next or Finish to 

continue. 

3. On the last page of the wizard, click Finish. 

Create a form by using the Blank Form tool 

If the wizard or the form-building tools don't meet your needs, you can use 

the Blank Form tool to build a form. This can be a very quick way to build 

a form, especially if you plan to put only a few fields on your form. 

1. On the Create tab, in the Forms group, click Blank Form. 

MS Access opens a blank form in Layout view, and displays the Field 

List pane. 

2. In the Field List pane, click the plus sign (+) next to the table or tables 

that contain the fields that you want to see on the form. 
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3. To add a field to the form, double-click it or drag it onto the form. 

▪ After the first field has been added, you can add several fields at once 

by holding down the CTRL key, clicking several fields, and then 

dragging them onto the form at the same time. 

▪ The order of the tables in the Field List pane can change, depending 

on which part of the form is currently selected. If the field you want 

to add is not visible, try selecting a different part of the form and then 

try adding the field again. 

4. Use the tools in the Header/Footer group on the Design tab to add a 

logo, title, or the date and time to the form. 

5. Use the tools in the Controls group of the Design tab to add a wider 

variety of controls to the form. 

For a slightly larger selection of controls, switch to Design view by right-

clicking the form and then clicking Design View. 

Understand Layout view and Design view 

Layout view    Layout view is the most intuitive view to use for form 

modification, and it can be used for almost all the changes that you would 

want to make to a form in MS Access. 

In Layout view, the form is actually running. Therefore, you can see your 

data much as it will appear when you are using the form. However, you can 

also change the form design in this view. Because you can see the data 

while you are modifying the form, this is a very useful view for setting the 

size of controls or performing almost any other task that affects the 

appearance and usability of the form. 

If you encounter a task that cannot be performed in Layout view, you can 

switch to Design view. In certain situations, MS Access displays a message 
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that states that you must switch to Design view before you can make a 

particular change. 

Design view    Design view gives you a more detailed view of the structure 

of your form. You can see the Header, Detail, and Footer sections for the 

form. The form is not actually running when it is shown in Design view. 

Therefore, you cannot see the underlying data while you are making design 

changes. However, there are certain tasks that you can perform more easily 

in Design view than in Layout view. You can: 

▪ Add a wider variety of controls to your form, such as bound object 

frames, page breaks, and charts. 

▪ Edit text box control sources in the text boxes themselves, without 

using the property sheet. 

▪ Resize form sections, such as the Form Header or the Detail section. 

▪ Change certain form properties that cannot be changed in Layout view. 

Fine-tune your form in Layout view 

After you create a form, you can easily fine-tune its design by working in 

Layout view. Using the actual form data as your guide, you can rearrange 

the controls and adjust their sizes. You can place new controls on the form 

and set the properties for the form and its controls. 

To switch to Layout view, right-click the form name in the Navigation Pane 

and then click Layout View. 

MS Access shows the form in Layout view. 

You can use the property sheet to change the properties for the form and 

its controls and sections. To display the property sheet, press F4. 
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You can use the Field List pane to add fields from the underlying table or 

query to your form design. To display the Field List pane: 

▪ On the Design tab, in the Tools group, click Add Existing Fields or 

use the keyboard shortcut by pressing ALT+F8. 

You can then drag fields directly from the Field List pane onto your form. 

▪ To add a single field, double-click it or drag it from the Field List pane 

to the section on the form where you want it displayed. 

▪ To add several fields at once, hold down CTRL and click the fields that 

you want to add. Then drag the selected fields onto the form. 

Fine-tune your form in Design view 

You can also fine-tune your form's design by working in Design view. You 

can add new controls and fields to the form by adding them to the design 

grid. The property sheet gives you MS Access to many properties that you 

can set to customize your form. 

To switch to Design view, right-click the form name in the Navigation Pane 

and then click Design View. 

MS Access shows the form in Design view. 

You can use the property sheet to change the properties for the form and 

its controls and sections. To display the property sheet, press F4. 

You can use the Field List pane to add fields from the underlying table or 

query to your form design. To display the Field List pane: 

▪ On the Design tab, in the Tools group, click Add Existing Fields or 

use the keyboard shortcut by pressing ALT+F8.. 
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You can then drag fields directly from the Field List pane onto your form. 

▪ To add a single field, double-click it or drag it from the Field List pane 

to the section on the form where you want it displayed. 

▪ To add several fields at once, hold down CTRL and click the fields that 

you want to add. Then drag the selected fields onto the form. 

Create a form in MS Access 

Forms in MS Access are like display cases in stores that make it easier to 

view or get the items that you want. Since forms are objects through which 

you or other users can add, edit, or display the data stored in your MS 

Access desktop database, the design of your form is an important aspect. 

If your MS Access desktop database is going to be used by multiple users, 

well-designed forms are essential for efficiency and data entry accuracy. 

There are several ways of creating a form in an MS Access desktop database 

and this article points you to some of the common ways. 

Create a form from an existing table or query in MS Access 

To create a form from a table or query in your database, in the Navigation 

Pane, click the table or query that contains the data for your form, and on 

the Create tab, click Form. 

MS Access creates a form and displays it in Layout view. You can make 

design changes like adjusting the size of the text boxes to fit the data, if 

necessary 
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Create a blank form in MS Access 

1. To create a form with no controls or preformatted elements: On 

the Create tab, click Blank Form. MS Access opens a blank form in 

Layout view and displays the Field List pane. 

2. In the Field List pane, click the plus sign (+) next to the table or tables 

that contain the fields that you want to see on the form. 

3. To add a field to the form, double-click it or drag it onto the form. To 

add several fields at once, hold down CTRL and click several fields, and 

then drag them onto the form at the same time. 

Note:  The order of the tables in the Field List pane can change, 

depending on which part of the form is currently selected. If you are not 

able to add a field to the form, try selecting a different part of the form 

and then try adding the field again. 

4. Use the tools in the Controls group on the Form Layout Tools tab to 

add a logo, title, page numbers, or the date and time to the form. 

5. If you want to add a wider variety of controls to the form, 

click Design and use the tools in the Controls group. 

Create a split form in MS Access 

A split form gives you two views of the data at the same time — a Form 

view and a Datasheet view. Working with split forms gives you the benefits 

of both types of forms in a single form. For example, you can use the 

datasheet portion of the form to quickly locate a record, and then use the 

form portion to view or edit the record. The two views are connected to the 

same data source and are synchronized with each other at all times. 
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To create a new split form by using the Split Form tool, in the Navigation 

Pane, click the table or query that contains the data, and then on 

the Create tab, click More Forms, and then click Split Form. 

MS Access creates the form and you can make design changes to the form. 

For example, you can adjust the size of the text boxes to fit the data, if 

necessary. 

Create a form that displays multiple records in MS Access 

A multiple item form, also known as a continuous form, and is useful if you 

want a form that displays multiple records but is more customizable than a 

datasheet, you can use the Multiple Items tool. 

1. In the Navigation Pane, click the table or query that contains the data 

you want to see on your form. 

2. On the Create tab and click More Forms > Multiple Items. 

MS Access creates the form and displays it in Layout view. In Layout view, 

you can make design changes to the form while it is displaying data. For 

example, you can adjust the size of the text boxes to fit the data.  
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Create a Navigation form in MS Access 

A navigation form is simply a form that contains a Navigation Control. 

Navigation forms are a great addition to any database but creating a 

navigation form is particularly important if you plan to publish a database 

to the Web, because the MS Access Navigation Pane does not display in a 

browser. 

1. Open the database to which you want to add a navigation form. 

2. On the Create tab, in the Forms group, click Navigation, and then 

select the style of navigation form that you want. 

MS Access creates the form, adds the Navigation Control to it, and displays 

the form in Layout view.  

 

 

 

Introduction to queries 

Using a query makes it easier to view, add, delete, or change data in your 

MS Access database. Some other reasons for using queries: 

▪ Find specific quickly data by filtering on specific criteria (conditions) 

▪ Calculate or summarize data 

▪ Automate data management tasks, such as reviewing the most current 

data on a recurring basis. 

Note:  If you want to try out the queries in the examples, use an MS Access 

desktop database. 

 12.5 Queries 
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Queries help you find and work with your data 

In a well-designed database, the data that you want to present through a 

form or report is usually located in multiple tables. A query can pull the 

information from various tables and assemble it for display in the form or 

report. A query can either be a request for data results from your database 

or for action on the data, or for both. A query can give you an answer to a 

simple question, perform calculations, combine data from different tables, 

add, change, or delete data from a database. Since queries are so versatile, 

there are many types of queries and you would create a type of query based 

on the task. 

Major query 

types 

Use 

Select To retrieve data from a table or make calculations. 

Action Add, change, or delete data. Each task has a specific 

type of action query. Action queries are not available 

in MS Access web apps. 

Create a select query 

If you want to review data from only certain fields in a table, or review data 

from multiple tables simultaneously or maybe just see the data based on 

certain criteria, a select query type would be your choice.  

Review data from select fields 

For example, if your database has a table with a lot of information about 

products and you want to review a list of products and their prices, here’s 

how you’d create a select query to return just the product names and the 

respective price: 
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1. Open the database and on the Create tab, click Query Design. 

2. On the Tables tab, double-click the Products table. 

3. In the Products table, let’s say that you have Product Name and List 

Price fields. Double-click the Product Name and List Price to add 

these fields to the query design grid. 

4. On the Design tab, click Run. The query runs, and displays a list of 

products and their prices. 

Review data from multiple related tables simultaneously 

For example, if you have a database for a store that sells food items and 

you want to review orders for customers who live in a particular city. Say 

that the data about orders and data about customers are stored in two 

tables named Customers and Orders respectively. If each table has a 

Customer ID field, which forms the basis of a one-to-many relationship 

between the two tables. You can create a query that returns orders for 

customers in a particular city, for example, Las Vegas, by using the 

following procedure: 

1. Open the database. On the Create tab, in the Query group, 

click Query Design. 

2. On the Tables tab, double-click Customers and Orders. 

Note the line (called a join) that connects the ID field in the Customers 

table and the Customer ID field in the Orders table. This line shows the 

relationship between the two tables. 

3. In the Customers table, double-click Company and City to add these 

fields to the query design grid. 

4. In the query design grid, in the City column, clear the check box in 

the Show row. 

5. In the Criteria row of the City column, type Las Vegas. 
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Clearing the Show check box prevents the query from displaying the 

city in its results, and typing Las Vegas in the Criteria row specifies 

that you want to see only records where the value of the City field is 

Las Vegas. In this case, the query returns only the customers that 

are located in Las Vegas. You don’t need to display a field to use it 

with a criterion. 

6. In the Orders table, double-click Order ID and Order Date to add 

these fields to the next two columns of the query design grid. 

7. On the Design tab, in the Results group, click Run. The query runs, 

and then displays a list of orders for customers in Las Vegas. 

8. Press CTRL+S to save the query. 

Create a parameter query 

If you frequently want to run variations of a particular query, consider using 

a parameter query. When you run a parameter query, the query prompts 

you for field values, and then uses the values that you supply to create 

criteria for your query. 

Note:  You cannot create a parameter query in an MS Access web app. 

Continuing from the previous example where you learnt to create a select 

query that returns orders for customers located in Las Vegas, you can 

modify the select query to prompt you to specify the city each time that 

you run the query. To follow along, open the database that you created in 

the previous example: 

1. In the Navigation Pane, right-click the query named Orders by 

City (that you created in the previous section), and then click Design 

View on the shortcut menu. 
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2. In the query design grid, in the Criteria row of the City column, 

delete Las Vegas, and then type [For what city?]. 

The string [For what city?] is your parameter prompt. The square 

brackets indicate that you want the query to ask for input, and the text 

(in this case, For what city?) is the question that the parameter prompt 

displays. 

Note: Neither a period (.) nor an exclamation point (!) can be used as 

text in a parameter prompt. 

3. Select the check box in the Show row of the City column, so that the 

query results will display the city. 

4. On the Design tab, in the Results group, click Run. The query prompts 

you to enter a value for City. 

5. Type New York, and then press ENTER to see orders for customers in 

New York. 

What if you don't know what values you can specify? You can use 

wildcard characters as part of the prompt: 

6. On the Home tab, in the Views group, click View, and then 

click Design View. 

7. In the query design grid, in the Criteria row of the City column, 

type Like [For what city?]&"*". 

In this parameter prompt, the Like keyword, the ampersand (&), and 

the asterisk (*) enclosed in quotation marks allow the user to type a 

combination of characters, including wildcard characters, to return a 

variety of results. For example, if the user types *, the query returns all 

cities; if the user types L, the query returns all cities that start with the 

letter "L;" and if the user types *s*, the query returns all cities that 

contain the letter "s." 
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8. On the Design tab, in the Results group, click Run, and at the query 

prompt, type New, and press ENTER. 

The query runs, and then displays orders for customers in New York. 

Specify parameter data types 

You can also specify what type of data a parameter should accept. You can 

set the data type for any parameter, but it is especially important to set 

the data type for numeric, currency, or date/time data. When you specify 

the data type that a parameter should accept, users see a more helpful 

error message if they enter the wrong type of data, such as entering text 

when currency is expected. 

If a parameter is set to accept text data, any input is interpreted as text, 

and no error message is displayed. 

To specify the data type for parameters in a query, use the following 

procedure: 

1. With the query open in Design view, on the Design tab, in 

the Show/Hide group, click Parameters. 

2. In the Query Parameters dialog box, in the Parameter column, type 

the prompt for each parameter for which you want to specify the data 

type. Make sure that each parameter matches the prompt that you use 

in the Criteria row of the query design grid. 

3. In the Data Type column, select the data type for each parameter. 

Create a totals query 

The Total row in a datasheet is very useful, but for more complex questions, 

you use a totals query. A totals query is a select query that allows you to 
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group and summarize data, like when you want to see total sales per 

product. In a totals query, you can use the Sum function (an aggregate 

function), to see total sales per product. 

Note:  You cannot use aggregate functions in an MS Access web app. 

Use the following procedure to modify the Product Subtotals query that you 

created in the previous example so that it summarizes product subtotals by 

product. 

1. On the Home tab, click View > Design View. 

The Product Subtotals query opens in Design view. 

2. On the Design tab, in the Show/Hide group, click Totals. 

The Totals row is displayed in the query design grid. 

Note:  Although they have similar names, the Totals row in the design 

grid and the Total row in a datasheet are not the same: 

▪ You can group by field values by using the Totals row in the design grid. 

▪ You can add a datasheet Total row to the results of a totals query. 

▪ When you use the Totals row in the design grid, you must choose an 

aggregate function for each field. If you do not want to perform a 

calculation on a field, you can group by the field. 

▪ In the second column of the design grid, in the Total row, 

select Sum from the drop-down list. 

▪ On the Design tab, in the Results group, click Run. The query runs, 

and then displays a list of products with subtotals. 

▪ Press CTRL+S to save the query. Leave the query open. 
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Make calculations based on your data 

You usually would not use tables to store calculated values, like subtotals, 

even if they are based on data in the same database, because calculated 

values can become outdated if the values that they are based on changes. 

For example, you would not store someone's age in a table, because every 

year you would have to update the value; instead, you store the person's 

date of birth, and then use a query to calculate the person's age. 

For example, if you have a database for some products you’d like to sell. 

This database has a table called Orders Details that has information about 

the products in fields such as, price of each product and the quantities. You 

can calculate the subtotal by using a query that multiplies the quantity of 

each product by the unit price for that product, multiplies the quantity of 

each product by the unit price and discount for that product, and then 

subtracts the total discount from the total unit price. If you created the 

sample database in the previous example, open it and follow along: 

1. On the Create tab, click Query Design. 

2. On the Tables tab, double-click Order Details. 

3. In the Order Details table, double-click Product ID to add this field to 

the first column of the query design grid. 

4. In the second column of the grid, right-click the Field row, and then 

click Zoom on the shortcut menu. 

5. In the Zoom box, type or paste the following: Subtotal: 

([Quantity]*[Unit Price])-([Quantity]*[Unit Price]*[Discount]) 

6. Click OK. 

7. On the Design tab, click Run. The query runs, and then displays a list 

of products and subtotals, per order. 

8. Press CTRL+S to save the query, and then name the query Product 

Subtotals. 



 

 

 

248 

Display summarized or aggregate data 

When you use tables to record transactions or store regularly occurring 

numeric data, it is useful to be able to review that data in aggregate, such 

as sums or averages. In MS Access, you can add a Totals row to a 

datasheet. Total row is a row at the bottom of the datasheet that can 

display a running total or other aggregate value. 

1. Run the Product Subtotals query you created earlier, and leave the 

results open in Datasheet view. 

2. On the Home tab, click Totals. A new row appears at the bottom of the 

datasheet, with the word Total in the first column. 

3. Click the cell in the last row of the datasheet named Total. 

4. Click the arrow to view the available aggregate functions. Because the 

column contains text data, there are only two 

choices: None and Count. 

5. Select Count. The content of the cell changes from Total to a count of 

the column values. 

6. Click the adjoining cell (the second column). Note that an arrow appears 

in the cell. 

7. Click the arrow, and then click Sum. The field displays a sum of the 

column values. 

8. Leave the query open in Datasheet view. 

Create a crosstab query 

Now suppose that you want to review product subtotals, but you also want 

to aggregate by month, so that each row shows subtotals for a product, 

and each column shows product subtotals for a month. To show subtotals 

for a product and to show product subtotals for a month, use a crosstab 

query. 
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Note: A crosstab query cannot be displayed in an MS Access web app. 

You can modify the Product Subtotals query again so that the query returns 

rows of product subtotals and columns of monthly subtotals. 

1. On the Home tab, in the Views group, click View, and then 

click Design View. 

2. In the Query Setup group, click Add Tables (or Show Table in MS 

Access 2013). 

3. Double-click Orders, and then click Close. 

4. On the Design tab, in the Query Type group, click Crosstab. In the 

design grid, the Show row is hidden, and the Crosstab row is 

displayed. 

5. In the third column of the design grid, right-click the Field row, and 

then click Zoom on the shortcut menu. The Zoom box opens. 

6. In the Zoom box, type or paste the following: Month: "Month " & 

DatePart("m", [Order Date]) 

7. Click OK. 

8. In the Crosstab row, select the following values from the drop-down 

list: Row Heading for the first column, Value for the second column, 

and Column Heading for the third column. 

9. On the Design tab, in the Results group, click Run. The query runs, 

and then displays product subtotals, aggregated by month. 

10. Press CTRL+S to save the query. 

Create a make table query 

You can use a make-table query to create a new table from data that is 

stored in other tables. 

Note:  A make-table query is not available in MS Access web apps. 
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For example, suppose that you want to send data for Chicago orders to a 

Chicago business partner who uses Access to prepare reports. Instead of 

sending all your order data, you want to restrict the data that you send to 

data specific to Chicago orders. 

You can build a select query that contains Chicago order data, and then use 

the select query to create the new table by using the following procedure: 

1. Open the example database from the previous example. 

To run a make-table query, you may need to enable the database 

content. 

Note:  If you see a message beneath the Ribbon about enabling the 

database, click Enable content. If your database is already in a trusted 

location, you will not see the Message Bar. 

2. On the Create tab, in the Query group, click Query Design. 

3. Double-click Order Details and Orders. 

4. In the Orders table, double-click Customer ID and Ship City to add 

these fields to the design grid. 

5. In the Order Details table, double-click Order ID, Product 

ID, Quantity, Unit Price, and Discount to add these fields to the 

design grid. 

6. In the Ship City column of the design grid, clear the box in 

the Show row. In the Criteria row, type 'Chicago' (include the single 

quotation marks). Verify the query results before you use them to create 

the table. 

7. On the Design tab, in the Results group, click Run. 

8. Press Ctrl + S to save the query. 

9. In the Query Name box, type Chicago Orders Query, and then 

click OK. 
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10. On the Home tab, in the Views group, click View, and then 

click Design View. 

11. On the Design tab, in the Query Type group, click Make Table. 

12. In the Make Table dialog box, in the Table Name box, 

type Chicago Orders, and then click OK. 

13. On the Design tab, in the Results group, click Run. 

14. In the confirmation dialog box, click Yes, and see the new table 

displayed in the Navigation Pane. 

Note: If there is already a table with the same name that you 

specified, MS Access deletes that table before running the query. 

Create an append query 

You can use an append query to retrieve data from one or more tables and 

add that data to another table. 

Note:  Append query is not available in MS Access web apps. 

For example, suppose that you created a table to share with a Chicago 

business associate, but you realize that the associate also works with clients 

in the Milwaukee area. You want to add rows that contain Milwaukee area 

data to the table before you share the table with your associate. You can 

add Milwaukee area data to the Chicago Orders table by using the following 

procedure: 

1. Open the query named "Chicago Orders Query" you created earlier in 

Design view. 

2. On the Design tab, in the Query Type group, click Append. 

The Append dialog box opens. 

3. In the Append dialog box, click the arrow in the Table Name box, 

select Chicago Orders from the drop-down list, and then click OK. 
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4. In the design grid, in the Criteria row of the Ship City column, delete 

'Chicago', and then type 'Milwaukee'. 

5. In the Append To row, select the appropriate field for each column. 

In this example, the Append To row values should match the Field row 

values, but that is not required for append queries to work. 

6. On the Design tab, in the Results group, click Run. 

Note:  While running a query that returns a large amount of data you might 

get an error message indicating that you will not be able to undo the query. 

Try increasing the limit on the memory segment to 3MB to allow the query 

to go through. 

Create an update query 

You can use an update query to change the data in your tables, and you 

can use an update query to enter criteria to specify which rows should be 

updated. An update query provides you an opportunity to review the 

updated data before you perform the update. 

Important:  An action query cannot be undone. You should consider 

making a backup of any tables that you will update by using an update 

query. An update query is not available in MS Access web apps. 

In the previous example, you appended rows to the Chicago Orders table. 

In the Chicago Orders table, the Product ID field shows the numeric Product 

ID. To make the data more useful in reports, you can replace the product 

IDs with product names, use the following procedure: 

1. Open the Chicago Orders table in Design view. 

2. In the Product ID row, change the Data Type from Number to Text. 

3. Save and close the Chicago Orders table. 



 

 

 

253 

4. On the Create tab, in the Query group, click Query Design. 

5. Double-click Chicago Orders and Products. 

6. On the Design tab, in the Query Type group, click Update. 

7. In the design grid, the Sort and Show rows disappear, and the Update 

To row appears. 

8. In the Chicago Orders table, double-click Product ID to add this field 

to the design grid. 

9. In the design grid, in the Update To row of the Product ID column, 

type or paste the following: [Products].[Product Name] 

Tip:  You can use an update query to delete field values by using an 

empty string ("") or NULL in the Update To row. 

10. In the Criteria row, type or paste the following: [Product ID] Like 

([Products].[ID]) 

11. You can review which values will be changed by an update query by 

viewing the query in Datasheet view. 

12. On the Design tab, click View > Datasheet View. The query 

returns a list of Product IDs that will be updated. 

13. On the Design tab, click Run. 

When you open the Chicago Orders table, you will see that the numeric 

values in the Product ID field have been replaced by the product names 

from the Products table. 

Create a delete query 

You can use a delete query to delete data from your tables, and you can 

use a delete query to enter criteria to specify which rows should be deleted. 

A delete query provides you an opportunity to review the rows that will be 

deleted before you perform the deletion. 
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Note:  A delete query option is not available in MS Access web apps. 

For example, say that while you were preparing to send the Chicago Orders 

table from the previous example to your Chicago business associate, you 

notice that some of the rows contain several empty fields. You decided to 

remove these rows before you send the table. You could just open the table 

and delete the rows manually, but if you have many rows to delete and you 

have clear criteria for which rows should be deleted, you might find it 

helpful to use a delete query. 

You can use a query to delete rows in the Chicago Orders table that do not 

have a value for Order ID by using the following procedure: 

1. On the Create tab, click Query Design. 

2. Double-click Chicago Orders. 

3. On the Design tab, in the Query Type group, click Delete. In the 

design grid, the Sort and Show rows disappear, and the Delete row 

appears. 

4. In the Chicago Orders table, double-click Order ID to add it to the 

grid. 

5. In the design grid, in the Criteria row of the Order ID column, type Is 

Null. 

6. On the Design tab, in the Results group, click Run. 

Create a simple select query 

When you want to select specific data from one or more sources, you can 

use a select query. A select query helps you retrieve only the data that you 

want, and also helps you combine data from several data sources. You can 

use tables and other select queries as data sources for a select query. This 

topic provides an overview of select queries, and gives steps for creating a 

select query, by using the Query Wizard or in Design view. 
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Overview 

When you want to use data, you rarely want to use all of the data from one 

table. For example, when you want to use data from a Contacts table, you 

usually want to look at one specific record, or maybe just the telephone 

number. Sometimes you want to combine data from more than one table, 

such as combining Customer information with Order information. To select 

the data that you want to use, you use a select query. 

A select query is a database object that shows information in Datasheet 

view. A query does not store data, it displays data that is stored in tables. 

A query can show data from one or more tables, from other queries, or 

from a combination of the two. 

Benefits of using a query 

A query lets you: 

▪ View data only from the fields you are interested in viewing. When you 

open a table, you see all the fields. A query is a handy way to save a 

selection of fields. 

Note: A query only points to data, it does not store data. When you save 

a query, you are not saving a copy of the data. 

▪ Combine data from several data sources. A table usually only displays 

data that it stores. A query lets you pick and choose fields from various 

sources and specify how the information should be combined. 

▪ Use expressions as fields. For example, you could use the Date function 

as a field, or you could use the Format function with a field to control 

the way the data from the field is formatted in the query results. 
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▪ View records that meet criteria that you specify. When you open a table, 

you see all the records. A query is a handy way to save a selection of 

records. 

Basic steps to create a select query 

You can create a select query by using the Query Wizard or by working in 

Design view. Some design elements are not available when you use the 

wizard, but you can add these elements later by using Design view. 

Although the two methods are somewhat different from each other, the 

basic steps are essentially the same: 

1. Choose the tables or queries that you want to use as sources of data. 

2. Specify the fields that you want to include from the data sources. 

3. Optionally, specify criteria to limit the records that the query returns. 

After you have created a select query, you run it to see the results. To run 

a select query, you open it in Datasheet view. If you save the query, you 

can reuse it whenever you need, for example, as a data source for a form, 

report, or another query. 

Use the Query Wizard to create a select query 

You can use the Query Wizard to automatically create a select query. When 

you use the wizard, you have less control over the details of the query 

design, but the query is usually created faster than if you did not use the 

wizard. Moreover, the wizard can catch some simple design mistakes and 

prompt you to perform a different action. 
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Before you begin 

If you use fields from data sources that are not related to each other, the 

Query Wizard asks you if you want to create relationships. The wizard opens 

the Relationships window for you, but you must restart the wizard if you 

edit any relationships. Therefore, before you run the wizard, consider 

creating any relationships that your query needs. 

Use the Query Wizard 

1. On the Create tab, in the Queries group, click Query Wizard.  

 

2. In the New Query dialog box, click Simple Query Wizard, and then 

click OK. 

3. Next, you add fields. You can add up to 255 fields from as many as 32 

tables or queries. 

For each field, perform these two steps: 

a. Under Tables/Queries, click the table or query that contains the 

field. 

b. Under Available Fields, double-click the field to add it to 

the Selected Fields list. If you want to add all fields to your query, 

click the button with the double right arrows (>>). 

c. When you have added all the fields that you want, click Next. 
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4. If you did not add any number fields (fields that contain numeric data), 

skip ahead to step 9. If you added any number fields, the wizard asks 

whether you want the query to return details or summary data. 

Do one of the following: 

a. If you want to see individual records, click Detail, and then 

click Next. Skip ahead to step 9. 

b. If you want to see summarized numeric data, such as averages, 

click Summary, and then click Summary Options. 
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5. In the Summary Options dialog box, specify which fields you want to 

summarize, and how you want to summarize the data. Only number 

fields are listed. 

For each number field, choose one of the following functions: 

a. Sum    The query returns the sum of all the values of the field. 

b. Avg    The query returns the average of the values of the field. 

c. Min    The query returns the smallest value of the field. 

d. Max    The query returns the largest value of the field. 
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6. If you want the query results to include a count of the records in a data 

source, select the appropriate Count records in data source 

name check box. 

7. Click OK to close the Summary Options dialog box. 

8. If you did not add a date/time field to the query, skip ahead to step 9. 

If you added a date-time field to the query, the Query Wizard asks you 

how you would like to group the date values. For example, suppose you 

added a number field ("Price") and a date/time field 

("Transaction_Time") to your query, and then specified in the Summary 

Options dialog box that you want to see the average value of the 

number field "Price". Because you included a date/time field, you could 

calculate summary values for each unique date/time value, for each day, 

for each month, for each quarter, or for each year. 
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Select the time period that you want to use to group the date/time values, 

and then click Next. 

Note: In Design view, you can use an expression to group by any time 

period you want, but the wizard only offers these choices. 

9. On the last page of the wizard, give the query a title, specify whether 

you want to open or modify the query, and then click Finish. 

If you choose to open the query, the query displays the selected data in 

Datasheet view. If you choose to modify the query, the query opens in 

Design view. 

Create a query by working in Design view 

You can use Design view to manually create a select query. When you use 

Design view, you have more control over the details of the query design, 
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but it is easier to make design mistakes, and it can take longer than using 

the wizard. 

Create a query 

Step 1: Add data sources 

When you use Design view, to add data sources, you add the data sources 

and fields in separate steps. However, you can always add more data 

sources later if you want. 

1. On the Create tab, in the Other group, click Query Design.  

 

2. Double-click each data source that you want to use or select each data 

source and then click Add. 
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Automatic joins 

When you add the data sources, if the sources already have relationships 

defined between them, those relationships are automatically added to the 

query as joins. Joins specify how data from related sources should be 

combined. MS Access also automatically creates a join between two tables 

if they have fields have compatible data types and one field is a primary 

key. 
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You might want to adjust the joins that MS Access creates. MS Access 

determines what type of join to create based on the relationship the join 

represents.  

Use the same data source several times 

In some cases, you want to join two copies of the same table or query, 

called a self-join, that combines records from the same table when there 

are matching values in the joined fields. For example, say you have an 

Employees table in which the ReportsTo field for each employee's record 

displays his or her manager's ID instead of name. You could use a self-join 

to display the manager's name in each employee's record instead. 

When you add a data source a second time, MS Access appends _1 to the 

name of the second instance. For example, if you added the Employees 

table twice, the second instance would be named Employees_1. 

Step 2: Join related data sources 

If the data sources that you add to a query already have relationships, MS 

Access automatically creates an inner join for each relationship. If 

referential integrity is enforced, MS Access also displays a "1" above the 

join line to show which table is on the "one" side of a one-to-many 

relationship and an infinity symbol (∞) to show which table is on the 

"many" side. 

If you add queries to your query, and have not created relationships 

between those queries, MS Access does not automatically create joins 

between those queries, or between queries and tables that are not related. 

If MS Access does not create joins when you add data sources, you should 
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usually add them yourself. Data sources that are not joined to any other 

data source can cause problems with the query results. 

You might also want to change the type of a join from an inner join to an 

outer join, so that your query includes more records. 

Add a join 

▪ To add a join, drag a field from one data source to a corresponding 

field on another data source. 

MS Access displays a line between the two fields to show that a join 

has been created. 

 

Change a join 

1. Double-click the join you want to change. 

The Join Properties dialog box appears. 
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2. In the Join Properties dialog box, review the three options. 

3. Click the option that you want to use, and then click OK. 

After the joins are ready, you add output fields — fields that have data 

that you want in the query results. 

Step 3: Add output fields 

You can easily add a field from any of the data sources that you added in 

step 1. 

▪ To add a field, drag the field from a data source in the upper pane of the 

query design window down to the Field row of the design grid, in the 

bottom pane of the query design window. 

When you add a field this way, MS Access automatically fills in 

the Table row of the design grid to reflect the data source of the field. 

Tip: If you want to quickly add all fields down to the Field row of the 

query design grid, double-click the table or query name from the upper 

pane to highlight all the fields in that source and then drag them all 

down to the design grid at the same time. 
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Use an expression as an output field 

If you want to perform calculations or use a function to produce query 

output, you can use an expression as an output field. An expression can 

use data from any of the query data sources, as well as functions, such as 

Format or InStr, and can also contains constants and arithmetic operators. 

1. In an empty column of the query design grid, right-click the Field row, 

and then click Zoom on the shortcut menu. 

2. In the Zoom box, type or paste your expression. Preface your 

expression with the name you would like to use for the expression 

output, followed by a colon. For example, if you wanted the expression 

to be labelled "Last updated", you would start your expression with Last 

updated:. 

Note: You can do a wide variety of things by using expressions. A 

thorough explanation of expressions is beyond the scope of this article.  

Step 4: Specify criteria 

This step is optional. 

You use criteria to limit the records that your query returns, on the basis 

of whether field values meet the criteria that you specify. 

Specify criteria for an output field 

1. In the query design grid, in the Criteria row of the field that has values 

that you want to limit, type an expression that field values must satisfy 

to be included in your results. For example, if you wanted to limit a query 

so that only records where the value of the field City is Las Vegas, 

type Las Vegas in the Criteria row under that field. 
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2. Specify any alternate criteria in the Or row, below the Criteria row. 

If you specify alternate criteria, a field value can meet any of the listed 

criteria and be included in the query result. 

Multiple field criteria 

You can use criteria with multiple fields. When you do, all the criteria in a 

given Criteria or Or row must be true for the record to be included. 

Specify criteria by using a field that you don't want to output 

You can add a field to your query design and not include the field's data in 

the query output. You do this if you want to use the field's values to limit 

the query results, but don't want to see the field values. 

1. Add the field to the design grid. 

2. Clear the check box in the Show row for the field. 

3. Specify criteria as you would for an output field. 

Step 5: View the results 

To see the query results, on the Design tab, click Run. MS Access displays 

the results of your query in Datasheet view. 

To make further changes to the query, click Home > View > Design 

View to switch back to Design view. 

Change your fields, expressions, or criteria and rerun the query until it 

returns the data that you want. 
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Run a query 

A query is a set of instructions that you can use for working with data. You 

run a query to perform these instructions. In addition to returning results — 

which can be sorted, grouped, or filtered — a query can also create, copy, 

delete, or change data. 

This article explains how to run queries and provides only brief overviews 

of the various types of queries. The article also discusses error messages 

you might encounter when you run different types of queries and provides 

steps you can take to work around or correct those errors. 

This article does not provide step-by-step instructions for creating queries. 

Important: You cannot run action queries if a database is operating in 

Disabled mode —a reduced functionality mode that MS Access uses to help 

protect your data in certain circumstances. You may see a dialog box 

warning, or you may see a warning in the Message Bar. 

Run a select or a crosstab query 

You use select queries and crosstab queries to retrieve and present data, 

and to supply forms and reports with data. When you run a select or a 

crosstab query, MS Access displays the results in Datasheet view. 

Run the query 

1. Locate the query in the Navigation Pane. 

2. Do one of the following: 

▪ Double-click the query you want to run. 

▪ Click the query you want to run, and then press ENTER. 
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If the query you want to run is currently open in Design view, you can also 

run it by clicking Run in the Results group on the Design tab on the 

Ribbon, part of the Microsoft Office Fluent user interface. 

Run an action query 

There are four types of action queries: append queries, delete queries, 

update queries, and make-table queries. Except for make-table queries 

(which create new tables), action queries make changes to the data in 

tables they are based on. These changes cannot be easily undone, for 

example, by pressing CTRL+Z. If you make changes using an action query 

that you later decide you didn't want to make, usually you will have to 

restore the data from a backup copy. For this reason, you should always 

make sure you have a fresh backup of the underlying data before running 

an action query. 

You can mitigate the risk of running an action query by first previewing the 

data that will be acted upon. There are two ways to do this: 

▪ View the action query in Datasheet view before you run it. To do this, 

open the query in Design view, click View on the MS Access status 

bar, and then click Datasheet View on the shortcut menu. To switch 

back to Design view, click View again, and then click Design 

View on the shortcut menu. 

▪ Change the query to a select query, and then run it. 

Note: Make sure to note what type of action query (append, update, 

make-table, or delete) you are starting with, so you can change the 

query back to that type after you preview the data with this method. 

Run an action query as a select query 
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a. Open the action query in Design view. 

b. On the Design tab, in the Query Type group, click Select. 

c. On the Design tab, in the Results group, click Run. 

Run the query 

When you are ready to run an action query, double-click it in the Navigation 

Pane, or click it and then press ENTER. 

Important: By default, MS Access disables all action queries in a database 

unless you indicate that you trust the database. You can indicate that you 

trust a database by using the Message Bar, just below the Ribbon. 

 

Trust a database 

1. On the Message Bar, click Options. 

The Microsoft Office Security Options dialog box appears. 

2. Select Enable this content and then click OK. 
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Troubleshoot an error message 

The following table shows some common error messages you may 

encounter. These errors can appear either as a message in a cell (instead 

of an expected value), or as an error message. The sections that follow the 

list include procedures you can use to resolve these errors. 

Error message Problem Solution 

Type mismatch 

in expression 

The query may be joining 

fields that have different data 

types. 

Check the query design 

and ensure that the 

joined fields have the 

same data type.  

Record is 

Deleted 

This can occur if either the 

object or the database is 

damaged. 

Compact and repair the 

database.  

Circular 

reference 

caused by alias 

The alias assigned to a field is 

the same as a component of 

the expression for that field. 

An alias is a name that is 

given to any expression in 

the Field row of the query 

design grid that is not an 

actual field. MS Access 

assigns the alias for you if 

you do not do so yourself; for 

example, EXPR1. An alias is 

immediately followed by a 

colon (:) and then by the 

expression. When you run the 

query, the alias becomes the 

Change the alias.  
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column name in the 

datasheet. 

#Error This error can occur when the 

value of a calculated field is 

greater than the value 

allowed by the 

field's FieldSize property 

setting. This also occurs when 

the denominator of a 

calculated field is or evaluates 

to zero (0). 

Ensure that the calculated 

field's denominator does 

not evaluate to zero (0). 

If appropriate, change 

the FieldSize property. 

#Deleted The record being referred to 

has been deleted. 

If the record was deleted 

accidentally, it must be 

restored from a backup. 

If the deletion was 

intentional, you can 

dismiss this error 

message by pressing 

SHIFT+F9 to refresh the 

query. 
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Examples of query criteria 

Query criteria help you zero in on specific items in an MS Access database. 

If an item matches all the criteria you enter, it appears in the query results. 

To add criteria to an MS Access query, open the query in Design view and 

identify the fields (columns) you want to specify criteria for. If the field is 

not in the design grid, double-click the field to add it to the design grid and 

then enter the criterion in the Criteria row for that field. 

A query criterion is an expression that MS Access compares to query field 

values to determine whether to include the record that contains each value. 

For example, = "Chicago" is an expression that MS Access can compare 

to values in a text field in a query. If the value for that field in a given 

record is "Chicago", MS Access includes the record in the query results. 

Here are some examples of commonly used criteria you can use as a 

starting point to create your criteria. The examples are grouped by data 

types. 

Introduction to query criteria 

A criterion is like a formula — it is a string that may consist of field 

references, operators, and constants. Query criteria are also referred to as 

expressions in MS Access. 
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The following tables shows some sample criteria and explains how they 

work. 

Criteria Description 

>25 and <50 This criterion applies to a Number field, such as Price 

or UnitsInStock. It includes only those records where 

the Price or UnitsInStock field contains a value 

greater than 25 and less than 50. 

DateDiff ("yyyy", 

[BirthDate], 

Date()) > 30 

This criterion applies to a Date/Time field, such as 

BirthDate. Only records where the number of years 

between a person's birthdate and today's date is 

greater than 30 are included in the query result. 

Is Null This criterion can be applied to any type of field to show 

records where the field value is null. 

As you can see, criteria can look very different from each other, depending 

on the data type of the field to which they apply and your specific 

requirements. Some criteria are simple, and use basic operators and 

constants. Others are complex, and use functions, special operators, and 

include field references. 

This topic lists several commonly used criteria by data type. If the examples 

given in this topic do not address your specific needs, you might need to 

write your own criteria. To do that, you must first familiarize yourself with 

the full list of functions, operators, special characters, and the syntax for 

expressions referring to fields and literals. 

Here, you will see where and how you add the criteria. To add a criteria to 

a query, you must open the query in Design view. You then identify the 

fields for which you want to specify criteria. If the field is not already in the 

design grid, you add it by either dragging it from the query design window 

to the field grid, or by double-clicking the field (Double-clicking the field 
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automatically adds it to the next empty column in the field grid.). Finally, 

you type the criteria in the Criteria row 

Criteria that you specify for different fields in the Criteria row are 

combined by using the AND operator. In other words, the criteria specified 

in the City and BirthDate fields are interpreted like this: 

City = "Chicago" AND BirthDate < DateAdd (" yyyy ", -40, Date()) 

 

1. The City and BirthDate fields include criteria. 

2. Only records where the value of the City field is Chicago will satisfy this 

criterion. 

3. Only records of those who are at least 40 years old will satisfy this 

criterion. 

4. Only records that meet both criteria will be included in the result. 

What if you want only one of these conditions to be met? In other words, 

if you have alternate criteria, how do you enter them? 
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If you have alternate criteria, or two sets of independent criteria where it 

is sufficient to satisfy one set, you use both the Criteria and the or rows 

in the design grid. 

 

1. The City criterion is specified in the Criteria row. 

2. The BirthDate criterion is specified in the or row. 

Criteria specified in the Criteria and or rows are combined using the OR 

operator, as shown below: 

City = "Chicago" OR BirthDate < DateAdd (" yyyy ", -40, Date()) 

If you need to specify more alternatives, use the rows below the or row. 

Before you continue with the examples, note the following: 

▪ If the criteria is temporary or changes often, you can filter the query 

result instead of frequently modifying the query criteria. A filter is a 

temporary criterion that changes the query result without altering the 

design of the query. 
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▪ If the criteria fields don't change, but the values you are interested in 

do change frequently, you can create a parameter query. A parameter 

query prompts the user for field values, and then uses those values to 

create the query criteria. Criteria for Text, Memo, and Hyperlink 

fields 

Note: Beginning in MS Access 2013, Text fields are now named Short 

Text and Memo fields are now named Long Text. 

The following examples are for the CountryRegion field in a query that is 

based on a table that stores contacts information. The criterion is specified 

in the Criteria row of the field in the design grid. 

 

A criterion that you specify for a Hyperlink field is, by default, applied to 

the display text portion of the field value. To specify criteria for the 

destination Uniform Resource Locator (URL) portion of the value, use 

the HyperlinkPart expression. The syntax for this expression is as 

follows: HyperlinkPart([Table1].[Field1],1) = 

"http://www.microsoft.com/", where Table1 is the name of the table 

containing the hyperlink field, Field1 is the hyperlink field, and 

http://www.microsoft.com is the URL you want to match. 
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To include records 

that... 

Use this 

criterion 

Query result 

Exactly match a 

value, such as China 

"China" Returns records where the 

CountryRegion field is set to 

China. 

Do not match a 

value, such as 

Mexico 

Not "Mexico" Returns records where the 

CountryRegion field is set to a 

country/region other than Mexico. 

Begin with the 

specified string, 

such as U 

Like U* Returns records for all 

countries/regions whose names 

start with "U", such as UK, USA, 

and so on. 

Note: When used in an 

expression, the asterisk (*) 

represents any string of 

characters — it is also called a 

wildcard character. For a list of 

such characters, see the 

article MS Access wildcard 

character reference. 

Do not begin with 

the specified string, 

such as U 

Not Like U* Returns records for all 

countries/regions whose names 

start with a character other than 

"U". 

Contain the 

specified string, 

such as Korea 

Like "*Korea*" Returns records for all 

countries/regions that contain the 

string "Korea". 

Do not contain the 

specified string, 

such as Korea 

Not Like 

"*Korea*" 

Returns records for all 

countries/regions that do not 

contain the string "Korea". 

https://support.microsoft.com/en-us/office/access-wildcard-character-reference-af00c501-7972-40ee-8889-e18abaad12d1
https://support.microsoft.com/en-us/office/access-wildcard-character-reference-af00c501-7972-40ee-8889-e18abaad12d1
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End with the 

specified string, 

such as "ina" 

Like "*ina" Returns records for all 

countries/regions whose names 

end in "ina", such as China and 

Argentina. 

Do not end with the 

specified string, 

such as "ina" 

Not Like "*ina" Returns records for all 

countries/regions that do not end 

in "ina", such as China and 

Argentina. 

Contain null (or 

missing) values 

Is Null Returns records where there is no 

value in the field. 

Do not contain null 

values 

Is Not Null Returns records where the value 

is not missing in the field. 

Contain zero-length 

strings 

"" (a pair of 

quotes) 

Returns records where the field is 

set to a blank (but not null) value. 

For example, records of sales 

made to another department 

might contain a blank value in the 

CountryRegion field. 

Do not contain 

zero-length strings 

Not "" Returns records where the 

CountryRegion field has a 

nonblank value. 

Contains null values 

or zero-length 

strings 

"" Or Is Null Returns records where there is 

either no value in the field, or the 

field is set to a blank value. 

Is not empty or 

blank 

Is Not Null And 

Not "" 

Returns records where the 

CountryRegion field has a 

nonblank, non-null value. 

Follow a value, such 

as Mexico, when 

>= "Mexico" Returns records of all 

countries/regions, beginning with 
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sorted in 

alphabetical order 

Mexico and continuing through 

the end of the alphabet. 

Fall within a 

specific range, such 

as A through D 

Like "[A-D]*" Returns records for 

countries/regions whose names 

start with the letters "A" through 

"D". 

Match one of two 

values, such as USA 

or UK 

"USA" Or "UK" Returns records for USA and UK. 

Contain one of the 

values in a list of 

values 

In("France", 

"China", 

"Germany", 

"Japan") 

Returns records for all 

countries/regions specified in the 

list. 

Contain certain 

characters at a 

specific position in 

the field value 

Right([CountryR

egion], 1) = "y" 

Returns records for all 

countries/regions where the last 

letter is "y". 

Satisfy length 

requirements 

Len([CountryReg

ion]) > 10 

Returns records for 

countries/regions whose name is 

more than 10 characters long. 

Match a specific 

pattern 

Like "Chi??" Returns records for 

countries/regions, such as China 

and Chile, whose names are five 

characters long and the first three 

characters are "Chi". 

Note: The characters ? and _, 

when used in an expression, 

represent a single character — 

these are also called wildcard 

characters. The 
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character _ cannot be used in the 

same expression with 

the ? character, nor can it be 

used in an expression with 

the * wildcard character. You may 

use the wildcard character _ in an 

expression that also contains 

the % wildcard character. 

Criteria for Number, Currency, and AutoNumber fields 

The following examples are for the UnitPrice field in a query that is based 

on a table that stores products information. The criterion is specified in 

the Criteria row of the field in the query design grid. 
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To include records 

that... 

Use this 

crit erion 

Query Result 

Exactly match a 

value, such as 100 

100 Returns records where the unit 

price of the product is $100. 

Do not match a 

value, such as 

1000 

Not 1000 Returns records where the unit 

price of the product is not $1000. 

Contain a value 

smaller than a 

value, such as 100 

< 100 

<= 100 

Returns records where the unit 

price is less than $100 (<100). The 

second expression (<=100) 

displays records where the unit 

price is less than or equal to $100. 

Contain a value 

larger than a value, 

such as 99.99 

>99.99 

>=99.99 

Returns records where the unit 

price is greater than $99.99 

(>99.99). The second expression 

displays records where the unit 

price is greater than or equal to 

$99.99. 

Contain one of the 

two values, such as 

20 or 25 

20 or 25 Returns records where the unit 

price is either $20 or $25. 

Contain a value 

that falls with a 

range of values 

>49.99 and 

<99.99 

-or- 

Between 50 

and 100 

Returns records where the unit 

price is between (but not including) 

$49.99 and $99.99. 

Contain a value 

that falls outside a 

range 

<50 or 

>100 

Returns records where the unit 

price is not between $50 and $100. 
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Contain one of 

many specific 

values 

In(20, 25, 

30) 

Returns records where the unit 

price is either $20, $25, or $30. 

Contain a value 

that ends with the 

specified digits 

Like "*4.99" Returns records where the unit 

price ends with "4.99", such as 

$4.99, $14.99, $24.99, and so on. 

Note: The characters * and %, 

when used in an expression, 

represent any number of 

characters — these are also called 

wildcard characters. The 

character % cannot be used in the 

same expression with 

the * character, nor can it be used 

in an expression with the ? wildcard 

character. You may use the 

wildcard character % in an 

expression that also contains 

the _ wildcard character. 

Contain null null 

(or missing) values 

Is Null Returns records where no value is 

entered in the UnitPrice field. 

Contain non-null 

values 

Is Not Null Returns records where the value is 

not missing in the UnitPrice field. 

Criteria for Date/Time fields 

The following examples are for the OrderDate field in a query based on a 

table that stores Orders information. The criterion is specified in 

the Criteria row of the field in the query design grid. 
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To include records 

that ... 

Use this 

criterion 

Query result 

Exactly match a 

value, such as 

2/2/2006 

#2/2/2006# Returns records of 

transactions that took place 

on Feb 2, 2006. Remember 

to surround date values with 

the # character so that MS 

Access can distinguish 

between date values and 

text strings. 

Do not match a 

value, such as 

2/2/2006 

Not #2/2/2006# Returns records of 

transactions that took place 

on a day other than Feb 2, 

2006. 

Contain values that 

fall before a certain 

date, such as 

2/2/2006 

< #2/2/2006# Returns records of 

transactions that took place 

before Feb 2, 2006. 



 

 

 

286 

To view transactions that 

took place on or before this 

date, use the <= operator 

instead of the < operator. 

Contain values that 

fall after a certain 

date, such as 

2/2/2006 

> #2/2/2006# Returns records of 

transactions that took place 

after Feb 2, 2006. 

To view transactions that 

took place on or after this 

date, use the >= operator 

instead of the > operator. 

Contain values that 

fall within a date 

range 

>#2/2/2006# 

and 

<#2/4/2006# 

Returns records where the 

transactions took place 

between Feb 2, 2006 and 

Feb 4, 2006. 

You can also use 

the Between operator to 

filter for a range of values, 

including the end points. For 

example, Between 

#2/2/2006# and 

#2/4/2006# is the same as 

>=#2/2/2006# and 

<=#2/4/2006# . 

Contain values that 

fall outside a range 

<#2/2/2006# or 

>#2/4/2006# 

Returns records where the 

transactions took place 

before Feb 2, 2006 or after 

Feb 4, 2006. 
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Contain one of two 

values, such as 

2/2/2006 or 

2/3/2006 

#2/2/2006# or 

#2/3/2006# 

Returns records of 

transactions that took place 

on either Feb 2, 2006 or Feb 

3, 2006. 

Contain one of 

many values 

In (#2/1/2006#, 

#3/1/2006#, 

#4/1/2006#) 

Returns records where the 

transactions took place on 

Feb 1, 2006, March 1, 2006, 

or April 1, 2006. 

Contain a date that 

falls in a specific 

month 

(irrespective of 

year), such as 

December 

DatePart("m", 

[SalesDate]) = 12 

Returns records where the 

transactions took place in 

December of any year. 

Contain a date that 

falls in a specific 

quarter 

(irrespective of 

year), such as the 

first quarter 

DatePart("q", 

[SalesDate]) = 1 

Returns records where the 

transactions took place in 

the first quarter of any year. 

Contain today's 

date 

Date() Returns records of 

transactions that took place 

on the current day. If 

today's date is 2/2/2006, 

you see records where the 

OrderDate field is set to Feb 

2, 2006. 

Contain 

yesterday's date 

Date()-1 Returns records of 

transactions that took place 

the day before the current 
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day. If today's date is 

2/2/2006, you see records 

for Feb 1, 2006. 

Contain 

tomorrow's date 

Date() + 1 Returns records of 

transactions that took place 

the day after the current 

day. If today's date is 

2/2/2006, you see records 

for Feb 3, 2006. 

Contain dates that 

fall during the 

current week 

DatePart("ww", 

[SalesDate]) = 

DatePart("ww", 

Date()) and Year( 

[SalesDate]) = 

Year(Date()) 

Returns records of 

transactions that took place 

during the current week. A 

week starts on Sunday and 

ends on Saturday. 

Contain dates that 

fell during the 

previous week 

Year([SalesDate])

* 53 + 

DatePart("ww", 

[SalesDate]) = 

Year(Date())* 53 

+ DatePart("ww", 

Date()) - 1 

Returns records of 

transactions that took place 

during the last week. A 

week starts on Sunday and 

ends on Saturday. 

Contain dates that 

fall during the 

following week 

Year([SalesDate])

* 

53+DatePart("ww

", [SalesDate]) = 

Year(Date())* 

53+DatePart("ww

", Date()) + 1 

Returns records of 

transactions that will take 

place next week. A week 

starts on Sunday and ends 

on Saturday. 
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Contain a date that 

fell during the last 

7 days 

Between Date() 

and Date()-6 

Returns records of 

transactions that took place 

during the last 7 days. If 

today's date is 2/2/2006, 

you see records for the 

period Jan 24, 2006 through 

Feb 2, 2006. 

Contain a date that 

belongs to the 

current month 

Year([SalesDate]) 

= Year(Now()) 

And 

Month([SalesDate

]) = 

Month(Now()) 

Returns records for the 

current month. If today's 

date is 2/2/2006, you see 

records for Feb 2006. 

Contain a date that 

belongs to the 

previous month 

Year([SalesDate])

* 12 + 

DatePart("m", 

[SalesDate]) = 

Year(Date())* 12 

+ DatePart("m", 

Date()) - 1 

Returns records for the 

previous month. If today's 

date is 2/2/2006, you see 

records for Jan 2006. 

Contain a date that 

belongs to the next 

month 

Year([SalesDate])

* 12 + 

DatePart("m", 

[SalesDate]) = 

Year(Date())* 12 

+ DatePart("m", 

Date()) + 1 

Returns records for the next 

month. If today's date is 

2/2/2006, you see records 

for Mar 2006. 

Contain a date that 

fell during the last 

30 or 31 days 

Between Date( ) 

And DateAdd("M", 

-1, Date( )) 

A month's worth of sales 

records. If today's date is 

2/2/2006, you see records 
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for the period Jan 2, 2006. 

to Feb 2, 2006 

Contain a date that 

belongs to the 

current quarter 

Year([SalesDate]) 

= Year(Now()) 

And DatePart("q", 

Date()) = 

DatePart("q", 

Now()) 

Returns records for the 

current quarter. If today's 

date is 2/2/2006, you see 

records for the first quarter 

of 2006. 

Contain a date that 

belongs to the 

previous quarter 

Year([SalesDate])

*4+DatePart("q",

[SalesDate]) = 

Year(Date())*4+

DatePart("q",Date

())- 1 

Returns records for the 

previous quarter. If today's 

date is 2/2/2006, you see 

records for the last quarter 

of 2005. 

Contain a date that 

belongs to the next 

quarter 

Year([SalesDate])

*4+DatePart("q",

[SalesDate]) = 

Year(Date())*4+

DatePart("q",Date

())+1 

Returns records for the next 

quarter. If today's date is 

2/2/2006, you see records 

for the second quarter of 

2006. 

Contain a date that 

falls during the 

current year 

Year([SalesDate]) 

= Year(Date()) 

Returns records for the 

current year. If today's date 

is 2/2/2006, you see records 

for the year 2006. 

Contain a date that 

belongs to the 

previous year 

Year([SalesDate]) 

= Year(Date()) - 

1 

Returns records of 

transactions that took place 

during the previous year. If 

today's date is 2/2/2006, 

you see records for the year 

2005. 
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Contain a date that 

belongs to next 

year 

Year([SalesDate]) 

= Year(Date()) + 

1 

Returns records of 

transactions with next year's 

date. If today's date is 

2/2/2006, you see records 

for the year 2007. 

Contain a date that 

falls between Jan 1 

and today (year to 

date records) 

Year([SalesDate]) 

= Year(Date()) 

and 

Month([SalesDate

]) <= 

Month(Date()) 

and 

Day([SalesDate]) 

<= Day (Date()) 

Returns records of 

transactions with dates that 

fall between Jan 1 of the 

current year and today. If 

today's date is 2/2/2006, 

you see records for the 

period Jan 1, 2006 to to 

2/2/2006. 

Contain a date that 

occurred in the 

past 

< Date() Returns records of 

transactions that took place 

before today. 

Contain a date that 

occurrs in the 

future 

> Date() Returns records of 

transactions that will take 

place after today. 

Filter for null (or 

missing) values 

Is Null Returns records where the 

date of transaction is 

missing. 

Filter for non-null 

values 

Is Not Null Returns records where the 

date of transaction is 

known. 
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Criteria for Yes/No fields 

As an example, your Customers table has a Yes/No field named Active, 

used to indicate whether a customer's account is currently active. The 

following table shows how values entered in the Criteria row for a Yes/No 

field are evaluated. 

Field value Result 

Yes, True, 1, or -1 Tested for a Yes value. A value of 1 or 

-1 is converted to "True" in the 

Criteria row after you enter it. 

No, False, or 0 Tested for a No value. A value of 0 is 

converted to "False" in the Criteria 

row after you enter it. 

No value (null) Not tested 

Any number other than 1, -1, 

or 0 

No results if it's the only criteria value 

in the field 

Any character string other 

than Yes, No, True, or False 

Query fails to run due to Data type 

mismatch error 

 

Multivalued fields    Data in a multivalued field are stored as rows in a 

hidden table that MS Access creates and populates to represent the field. 

In query Design view, this is represented in the Field List by using an 

expandable field. To use criteria for a multivalued field, you supply criteria 

for a single row of the hidden table. To do this: 

1. Create a query containing the multivalued field, and open it in Design 

view. 

2. Expand the multivalued field by clicking the plus symbol (+) next to it — 

if the field is already expanded, this is a minus symbol (-). Just below 
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the name of the field, you will see a field representing a single value of 

the multivalued field. This field will have the same name as the 

multivalued field, with the string .Value appended. 

3. Drag the multivalued field and its single value field to separate 

columns in the design grid. If you want to see only the complete 

multivalue field in your results, clear the Show check box for the 

single value field. 

4. Type your criteria in the Criteria row for the single value field, using 

criteria that is appropriate for whatever type of data the values 

represent. 

5. Each value in the multivalued field will be individually evaluated using 

the criteria you supply. For example, you may have a multivalued field 

that stores a list of numbers. If you supply the criteria >5 AND <3, any 

record where there is at least one value greater than 5 and one value 

less than 3 will match. 

 

 

 

 

Introduction to reports in MS Access 

Reports offer a way to view, format, and summarize the information in your 

Microsoft Access database. For example, you can create a simple report of 

phone numbers for all your contacts, or a summary report on the total sales 

across different regions and time periods. 

From this article, you’ll get an overview of reports in MS Access. You’ll also 

learn the basics of creating a report, and using options like sorting, 

 12.6 Report 
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grouping, and summarizing the data, and how to preview and print the 

report. 

Note:  The information in this article is intended for use only with MS 

Access desktop databases. MS Access web apps don't support reports. 

What can you do with a report? 

A report is a database object that comes in handy when you want to 

present the information in your database for any of the following uses: 

▪ Display or distribute a summary of data. 

▪ Archive snapshots of the data. 

▪ Provide details about individual records. 

▪ Create labels. 

Parts of a report 

While it is possible to create “unbound” reports that do not display data, 

but for the purposes of this article, we’ll assume that a report is bound to 

a data source such as a table or query. The design of a report is divided 

into sections that you can view in the Design view. Understanding how each 

section works can helps you create better reports. For example, the section 

in which you choose to place a calculated control determines how MS Access 

calculates the results.  
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The following list is a summary of the section types and their uses: 

Section How the section is 

displayed when 

printed 

Where the section can be used 

Report 

Header 

At the beginning of the 

report. 

Use the report header for information 

that might normally appear on a cover 

page, such as a logo, a title, or a date. 

When you place a calculated control 

that uses the Sum aggregate function 

in the report header, the sum 

calculated is for the entire report. The 

report header is printed before the 

page header. 

Page 

Header 

At the top of every page. Use a page header to repeat the 

report title on every page. 

Group 

Header 

At the beginning of each 

new group of records. 

Use the group header to print the 

group name. For example, in a report 

that is grouped by product, use the 

group header to print the product 

name. When you place a calculated 

control that uses the Sum aggregate 

function in the group header, the 

sum is for the current group. You can 

have multiple group header sections 

on a report, depending on how many 

grouping levels you have added. For 

more information about creating 

group headers and footers, see the 

section Add grouping, sorting, or 

totals. 
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Detail Appears once for every 

row in the record source. 

This is where you place the controls 

that make up the main body of the 

report. 

Group 

Footer 

At the end of each group 

of records. 

Use a group footer to print summary 

information for a group. You can have 

multiple group footer sections on a 

report, depending on how many 

grouping levels you have added. 

Page 

Footer 

At the end of every page. Use a page footer to print page 

numbers or per-page information. 

Report 

Footer 

At the end of the report. 

Note:  In Design view, 

the report footer appears 

below the page footer. 

However, in all other 

views (Layout view, for 

example, or when the 

report is printed or 

previewed), the report 

footer appears above the 

page footer, just after 

the last group footer or 

detail line on the final 

page. 

Use the report footer to print report 

totals or other summary information 

for the entire report. 

You’ll find that it’s much easier to create meaningful reports when your 

database has a well-designed table structure and relationships.  
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Create a report in MS Access 

You can create reports for you MS Access desktop database by following 

the steps below: 

Step 1: Choose a record source 

The record source of a report can be a table, a named query, or an 

embedded query. The record source must contain all of the rows and 

columns of data you want display on the report. 

▪ If the data is from an existing table or query, select the table or query 

in the Navigation Pane, and then continue to Step 2. 

▪ If the record source does not yet exist, do one of the following: 

▪ Continue to Step 2 and use the Blank Report tool, 

Or 

▪ Create the table(s) or query that contains the required data. Select the 

query or table in the Navigation Pane, and then continue to Step 2. 

Step 2: Choose a report tool 

The report tools are located on the Create tab of the ribbon, in 

the Reports group.  
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The following table describes the options: 

Tool Description 

Report Creates a simple, tabular report containing all of the fields 

in the record source you selected in the Navigation Pane. 

Report 

Design 

Opens a blank report in Design view, to which you can add 

the required fields and controls. 

Blank 

Report 

Opens a blank report in Layout view, and displays the Field 

List from where you can add fields to the report 

Report 

Wizard 

Displays a multiple-step wizard that lets you specify fields, 

grouping/sorting levels, and layout options. 

Labels Displays a wizard that lets you select standard or custom 

label sizes, as well as which fields you want to display, and 

how you want them sorted. 

Step 3: Create the report 

1. Click the button for the tool you want to use. If a wizard appears, follow 

the steps in the wizard and click Finish on the last page. 

MS Access displays the report in Layout view. 

2. Format the report to achieve the looks that you want: 

▪ Resize fields and labels by selecting them and then dragging the 

edges until they are the size you want. 

▪ Move a field by selecting it (and its label, if present), and then 

dragging it to the new location. 

▪ Right-click a field and use the commands on the shortcut menu to 

merge or split cells, delete or select fields, and perform other 

formatting tasks. 

In addition, you can use the features described in the following sections to 

make your report more attractive and readable. 
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Add grouping, sorting, or totals 

The fastest way to add grouping, sorting, or totals to a desktop database 

report is to right-click the field to which you want to apply the group, sort, 

or total, and then click the desired command on the shortcut menu. 

You can also add grouping, sorting, or totals by using the Group, Sort, and 

Total pane while the report is open in Layout view or Design view: 

1. If the Group, Sort, and Total pane is not already open, on 

the Design tab, in the Grouping and Totals group, click Group & 

Sort. 

2. Click Add a group or Add a sort, and then select the field on which 

you want to group or sort. 

3. Click More on a grouping or sorting line to set more options and to add 

totals. 

Highlight data with conditional formatting 

MS Access includes tools for highlighting data on a report. You can add 

conditional formatting rules for each control or group of controls, and in 

client reports, you can also add data bars to compare data. 

To add conditional formatting to controls: 

1. Right-click the report in the Navigation Pane and click Layout View. 

2. Select the required controls and on the Format tab, in the Control 

Formatting group, click Conditional Formatting. 

Tip:  To select multiple controls, hold down the CTRL key and click the 

controls. 
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3. In the Conditional Formatting Rules Manager dialog box, click New 

Rule. 

4. In the New Formatting Rule dialog box, select a value under Select a 

rule type: 

▪ To create a rule that is evaluated for each record individually, 

select Check values in the current record or use an expression. 

▪ To create a rule that compares records to each other by using data 

bars, click Compare to other records. 

1. Under Edit the rule description, specify the rule for when the 

formatting would be applied as well as what formatting should be 

applied, and then click OK. 

2. To create an additional rule for the same control or set of controls, repeat 

this procedure from step 4. 

Customizing color and fonts 

Try an App Theme options to customize the color and fonts. 

1. Open a report in Layout view by right-clicking it in the Navigation Pane 

and then clicking Layout View. 

2. From the Report Layout Tools options, on the Design tab, 

click Themes and point the cursor over the various themes in the 

gallery to preview the effects. Click on a theme to select it, and then 

save your report. 

3. Use the Colors or Fonts galleries to set colors or fonts independently. 
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Add a logo or background image 

You can add a logo or background image to a report and If you update the 

image, the update is automatically made wherever the image is used in the 

database. 

To add or remove an image: 

1. In the Navigation Pane, right-click the report and click Layout View. 

2. In the report, click the position where you want to add the image and 

on the Design tab, in the Header/Footer group, click Logo. 

3. Navigate to the image, and click Open. MS Access adds the image to 

the report. 

4. To remove the image, right-click the image and click Delete from the 

shortcut menu. 

To add a background image: 

1. In the Navigation Pane, right-click the report and click Layout View. 

2. On the Format tab, in the Background group, click Background 

Image. 

3. Select an image from the Image Gallery list or click Browse, select an 

image, and then click OK. 

Preview and print a report 

Preview a report 

1. Right-click the report in the Navigation Pane and click Print Preview. 

You can use the commands on the Print Preview tab to do any of the 

following: 

▪ Print the report 
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▪ Adjust page size or layout 

▪ Zoom in or out, or view multiple pages at a time 

▪ Refresh the data on the report 

▪ Export the report to another file format. 

2. Click Close Print Preview. 

Print a report 

To print a report without previewing it: 

▪ Right-click the report in the Navigation Pane and click Print. The report 

is sent to your default printer. 

Note:  If you select the report in the Navigation Pane and 

select Print from the File tab, you can select additional printing options 

such as number of pages and copies and specify a printer. 

▪ To open a dialog box where you can select a printer, specify the number 

of copies, and so on, click Print. 

 Change the page settings 

1. Open the report in Print Preview. You can change page settings in any 

view, but Print Preview is best because you can see the effects of any 

changes immediately. 

2. On the Print Preview tab, in the Page Layout and Page Size groups, 

click Portrait  or Landscape  to set the page 

orientation, Size  to set the paper size, Margins  to adjust the 

margins, and so on. 

3. After you make a change, use the navigation buttons to view several 

pages to ensure that you haven't created any formatting problems on 

later pages. 
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Send your report to a printer 

1. Open the report in any view, or select the report in the Navigation Pane. 

2. Click File > Print > Print.  

MS Access displays the Print dialog box. 

3. Enter your choices for options such as printer, print range, and number 

of copies. 

4. Click OK. 

Send your report as an e-mail message 

You can send your report to recipients as an e-mail message instead of 

printing a paper copy: 

1. In the Navigation Pane, click the report to select it. On the External 

Data tab, in the Export group, click Email.  

2. In the Send Object As dialog box, in the Select Output Format list, 

click the file format that you want to use. 

3. Complete any remaining dialog boxes. 

4. In your e-mail application, type the message details and send the 

message. 

Decide which data to put in each report section 

Each report has one or more report sections. The one section that is present 

in every report is the Detail section. This section repeats once for each 

record in the table or query that the report is based on. Other sections are 

optional and repeat less often and are usually used to display information 

that is common to a group of records, a page of the report, or the entire 

report. 
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The following table describes where each section is located and how the 

section is typically used. 

Section Location Typical contents 

Report 

header 

section 

Appears only once, at the top of 

the first page of the report. 

▪ Report title 

▪ Logo 

▪ Current date 

Report 

footer 

section 

Appears after the last line of 

data, above the Page Footer 

section on the last page of the 

report. 

Report totals 

(sums, counts, 

averages, and so 

on) 

Page header 

section 

Appears at the top of each page 

of the report. 

▪ Report title 

▪ Page number 

Page footer 

section 

Appears at the bottom of each 

page of the report. 

▪ Current date 

▪ Page number 

Group 

header 

section 

Appears just preceding of a 

group of records. 

The field that is 

being grouped on 

Group footer 

section 

Appears just after a group of 

records. 

Group totals 

(sums, counts, 

averages, and so 

on) 

Decide how to arrange the detail data 

Most reports are arranged in either a tabular or a stacked layout, but MS 

Access gives you the flexibility to use just about any arrangement of 

records and fields that you want. 
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Tabular layout    A tabular layout is similar to a spreadsheet. Labels are 

across the top, and the data is aligned in columns below the labels. Tabular 

refers to the table-like appearance of the data. This is the type of report 

that MS Access creates when you click Report in the Reports group of 

the Create tab. The tabular layout is a good one to use if your report has 

a relatively small number of fields that you want to display in a simple list 

format. The following illustration shows an employee report that was 

created by using a tabular layout. 

 

Stacked layout    A stacked layout resembles a form that you fill out when 

you open a bank account or make a purchase from an online retailer. Each 

piece of data is labeled, and the fields are stacked on top of each other. 

This layout is good for reports that contain too many fields to display in a 

tabular format — that is, the width of the columns would exceed the width 

of the report. The following illustration shows an employee report that was 

created by using a stacked layout. 
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Note: In the Report Wizard, this layout is referred to as a columnar layout. 

Mixed layout    You can mix elements of tabular and stacked layouts. For 

example, for each record, you can arrange some of the fields in a horizontal 

row at the top of the Detail section and arrange other fields from the same 

record in one or more stacked layouts beneath the top row. The following 

illustration shows an employee report that was created by using a mixed 

layout. The ID, Last Name, and First Name fields are arranged in a tabular 

control layout, and the Job Title and Business Phone fields are arranged in 

a stacked layout. In this example, gridlines are used to provide a visual 

separation of fields for each employee. 
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Justified layout    If you use the Report Wizard to create your report, you 

can choose to use a justified layout. This layout uses the full width of the 

page to display the records as compactly as possible. Of course, you can 

achieve the same results without using the Report Wizard, but it can be a 

painstaking process to align the fields exactly. The following illustration 

shows an employee report that was created by using the Report Wizard's 

justified layout. 
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The justified layout is a good layout to use if you are displaying a large 

number of fields on the report. In the preceding example, if you use a 

tabular layout to display the same data, the fields extend off the edge of 

the page. If you use a stacked layout, each record takes up much more 

vertical space, which wastes paper and makes the report more difficult to 

read. 

Use control layouts to align your data 

Control layouts are guides that you can add to a report while it is open in 

Layout view or Design view. MS Access adds control layouts automatically 

when you use the Report Wizard to build a report, or when you create a 

report by clicking Report in the Reports group of the Create tab. A 

control layout is like a table, each cell of which can contain a label, a text 

box, or any other type of control. The following illustration shows a tabular 

control layout on a report. 
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The orange lines indicate the rows and columns of the control layout, and 

they are visible only when the report is open in Layout view or Design view. 

Control layouts help you achieve a uniform alignment of data in rows and 

columns, and they make it easier to add, resize, or remove fields. By using 

the tools in the Table and Position groups on the Arrange tab (available 

in Layout view or Design view), you can change one type of control layout 

to another, and you can remove controls from layouts so that you can 

position the controls wherever you want on the report. 

Add or remove report or page header and footer sections 

As mentioned earlier in this article, headers and footers are report sections 

that you can use to display information that is common to the entire report, 

or to each page of a report. For example, you can add a Page Footer section 

to display a page number at the bottom of each page, or you can add a 

Report Header section to display a title for the entire report. 
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Add report or page header and footer sections 

1. In the Navigation Pane, right-click the report that you want to change, 

and then click Design View on the shortcut menu. 

2. Verify which sections are already on the report. The sections are 

separated by shaded horizontal bars called section selectors. The label 

on each section selector indicates what the section directly below it is. 

 

Every report has a Detail section and can also contain Report Header, 

Page Header, Page Footer, and Report Footer sections. In addition, if 

there are grouping levels in the report, you might see group headers or 

footers (such as the File As Header shown in the preceding 

illustration). By default, group headers and footers are named by using 

the field name or expression that is the basis of the group. In this case, 

the name of the grouping field is "File As." 

3. To add page header and footer sections or report header and footer 

sections to your report, right-click any section selector and then 

click Page Header/Footer or Report Header/Footer on the shortcut 

menu. 
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Caution: If the section is already present on the report, MS Access 

warns you that it will delete the existing section and the controls it 

contains. 

You can now move existing controls or add new controls to the new 

sections. 

MS Access always adds page and report header and footer sections in pairs. 

That is, you cannot add a page or report header section without also adding 

the corresponding footer section. If you do not need both sections, you 

cannot delete a section, but you can resize the unused section to a height 

of zero (0) to avoid adding extra vertical spacing to your report. Position 

the pointer at the bottom of the unused section until it turns into a double-

headed arrow , and then drag upward until the section is hidden. If there 

are any controls in the section, you must delete them before you can fully 

hide the section. 

Remove report or page header and footer sections 

1. In the Navigation Pane, right-click the report that you want to change, 

and then click Design View on the shortcut menu. 

2. Right-click any section selector and then click Page 

Header/Footer or Report Header/Footer on the shortcut menu. 

If you are removing a header and footer pair and those sections contain 

controls, MS Access warns you that deleting the sections will also delete 

the controls and that you will not be able to undo the action. Click Yes to 

remove the sections and delete the controls, or click No to cancel the 

operation. 
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Tips for formatting different data types 

When you create a report by using the Report tool (available on 

the Create tab, in the Reports group), or by using the Report Wizard, MS 

Access adds the fields to the report for you and creates the most 

appropriate control to display each field, based on the field's data type. If 

you are adding fields to a report yourself, the preferred method is to drag 

each field from the Field List to the report. As with the Report Wizard or 

the Report tool, MS Access creates the most appropriate control for each 

field, depending on the field's data type. For most data types, the most 

appropriate (default) control to use is the text box. 

The following sections provide tips about how to format some of the special 

case data types. 

Multivalued fields    The default control for a multivalued field is a combo 

box. This can seem like a strange choice for a control on a report, because 

you can't click the arrow on a combo box in a report. However, in the 

context of a report, a combo box behaves like a text box. The arrow is 

visible only in Design view. 

If the field contains multiple values, those values are separated by commas. 

If the combo box is not wide enough to display all the values on one line 

and the CanGrow property of the combo box is set to Yes, the values wrap 

to the next line. Otherwise, the values are truncated. To set 

the CanGrow property for a control, open the report in Design view or 

Layout view, click the control, and then press F4 to display the control's 

property sheet. The CanGrow property is located on both the Format tab 

and the All tab of the property sheet for the control. 

Rich text fields    The default control for a rich text field is a text box. If 

the text box is not wide enough to display all the values on one line and 

the CanGrow property of the text box is set to Yes, the values wrap to the 
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next line. Otherwise, the values are truncated. To set 

the CanGrow property for a control, open the report in Design view or 

Layout view, click the control, and then press F4 to display the control's 

property sheet. The CanGrow property is located on both the Format tab 

and the All tab of the property sheet for the control. 

A rich text field helps you to format text in a variety of ways. For example, 

several words in a field can be underlined, and several other words in the 

same field can be in italic. You can, however, still set an overall formatting 

style for the text box that contains the rich text. The text box formatting 

applies only to the text that has not been specifically formatted by using 

rich text formatting. 

Set formatting styles for a text box that displays a rich text field 

1. Right-click the report in the Navigation Pane, and then click Layout 

View on the shortcut menu. 

2. Click the text box that displays the rich text field, and then, on 

the Format tab, in the Font group, click the formatting style that you 

want to apply. 

MS Access applies the formatting to all text in the rich text field that has 

not already had that type (but not value) of formatting applied in a view 

that supports data entry, such as Datasheet view for a table or query, 

or Form view for a form. For example, if a portion of the text in the field 

is formatted with a red font color, and you apply a blue font color to the 

text box, MS Access turns all of the text blue except for that which was 

individually formatted as red. As another example, if a portion of the 

text in the field is formatted with an 11-point font size, and you apply a 

14-point font size to the text box, MS Access applies the 14-point font 
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size to all of the text except for that which was individually formatted at 

11 points. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Instructions: Find the true statement below. Then, rewrite the 
remaining false statements so they are true. 

1. An Access database can have a maximum of one table 

2. Datasheet View is used to precisely determine the characteristics of 

each field 

3. You cannot modify the size of a field in Design View 

4. Tables are composed of records 

• Microsoft Access is a software to manage database 

• It comprise of table, queries, report and form 

SUMMARY 

 

 

 

 

                                    
Explain a database that you usually use. How many fields that it has. 

What is the key for the table 

 
 ACTIVITY 

Checkpoint 12 
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 KEY TERM 

Table Report 

Field Primary Key 

Form Query 
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